Rebase to FSF GDB 7.5.91.20130407 (pre-7.6 snapshot).
- [SCL] Remove BuildRequires of gcc-go on SCL (Miroslav Franc, BZ 948982). - Provide man page for gdbinit.5 (BZ 881892), document gdb -p in man (BZ 659000).
This commit is contained in:
parent
402506cde5
commit
ac3dde5b9b
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
/gdb-libstdc++-v3-python-r155978.tar.bz2
|
/gdb-libstdc++-v3-python-r155978.tar.bz2
|
||||||
/gdb-7.5.91.20130402.tar.bz2
|
/gdb-7.5.91.20130407.tar.bz2
|
||||||
|
@ -40,13 +40,13 @@ Subject: [PATCH 4/4] add gdb-add-index
|
|||||||
5 files changed, 57 insertions(+), 1 deletions(-)
|
5 files changed, 57 insertions(+), 1 deletions(-)
|
||||||
create mode 100755 gdb/gdb-add-index
|
create mode 100755 gdb/gdb-add-index
|
||||||
|
|
||||||
Index: gdb-7.4.50.20120103/gdb/Makefile.in
|
Index: gdb-7.5.91.20130407/gdb/Makefile.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.4.50.20120103.orig/gdb/Makefile.in 2012-01-03 05:53:25.000000000 +0100
|
--- gdb-7.5.91.20130407.orig/gdb/Makefile.in 2013-04-07 07:45:37.000000000 +0200
|
||||||
+++ gdb-7.4.50.20120103/gdb/Makefile.in 2012-01-03 15:24:25.693543435 +0100
|
+++ gdb-7.5.91.20130407/gdb/Makefile.in 2013-04-07 07:46:22.986226811 +0200
|
||||||
@@ -1033,7 +1033,16 @@ install-only: install-gstack $(CONFIG_IN
|
@@ -1038,7 +1038,16 @@ install-only: install-gstack $(CONFIG_IN
|
||||||
$(INSTALL_DATA) $(srcdir)/gdb.1 \
|
$(INSTALL_PROGRAM) gdb$(EXEEXT) \
|
||||||
$(DESTDIR)$(man1dir)/$$transformed_name.1 ; \
|
$(DESTDIR)$(bindir)/$$transformed_name$(EXEEXT) ; \
|
||||||
$(SHELL) $(srcdir)/../mkinstalldirs $(DESTDIR)$(includedir)/gdb ; \
|
$(SHELL) $(srcdir)/../mkinstalldirs $(DESTDIR)$(includedir)/gdb ; \
|
||||||
- $(INSTALL_DATA) jit-reader.h $(DESTDIR)$(includedir)/gdb/jit-reader.h
|
- $(INSTALL_DATA) jit-reader.h $(DESTDIR)$(includedir)/gdb/jit-reader.h
|
||||||
+ $(INSTALL_DATA) jit-reader.h $(DESTDIR)$(includedir)/gdb/jit-reader.h; \
|
+ $(INSTALL_DATA) jit-reader.h $(DESTDIR)$(includedir)/gdb/jit-reader.h; \
|
||||||
@ -62,11 +62,11 @@ Index: gdb-7.4.50.20120103/gdb/Makefile.in
|
|||||||
@$(MAKE) DO=install "DODIRS=$(SUBDIRS)" $(FLAGS_TO_PASS) subdir_do
|
@$(MAKE) DO=install "DODIRS=$(SUBDIRS)" $(FLAGS_TO_PASS) subdir_do
|
||||||
|
|
||||||
install-python:
|
install-python:
|
||||||
Index: gdb-7.4.50.20120103/gdb/doc/gdb.texinfo
|
Index: gdb-7.5.91.20130407/gdb/doc/gdb.texinfo
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.4.50.20120103.orig/gdb/doc/gdb.texinfo 2012-01-03 15:20:54.000000000 +0100
|
--- gdb-7.5.91.20130407.orig/gdb/doc/gdb.texinfo 2013-04-07 07:45:38.000000000 +0200
|
||||||
+++ gdb-7.4.50.20120103/gdb/doc/gdb.texinfo 2012-01-03 15:23:43.295231946 +0100
|
+++ gdb-7.5.91.20130407/gdb/doc/gdb.texinfo 2013-04-07 07:45:43.458236312 +0200
|
||||||
@@ -16228,6 +16228,14 @@ There are currently some limitation on i
|
@@ -17159,6 +17159,14 @@ There are currently some limitation on i
|
||||||
for DWARF debugging information, not stabs. And, they do not
|
for DWARF debugging information, not stabs. And, they do not
|
||||||
currently work for programs using Ada.
|
currently work for programs using Ada.
|
||||||
|
|
||||||
@ -81,10 +81,10 @@ Index: gdb-7.4.50.20120103/gdb/doc/gdb.texinfo
|
|||||||
@node Symbol Errors
|
@node Symbol Errors
|
||||||
@section Errors Reading Symbol Files
|
@section Errors Reading Symbol Files
|
||||||
|
|
||||||
Index: gdb-7.4.50.20120103/gdb/gdb-add-index
|
Index: gdb-7.5.91.20130407/gdb/gdb-add-index
|
||||||
===================================================================
|
===================================================================
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
+++ gdb-7.4.50.20120103/gdb/gdb-add-index 2012-01-03 15:23:43.296231942 +0100
|
+++ gdb-7.5.91.20130407/gdb/gdb-add-index 2013-04-07 07:45:43.462236311 +0200
|
||||||
@@ -0,0 +1,30 @@
|
@@ -0,0 +1,30 @@
|
||||||
+#! /bin/sh
|
+#! /bin/sh
|
||||||
+
|
+
|
||||||
|
1201
gdb-upstream.patch
Normal file
1201
gdb-upstream.patch
Normal file
File diff suppressed because it is too large
Load Diff
18
gdb.spec
18
gdb.spec
@ -27,14 +27,14 @@
|
|||||||
Summary: A GNU source-level debugger for C, C++, Fortran, Go and other languages
|
Summary: A GNU source-level debugger for C, C++, Fortran, Go and other languages
|
||||||
Name: %{?scl_prefix}gdb
|
Name: %{?scl_prefix}gdb
|
||||||
|
|
||||||
%global snap 20130402
|
%global snap 20130407
|
||||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||||
%global snapgnulib 20121213
|
%global snapgnulib 20121213
|
||||||
Version: 7.5.91.%{snap}
|
Version: 7.5.91.%{snap}
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 15%{?dist}
|
Release: 16%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -261,7 +261,7 @@ Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
|||||||
|
|
||||||
# Backported fixups post the source tarball.
|
# Backported fixups post the source tarball.
|
||||||
#Xdrop: Just backports.
|
#Xdrop: Just backports.
|
||||||
#Patch232: gdb-upstream.patch
|
Patch232: gdb-upstream.patch
|
||||||
|
|
||||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||||
#=fedoratest+ppc
|
#=fedoratest+ppc
|
||||||
@ -620,7 +620,7 @@ ExclusiveArch: noarch i386 x86_64 ppc ppc64 ia64 s390 s390x
|
|||||||
BuildRequires: sharutils dejagnu
|
BuildRequires: sharutils dejagnu
|
||||||
# gcc-objc++ is not covered by the GDB testsuite.
|
# gcc-objc++ is not covered by the GDB testsuite.
|
||||||
BuildRequires: gcc gcc-c++ gcc-gfortran gcc-java gcc-objc
|
BuildRequires: gcc gcc-c++ gcc-gfortran gcc-java gcc-objc
|
||||||
%if 0%{!?rhel:1} || 0%{?scl:1} || 0%{?rhel} > 6
|
%if 0%{!?rhel:1} || 0%{?rhel} > 6
|
||||||
BuildRequires: gcc-go
|
BuildRequires: gcc-go
|
||||||
%endif
|
%endif
|
||||||
# archer-sergiodj-stap-patch-split
|
# archer-sergiodj-stap-patch-split
|
||||||
@ -651,7 +651,7 @@ BuildRequires: libgcc%{bits_local} libgcc%{bits_other}
|
|||||||
# libstdc++-devel of matching bits is required only for g++ -static.
|
# libstdc++-devel of matching bits is required only for g++ -static.
|
||||||
BuildRequires: libstdc++%{bits_local} libstdc++%{bits_other}
|
BuildRequires: libstdc++%{bits_local} libstdc++%{bits_other}
|
||||||
BuildRequires: libgcj%{bits_local} libgcj%{bits_other}
|
BuildRequires: libgcj%{bits_local} libgcj%{bits_other}
|
||||||
%if 0%{!?rhel:1} || 0%{?scl:1} || 0%{?rhel} > 6
|
%if 0%{!?rhel:1} || 0%{?rhel} > 6
|
||||||
BuildRequires: libgo-devel%{bits_local} libgo-devel%{bits_other}
|
BuildRequires: libgo-devel%{bits_local} libgo-devel%{bits_other}
|
||||||
%endif
|
%endif
|
||||||
%if 0%{!?el5:1}
|
%if 0%{!?el5:1}
|
||||||
@ -758,7 +758,7 @@ find -name "*.info*"|xargs rm -f
|
|||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
|
||||||
%patch349 -p1
|
%patch349 -p1
|
||||||
#patch232 -p1
|
%patch232 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
|
|
||||||
@ -1307,6 +1307,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_bindir}/gdb
|
%{_bindir}/gdb
|
||||||
%config(noreplace) %{_sysconfdir}/gdbinit
|
%config(noreplace) %{_sysconfdir}/gdbinit
|
||||||
%{_sysconfdir}/gdbinit.d
|
%{_sysconfdir}/gdbinit.d
|
||||||
|
%{_mandir}/*/gdbinit.5*
|
||||||
%{_mandir}/*/gdb.1*
|
%{_mandir}/*/gdb.1*
|
||||||
%{_bindir}/gstack
|
%{_bindir}/gstack
|
||||||
%{_mandir}/*/gstack.1*
|
%{_mandir}/*/gstack.1*
|
||||||
@ -1370,6 +1371,11 @@ fi
|
|||||||
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Apr 7 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.5.91.20130407-16.fc19
|
||||||
|
- Rebase to FSF GDB 7.5.91.20130407 (pre-7.6 snapshot).
|
||||||
|
- [SCL] Remove BuildRequires of gcc-go on SCL (Miroslav Franc, BZ 948982).
|
||||||
|
- Provide man page for gdbinit.5 (BZ 881892), document gdb -p in man (BZ 659000).
|
||||||
|
|
||||||
* Tue Apr 2 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.5.91.20130402-15.fc19
|
* Tue Apr 2 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.5.91.20130402-15.fc19
|
||||||
- Rebase to FSF GDB 7.5.91.20130402 (pre-7.6 snapshot).
|
- Rebase to FSF GDB 7.5.91.20130402 (pre-7.6 snapshot).
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
4981307aa9619bbec5b73261e4e41c8d gdb-libstdc++-v3-python-r155978.tar.bz2
|
4981307aa9619bbec5b73261e4e41c8d gdb-libstdc++-v3-python-r155978.tar.bz2
|
||||||
73940913cbddd402477ed4aeefc5144f gdb-7.5.91.20130402.tar.bz2
|
b416c7aabe1d922b8da0c435f6e02ce6 gdb-7.5.91.20130407.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user