ac3dde5b9b
- [SCL] Remove BuildRequires of gcc-go on SCL (Miroslav Franc, BZ 948982). - Provide man page for gdbinit.5 (BZ 881892), document gdb -p in man (BZ 659000).
119 lines
4.3 KiB
Diff
119 lines
4.3 KiB
Diff
http://sourceware.org/ml/gdb-patches/2010-07/msg00184.html
|
|
Subject: Re: [0/4] RFC: add DWARF index support
|
|
|
|
Jan Kratochvil: Fixed $d -> $dir.
|
|
Jan Kratochvil: Remove /dev/null redirection.
|
|
|
|
>>>>> "Tom" == Tom Tromey <tromey@redhat.com> writes:
|
|
|
|
Tom> This patch series adds support for a DWARF index to gdb.
|
|
|
|
Roland suggested we wrap up the index-creation code into a helper
|
|
script.
|
|
|
|
I'm not sure if this is something people would want in gdb proper, but I
|
|
figured I would send it here just in case.
|
|
|
|
Tom
|
|
|
|
2010-07-09 Tom Tromey <tromey@redhat.com>
|
|
|
|
* Makefile.in (install-only): Install gdb-add-index.
|
|
* gdb-add-index: New file.
|
|
|
|
2010-07-09 Tom Tromey <tromey@redhat.com>
|
|
|
|
* gdb.texinfo (Index Files): Mention gdb-add-index.
|
|
|
|
>From 30714fe719e61baea03d0dc5793eb0d564faebb7 Mon Sep 17 00:00:00 2001
|
|
From: Tom Tromey <tromey@redhat.com>
|
|
Date: Fri, 9 Jul 2010 11:17:54 -0600
|
|
Subject: [PATCH 4/4] add gdb-add-index
|
|
Subject: [PATCH 4/4] add gdb-add-index
|
|
|
|
---
|
|
gdb/ChangeLog | 5 +++++
|
|
gdb/Makefile.in | 11 ++++++++++-
|
|
gdb/doc/ChangeLog | 4 ++++
|
|
gdb/doc/gdb.texinfo | 8 ++++++++
|
|
gdb/gdb-add-index | 30 ++++++++++++++++++++++++++++++
|
|
5 files changed, 57 insertions(+), 1 deletions(-)
|
|
create mode 100755 gdb/gdb-add-index
|
|
|
|
Index: gdb-7.5.91.20130407/gdb/Makefile.in
|
|
===================================================================
|
|
--- gdb-7.5.91.20130407.orig/gdb/Makefile.in 2013-04-07 07:45:37.000000000 +0200
|
|
+++ gdb-7.5.91.20130407/gdb/Makefile.in 2013-04-07 07:46:22.986226811 +0200
|
|
@@ -1038,7 +1038,16 @@ install-only: install-gstack $(CONFIG_IN
|
|
$(INSTALL_PROGRAM) gdb$(EXEEXT) \
|
|
$(DESTDIR)$(bindir)/$$transformed_name$(EXEEXT) ; \
|
|
$(SHELL) $(srcdir)/../mkinstalldirs $(DESTDIR)$(includedir)/gdb ; \
|
|
- $(INSTALL_DATA) jit-reader.h $(DESTDIR)$(includedir)/gdb/jit-reader.h
|
|
+ $(INSTALL_DATA) jit-reader.h $(DESTDIR)$(includedir)/gdb/jit-reader.h; \
|
|
+ transformed_name=`t='$(program_transform_name)'; \
|
|
+ echo gdb-add-index | sed -e "$$t"` ; \
|
|
+ if test "x$$transformed_name" = x; then \
|
|
+ transformed_name=gdb-add-index ; \
|
|
+ else \
|
|
+ true ; \
|
|
+ fi ; \
|
|
+ $(INSTALL_PROGRAM) $(srcdir)/gdb-add-index \
|
|
+ $(DESTDIR)$(bindir)/$$transformed_name$(EXEEXT)
|
|
@$(MAKE) DO=install "DODIRS=$(SUBDIRS)" $(FLAGS_TO_PASS) subdir_do
|
|
|
|
install-python:
|
|
Index: gdb-7.5.91.20130407/gdb/doc/gdb.texinfo
|
|
===================================================================
|
|
--- gdb-7.5.91.20130407.orig/gdb/doc/gdb.texinfo 2013-04-07 07:45:38.000000000 +0200
|
|
+++ gdb-7.5.91.20130407/gdb/doc/gdb.texinfo 2013-04-07 07:45:43.458236312 +0200
|
|
@@ -17159,6 +17159,14 @@ There are currently some limitation on i
|
|
for DWARF debugging information, not stabs. And, they do not
|
|
currently work for programs using Ada.
|
|
|
|
+@value{GDBN} comes with a program, @command{gdb-add-index}, which can
|
|
+be used to add the index to a symbol file. It takes the symbol file
|
|
+as its only argument:
|
|
+
|
|
+@smallexample
|
|
+$ gdb-add-index symfile
|
|
+@end smallexample
|
|
+
|
|
@node Symbol Errors
|
|
@section Errors Reading Symbol Files
|
|
|
|
Index: gdb-7.5.91.20130407/gdb/gdb-add-index
|
|
===================================================================
|
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
+++ gdb-7.5.91.20130407/gdb/gdb-add-index 2013-04-07 07:45:43.462236311 +0200
|
|
@@ -0,0 +1,30 @@
|
|
+#! /bin/sh
|
|
+
|
|
+# Add a .gdb_index section to a file.
|
|
+
|
|
+# Copyright (C) 2010 Free Software Foundation, Inc.
|
|
+# This program is free software; you can redistribute it and/or modify
|
|
+# it under the terms of the GNU General Public License as published by
|
|
+# the Free Software Foundation; either version 3 of the License, or
|
|
+# (at your option) any later version.
|
|
+#
|
|
+# This program is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+# GNU General Public License for more details.
|
|
+#
|
|
+# You should have received a copy of the GNU General Public License
|
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
+
|
|
+file="$1"
|
|
+dir="${file%/*}"
|
|
+
|
|
+# We don't care if gdb gives an error.
|
|
+gdb -nx --batch-silent -ex "file $file" -ex "save gdb-index $dir"
|
|
+
|
|
+if test -f "${file}.gdb-index"; then
|
|
+ objcopy --add-section .gdb_index="${file}.gdb-index" --set-section-flags .gdb_index=readonly "$file" "$file"
|
|
+ rm -f "${file}.gdb-index"
|
|
+fi
|
|
+
|
|
+exit 0
|