- Drop gdb-6.8-glibc-headers-compat.patch: GNU/Linux irrelevant (Tom Tromey).
- Drop gdb-6.3-terminal-fix-20050214.patch: The bug is not reproducible. - Drop gdb-6.7-kernel-headers-compat.patch: kernel-headers seem to be fixed. - Drop gdb-archer-ada.patch: No longer needed for Ada (Keith Seitz). - New PR backtrace/12237, drop gdb-6.3-framepczero-20040927.patch gdb-6.3-bt-past-zero-20051201.patch as they already had no effect. - Drop gdb-6.8-gcc35998-ada-memory-trash.patch as a different fix is upstream. - Drop gdb-6.3-inheritance-20050324.patch: the call is redundent (Tom Tromey).
This commit is contained in:
parent
41aeaf682d
commit
ac0fd38455
@ -1,26 +0,0 @@
|
||||
2005-03-24 Jeff Johnston <jjohnstn@redhat.com>
|
||||
|
||||
* valops.c (check_field_in): Use check_typedef for base classes
|
||||
to avoid problems with opaque type references.
|
||||
|
||||
Index: gdb-6.8.50.20081128/gdb/valops.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20081128.orig/gdb/valops.c 2008-12-08 10:56:11.000000000 +0100
|
||||
+++ gdb-6.8.50.20081128/gdb/valops.c 2008-12-08 10:59:14.000000000 +0100
|
||||
@@ -2484,8 +2484,14 @@ check_field (struct type *type, const ch
|
||||
}
|
||||
|
||||
for (i = TYPE_N_BASECLASSES (type) - 1; i >= 0; i--)
|
||||
- if (check_field (TYPE_BASECLASS (type, i), name))
|
||||
- return 1;
|
||||
+ {
|
||||
+ /* Check the base classes. Make sure we have the real type for
|
||||
+ each base class as opposed to an opaque declaration. */
|
||||
+ struct type *baseclass = check_typedef (TYPE_BASECLASS (type, i));
|
||||
+
|
||||
+ if (check_field (baseclass, name))
|
||||
+ return 1;
|
||||
+ }
|
||||
|
||||
return 0;
|
||||
}
|
6
gdb.spec
6
gdb.spec
@ -159,10 +159,6 @@ Patch259: gdb-6.3-step-thread-exit-20050211-test.patch
|
||||
#=fedoratest
|
||||
Patch145: gdb-6.3-threaded-watchpoints2-20050225.patch
|
||||
|
||||
# Fix printing of inherited members
|
||||
#=maybepush
|
||||
Patch148: gdb-6.3-inheritance-20050324.patch
|
||||
|
||||
# Do not issue warning message about first page of storage for ia64 gcore
|
||||
#=ia64
|
||||
Patch153: gdb-6.3-ia64-gcore-page0-20050421.patch
|
||||
@ -683,7 +679,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch141 -p1
|
||||
%patch259 -p1
|
||||
%patch145 -p1
|
||||
%patch148 -p1
|
||||
%patch153 -p1
|
||||
%patch157 -p1
|
||||
%patch158 -p1
|
||||
@ -1155,6 +1150,7 @@ fi
|
||||
- New PR backtrace/12237, drop gdb-6.3-framepczero-20040927.patch
|
||||
gdb-6.3-bt-past-zero-20051201.patch as they already had no effect.
|
||||
- Drop gdb-6.8-gcc35998-ada-memory-trash.patch as a different fix is upstream.
|
||||
- Drop gdb-6.3-inheritance-20050324.patch: the call is redundent (Tom Tromey).
|
||||
|
||||
* Thu Nov 18 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20101117-1.fc15
|
||||
- Rebase to FSF GDB 7.2.50.20101117 (which is a 7.3 pre-release).
|
||||
|
Loading…
Reference in New Issue
Block a user