- Drop gdb-6.8-glibc-headers-compat.patch: GNU/Linux irrelevant (Tom Tromey).
- Drop gdb-6.3-terminal-fix-20050214.patch: The bug is not reproducible. - Drop gdb-6.7-kernel-headers-compat.patch: kernel-headers seem to be fixed. - Drop gdb-archer-ada.patch: No longer needed for Ada (Keith Seitz). - New PR backtrace/12237, drop gdb-6.3-framepczero-20040927.patch gdb-6.3-bt-past-zero-20051201.patch as they already had no effect. - Drop gdb-6.8-gcc35998-ada-memory-trash.patch as a different fix is upstream.
This commit is contained in:
parent
4546826203
commit
41aeaf682d
@ -1,21 +0,0 @@
|
||||
[patch] Workaround ada (gnat-4.3.0) on x86_64
|
||||
http://sourceware.org/ml/gdb-patches/2008-04/msg00427.html
|
||||
|
||||
--- ./gdb/dwarf2read.c 4 May 2008 17:27:01 -0000 1.260
|
||||
+++ ./gdb/dwarf2read.c 4 May 2008 18:26:20 -0000
|
||||
@@ -6754,7 +6754,14 @@ dwarf2_attr (struct die_info *die, unsig
|
||||
for (i = 0; i < die->num_attrs; ++i)
|
||||
{
|
||||
if (die->attrs[i].name == name)
|
||||
- return &die->attrs[i];
|
||||
+ {
|
||||
+ /* GCC PR ada/35998 workaround. */
|
||||
+ if (name == DW_AT_byte_size
|
||||
+ && DW_UNSND (&die->attrs[i]) == 0xffffffff)
|
||||
+ return NULL;
|
||||
+
|
||||
+ return &die->attrs[i];
|
||||
+ }
|
||||
if (die->attrs[i].name == DW_AT_specification
|
||||
|| die->attrs[i].name == DW_AT_abstract_origin)
|
||||
spec = &die->attrs[i];
|
6
gdb.spec
6
gdb.spec
@ -374,10 +374,6 @@ Patch315: gdb-6.8-bz442765-threaded-exec-test.patch
|
||||
#=push: But it is just a GCC workaround, look up the existing GCC PR for it.
|
||||
Patch317: gdb-6.8-sparc64-silence-memcpy-check.patch
|
||||
|
||||
# Fix memory trashing on binaries from GCC Ada (workaround GCC PR 35998).
|
||||
#=push
|
||||
Patch318: gdb-6.8-gcc35998-ada-memory-trash.patch
|
||||
|
||||
# Test a crash on libraries missing the .text section.
|
||||
#=fedoratest
|
||||
Patch320: gdb-6.5-section-num-fixup-test.patch
|
||||
@ -740,7 +736,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch311 -p1
|
||||
%patch315 -p1
|
||||
%patch317 -p1
|
||||
%patch318 -p1
|
||||
%patch320 -p1
|
||||
%patch326 -p1
|
||||
%patch329 -p1
|
||||
@ -1159,6 +1154,7 @@ fi
|
||||
- Drop gdb-archer-ada.patch: No longer needed for Ada (Keith Seitz).
|
||||
- New PR backtrace/12237, drop gdb-6.3-framepczero-20040927.patch
|
||||
gdb-6.3-bt-past-zero-20051201.patch as they already had no effect.
|
||||
- Drop gdb-6.8-gcc35998-ada-memory-trash.patch as a different fix is upstream.
|
||||
|
||||
* Thu Nov 18 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20101117-1.fc15
|
||||
- Rebase to FSF GDB 7.2.50.20101117 (which is a 7.3 pre-release).
|
||||
|
Loading…
Reference in New Issue
Block a user