- Fix broken python "help()" command "modules" (BZ 526552).
- Upgrade to the FSF GDB gdb-7.0 snapshot: 6.8.91.20090930 - archer-jankratochvil-fedora12 commit: 7cb860f03e2437c97239334ebe240d06f45723e0
This commit is contained in:
parent
40f8d2fd9b
commit
ab901d8ee8
@ -1,2 +1,2 @@
|
||||
libstdc++-v3-python-r151798.tar.xz
|
||||
gdb-6.8.91.20090925.tar.bz2
|
||||
gdb-6.8.91.20090930.tar.bz2
|
||||
|
@ -102,17 +102,3 @@ frames-invalid can happen asynchronously.
|
||||
|
||||
set timeout $oldtimeout
|
||||
return 0
|
||||
--- sources/gdb/testsuite/gdb.base/dump.exp-orig 2008-08-28 11:44:40.000000000 +0200
|
||||
+++ sources/gdb/testsuite/gdb.base/dump.exp 2008-08-28 11:44:49.000000000 +0200
|
||||
@@ -493,8 +493,10 @@ if ![string compare $is64bitonly "no"] t
|
||||
gdb_test "print zero_all ()" "" ""
|
||||
|
||||
# restore with expressions
|
||||
+ # Address may fit in int32 but its negative result would be 0xffffxxxx for
|
||||
+ # 64-bit LONGEST addresses.
|
||||
test_restore_saved_value \
|
||||
- "intarr3.srec ${array2_start}-${array_start} &intarray\[3\] &intarray\[4\]" \
|
||||
+ "intarr3.srec (long)${array2_start}-${array_start} &intarray\[3\] &intarray\[4\]" \
|
||||
"array partial with expressions" 4 "intarray2\[3\]"
|
||||
|
||||
gdb_test "print intarray2\[2\] == 0" " = 1" "element 2 not changed, == 4"
|
||||
|
@ -2,7 +2,7 @@ http://sourceware.org/gdb/wiki/ProjectArcher
|
||||
http://sourceware.org/gdb/wiki/ArcherBranchManagement
|
||||
|
||||
GIT snapshot:
|
||||
commit 4338ea85c798007c32594032f602db9fd230eba9
|
||||
commit 7cb860f03e2437c97239334ebe240d06f45723e0
|
||||
|
||||
branch `archer' - the merge of branches:
|
||||
archer-tromey-call-frame-cfa
|
||||
@ -21843,7 +21843,7 @@ index 7f033d6..11dba06 100644
|
||||
+typedef int myint;
|
||||
+int dm_type_typedef (myint i) { return i; }
|
||||
diff --git a/gdb/testsuite/gdb.cp/cplusfuncs.exp b/gdb/testsuite/gdb.cp/cplusfuncs.exp
|
||||
index 5e08768..10ffdf0 100644
|
||||
index 5e08768..2ec50ca 100644
|
||||
--- a/gdb/testsuite/gdb.cp/cplusfuncs.exp
|
||||
+++ b/gdb/testsuite/gdb.cp/cplusfuncs.exp
|
||||
@@ -63,12 +63,28 @@ set dm_type_foo_ref "foo&"
|
||||
@ -22195,6 +22195,25 @@ index 5e08768..10ffdf0 100644
|
||||
}
|
||||
|
||||
proc do_tests {} {
|
||||
@@ -534,6 +704,7 @@ proc do_tests {} {
|
||||
global srcdir
|
||||
global binfile
|
||||
global gdb_prompt
|
||||
+ global dm_type_int_star
|
||||
|
||||
set prms_id 0
|
||||
set bug_id 0
|
||||
@@ -557,6 +728,10 @@ proc do_tests {} {
|
||||
test_paddr_operator_functions
|
||||
test_paddr_hairy_functions
|
||||
test_lookup_operator_functions
|
||||
+
|
||||
+ # A regression test on errors involving operators
|
||||
+ gdb_test "list foo::operator $dm_type_int_star" \
|
||||
+ ".*the class foo does not have any method named operator $dm_type_int_star.*"
|
||||
}
|
||||
|
||||
do_tests
|
||||
diff --git a/gdb/testsuite/gdb.cp/expand-sals.exp b/gdb/testsuite/gdb.cp/expand-sals.exp
|
||||
index 3c302c3..cd0496d 100644
|
||||
--- a/gdb/testsuite/gdb.cp/expand-sals.exp
|
||||
|
21
gdb.spec
21
gdb.spec
@ -10,11 +10,11 @@ Name: gdb%{?_with_debug:-debug}
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 6.8.91.20090925
|
||||
Version: 6.8.91.20090930
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 3%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 1%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -374,7 +374,6 @@ BuildRequires: readline-devel
|
||||
#Requires: rpm-libs
|
||||
BuildRequires: rpm-devel
|
||||
%if 0%{!?_without_python:1}
|
||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
Requires: python-libs
|
||||
BuildRequires: python-devel
|
||||
# Temporarily before it gets moved to libstdc++.rpm
|
||||
@ -612,7 +611,7 @@ CFLAGS="$CFLAGS -O0 -ggdb2"
|
||||
--mandir=%{_mandir} \
|
||||
--infodir=%{_infodir} \
|
||||
--with-gdb-datadir=%{_datadir}/gdb \
|
||||
--with-pythondir=%{python_sitelib} \
|
||||
--with-pythondir=%{_datadir}/gdb/python \
|
||||
--enable-gdb-build-warnings=,-Wno-unused \
|
||||
%ifnarch %{ix86} alpha ia64 ppc s390 s390x x86_64 ppc64 sparcv9 sparc64
|
||||
--disable-werror \
|
||||
@ -764,14 +763,14 @@ for LIB in lib lib64;do
|
||||
LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
|
||||
mkdir -p $LIBPATH
|
||||
# basename is being run only for the native (non-biarch) file.
|
||||
sed -e 's,@pythondir@,%{python_sitelib}/gdb,' \
|
||||
sed -e 's,@pythondir@,%{_datadir}/gdb/python,' \
|
||||
-e 's,@toolexeclibdir@,%{_prefix}/'"$LIB," \
|
||||
< $RPM_BUILD_DIR/%{gdb_src}/%{libstdcxxpython}/hook.in \
|
||||
> $LIBPATH/$(basename %{_prefix}/%{_lib}/libstdc++.so.6.*)-gdb.py
|
||||
done
|
||||
test ! -e $RPM_BUILD_ROOT%{python_sitelib}/gdb/libstdcxx
|
||||
test ! -e $RPM_BUILD_ROOT%{_datadir}/gdb/python/libstdcxx
|
||||
cp -a $RPM_BUILD_DIR/%{gdb_src}/%{libstdcxxpython}/libstdcxx \
|
||||
$RPM_BUILD_ROOT%{python_sitelib}/gdb/libstdcxx
|
||||
$RPM_BUILD_ROOT%{_datadir}/gdb/python/libstdcxx
|
||||
%endif # 0%{!?_without_python:1}
|
||||
|
||||
# Remove the files that are part of a gdb build but that are owned and
|
||||
@ -832,9 +831,6 @@ fi
|
||||
%{_bindir}/pstack
|
||||
%{_mandir}/*/gstack.1*
|
||||
%{_mandir}/*/pstack.1*
|
||||
%if 0%{!?_without_python:1}
|
||||
%{python_sitelib}/gdb
|
||||
%endif # 0%{!?_without_python:1}
|
||||
%endif # 0%{!?_with_upstream:1}
|
||||
%{_datadir}/gdb
|
||||
%{_infodir}/annotate.info*
|
||||
@ -851,6 +847,11 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Sep 30 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.91.20090930-1
|
||||
- Fix broken python "help()" command "modules" (BZ 526552).
|
||||
- Upgrade to the FSF GDB gdb-7.0 snapshot: 6.8.91.20090930
|
||||
- archer-jankratochvil-fedora12 commit: 7cb860f03e2437c97239334ebe240d06f45723e0
|
||||
|
||||
* Sun Sep 27 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.91.20090925-3
|
||||
- New test for step-resume breakpoint placed in multiple threads at once.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user