- Suggest SELinux permissions problem; no assertion failure anymore (BZ
232371). - Related: rhbz#232371
This commit is contained in:
parent
eaba00d1b0
commit
8955b7e320
17
gdb-6.6-bz232371-selinux-thread-error.patch
Normal file
17
gdb-6.6-bz232371-selinux-thread-error.patch
Normal file
@ -0,0 +1,17 @@
|
||||
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=232371
|
||||
|
||||
|
||||
diff -u -rup gdb-6.6-orig/gdb/linux-nat.c gdb-6.6/gdb/linux-nat.c
|
||||
--- gdb-6.6-orig/gdb/linux-nat.c 2007-03-15 19:55:40.000000000 -0400
|
||||
+++ gdb-6.6/gdb/linux-nat.c 2007-03-15 20:02:09.000000000 -0400
|
||||
@@ -1014,6 +1014,10 @@ lin_lwp_attach_lwp (ptid_t ptid, int ver
|
||||
{
|
||||
/* Try again with __WCLONE to check cloned processes. */
|
||||
pid = my_waitpid (GET_LWP (ptid), &status, __WCLONE);
|
||||
+ if (pid == -1 && errno == ECHILD)
|
||||
+ error (_("Can't attach %s (%s) - possible SELinux denial,"
|
||||
+ " check your /var/log/messages for `avc: denied'"),
|
||||
+ target_pid_to_str (ptid), safe_strerror (errno));
|
||||
lp->cloned = 1;
|
||||
}
|
||||
|
9
gdb.spec
9
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
||||
Version: 6.6
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
@ -311,6 +311,9 @@ Patch234: gdb-6.6-bz230000-power6-disassembly-test.patch
|
||||
# Temporary support for shared libraries >2GB on 64bit hosts. (BZ 231832)
|
||||
Patch235: gdb-6.3-bz231832-obstack-2gb.patch
|
||||
|
||||
# Suggest SELinux permissions problem; no assertion failure anymore (BZ 232371).
|
||||
Patch236: gdb-6.6-bz232371-selinux-thread-error.patch
|
||||
|
||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu gettext
|
||||
BuildRequires: flex bison sharutils
|
||||
|
||||
@ -437,6 +440,7 @@ and printing their data.
|
||||
%patch232 -p1
|
||||
%patch234 -p1
|
||||
%patch235 -p1
|
||||
%patch236 -p1
|
||||
|
||||
# Change the version that gets printed at GDB startup, so it is RedHat
|
||||
# specific.
|
||||
@ -599,6 +603,9 @@ fi
|
||||
# don't include the files in include, they are part of binutils
|
||||
|
||||
%changelog
|
||||
* Thu Mar 15 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.6-7
|
||||
- Suggest SELinux permissions problem; no assertion failure anymore (BZ 232371).
|
||||
|
||||
* Wed Mar 14 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.6-6
|
||||
- Fix occasional dwarf2_read_address: Corrupted DWARF expression (BZ 232353).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user