- Fix occasional dwarf2_read_address: Corrupted DWARF expression (BZ
232353). - Resolves: rhbz#232353
This commit is contained in:
parent
e157c1b26f
commit
eaba00d1b0
@ -521,3 +521,34 @@ https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=230000
|
||||
if (TARGET_BYTE_ORDER == BFD_ENDIAN_BIG)
|
||||
return print_insn_big_powerpc (memaddr, info);
|
||||
else
|
||||
|
||||
|
||||
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=232353
|
||||
|
||||
|
||||
2007-01-27 Daniel Jacobowitz <dan@codesourcery.com>
|
||||
|
||||
* dwarf2loc.h (struct dwarf2_locexpr_baton): Change size to a long.
|
||||
(struct dwarf2_loclist_baton): Likewise.
|
||||
|
||||
|
||||
--- ./gdb/dwarf2loc.h 17 Dec 2005 22:33:59 -0000 1.6
|
||||
+++ ./gdb/dwarf2loc.h 5 Jan 2007 15:31:17 -0000
|
||||
@@ -39,7 +39,7 @@ struct dwarf2_locexpr_baton
|
||||
gdb_byte *data;
|
||||
|
||||
/* Length of the location expression. */
|
||||
- unsigned short size;
|
||||
+ unsigned long size;
|
||||
|
||||
/* The objfile containing the symbol whose location we're computing. */
|
||||
struct objfile *objfile;
|
||||
@@ -55,7 +55,7 @@ struct dwarf2_loclist_baton
|
||||
gdb_byte *data;
|
||||
|
||||
/* Length of the location list. */
|
||||
- unsigned short size;
|
||||
+ unsigned long size;
|
||||
|
||||
/* The objfile containing the symbol whose location we're computing. */
|
||||
/* Used (only???) by thread local variables. The objfile in which
|
||||
|
5
gdb.spec
5
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
||||
Version: 6.6
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
@ -599,6 +599,9 @@ fi
|
||||
# don't include the files in include, they are part of binutils
|
||||
|
||||
%changelog
|
||||
* Wed Mar 14 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.6-6
|
||||
- Fix occasional dwarf2_read_address: Corrupted DWARF expression (BZ 232353).
|
||||
|
||||
* Mon Mar 12 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.6-5
|
||||
- Temporary support for shared libraries >2GB on 64bit hosts. (BZ 231832)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user