- Fix ia64 compilation errors (Yi Zhan, BZ 442684).
- Fix build on non-standard rpm-devel includes (Robert Scheck, BZ 442449). - Do not run the PIE mode for the testsuite during `--with upstream'. - Fix test of the crash on a sw watchpoint condition getting out of the scope.
This commit is contained in:
parent
5f5d7d94b5
commit
7db944e3bd
@ -20,6 +20,10 @@
|
||||
|
||||
Port to GDB-6.8pre.
|
||||
|
||||
2008-04-16 Yi Zhan <yi.zhan@intel.com>
|
||||
|
||||
Fix a compilation error on a typo.
|
||||
|
||||
Index: gdb-6.8cvs20080219/gdb/libunwind-frame.c
|
||||
===================================================================
|
||||
--- gdb-6.8cvs20080219.orig/gdb/libunwind-frame.c 2008-01-02 00:04:03.000000000 +0100
|
||||
@ -36,7 +40,7 @@ Index: gdb-6.8cvs20080219/gdb/libunwind-frame.c
|
||||
unw_accessors_t *acc;
|
||||
unw_addr_space_t as;
|
||||
unw_word_t fp;
|
||||
+ unw_word_t fp, sp;
|
||||
+ unw_word_t sp;
|
||||
unw_regnum_t uw_sp_regnum;
|
||||
struct libunwind_frame_cache *cache;
|
||||
struct libunwind_descr *descr;
|
||||
|
@ -3,6 +3,11 @@
|
||||
* ia64-tdep.c (ia64_sigtramp_frame_prev_register): Build
|
||||
pseudo-registers the same as ia64_pseudo_register_read.
|
||||
|
||||
2008-04-16 Yi Zhan <yi.zhan@intel.com>
|
||||
|
||||
* ia64-tdep.c (ia64_sigtramp_frame_prev_register): Fix an
|
||||
ISO C compliance compilation error.
|
||||
|
||||
--- gdb-6.3/gdb/ia64-tdep.c.fix 2005-07-08 20:26:37.000000000 -0400
|
||||
+++ gdb-6.3/gdb/ia64-tdep.c 2005-07-08 20:27:41.000000000 -0400
|
||||
@@ -2037,7 +2037,100 @@ ia64_sigtramp_frame_prev_register (struc
|
||||
@ -52,8 +57,8 @@
|
||||
+ {
|
||||
+ /* Compute address of nat collection bits */
|
||||
+ CORE_ADDR nat_collection;
|
||||
+ nat_addr = gr_addr | 0x1f8;
|
||||
+ int nat_bit;
|
||||
+ nat_addr = gr_addr | 0x1f8;
|
||||
+ /* If our nat collection address is bigger than bsp, we have to get
|
||||
+ the nat collection from rnat. Otherwise, we fetch the nat
|
||||
+ collection from the computed address. FIXME: Do not know if
|
||||
|
@ -124,5 +124,5 @@
|
||||
+gdb_test "backtrace"
|
||||
+
|
||||
+gdb_test "finish" \
|
||||
+ "Watchpoint .* deleted because the program has left the block in.*which its expression is valid..*in jumper.*" \
|
||||
+ "Watchpoint .* deleted because the program has left the block in.*which its expression is valid..*in (jumper|func).*" \
|
||||
+ "Catch the no longer valid watchpoint"
|
||||
|
@ -28,10 +28,23 @@
|
||||
Implement the `debuginfo-install' rpm/yum integration.
|
||||
Resolve the RH Bug 435581.
|
||||
|
||||
2008-04-16 Robert Scheck <redhat-bugzilla@linuxnetz.de>
|
||||
|
||||
Fix -I for non-standard rpm includes in `$(includedir)/rpm'.
|
||||
|
||||
Index: gdb-6.7.50.20080227/gdb/Makefile.in
|
||||
===================================================================
|
||||
--- gdb-6.7.50.20080227.orig/gdb/Makefile.in 2008-03-10 00:48:52.000000000 +0100
|
||||
+++ gdb-6.7.50.20080227/gdb/Makefile.in 2008-03-10 00:48:53.000000000 +0100
|
||||
@@ -340,7 +340,7 @@
|
||||
# your system doesn't have fcntl.h in /usr/include (which is where it
|
||||
# should be according to Posix).
|
||||
DEFS = @DEFS@
|
||||
-GDB_CFLAGS = -I. -I$(srcdir) -I$(srcdir)/config -DLOCALEDIR="\"$(localedir)\"" $(DEFS)
|
||||
+GDB_CFLAGS = -I. -I$(srcdir) -I$(srcdir)/config -I$(includedir)/rpm -DLOCALEDIR="\"$(localedir)\"" $(DEFS)
|
||||
|
||||
# MH_CFLAGS, if defined, has host-dependent CFLAGS from the config directory.
|
||||
GLOBAL_CFLAGS = $(MH_CFLAGS)
|
||||
@@ -392,7 +392,7 @@ INSTALLED_LIBS=-lbfd -lreadline -lopcode
|
||||
CLIBS = $(SIM) $(READLINE) $(OPCODES) $(BFD) $(INTL) $(LIBIBERTY) $(LIBDECNUMBER) \
|
||||
$(XM_CLIBS) $(TM_CLIBS) $(NAT_CLIBS) $(GDBTKLIBS) @LIBS@ \
|
||||
|
20
gdb-6.8-upstream.patch
Normal file
20
gdb-6.8-upstream.patch
Normal file
@ -0,0 +1,20 @@
|
||||
2008-03-30 Daniel Jacobowitz <dan@codesourcery.com>
|
||||
|
||||
* ia64-tdep.c (examine_prologue): Correct array access.
|
||||
|
||||
===================================================================
|
||||
RCS file: /cvs/src/src/gdb/ia64-tdep.c,v
|
||||
retrieving revision 1.172
|
||||
retrieving revision 1.173
|
||||
diff -u -r1.172 -r1.173
|
||||
--- src/gdb/ia64-tdep.c 2008/02/20 14:31:40 1.172
|
||||
+++ src/gdb/ia64-tdep.c 2008/03/31 03:38:48 1.173
|
||||
@@ -1234,7 +1234,7 @@
|
||||
spill_reg = rN;
|
||||
last_prologue_pc = next_pc;
|
||||
}
|
||||
- else if (qp == 0 && rM >= 32 && rM < 40 && !instores[rM] &&
|
||||
+ else if (qp == 0 && rM >= 32 && rM < 40 && !instores[rM-32] &&
|
||||
rN < 256 && imm == 0)
|
||||
{
|
||||
/* mov rN, rM where rM is an input register */
|
25
gdb.spec
25
gdb.spec
@ -13,7 +13,7 @@ Version: 6.8
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 2%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 3%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
@ -42,7 +42,7 @@ Obsoletes: gdb64 < 5.3.91
|
||||
# The last Rawhide release was (no dist tag) pstack-1.2-7.2.2
|
||||
Obsoletes: pstack < 1.2-7.2.2.1
|
||||
Provides: pstack = 1.2-7.2.2.1
|
||||
%endif # 1%{?_with_upstream:0}
|
||||
%endif # 0%{!?_with_upstream:1}
|
||||
|
||||
# GDB patches have the format `gdb-<version>-bz<red-hat-bz-#>-<desc>.patch'.
|
||||
# They should be created using patch level 1: diff -up ./gdb (or gdb-6.3/gdb).
|
||||
@ -244,7 +244,7 @@ Patch229: gdb-6.3-bz140532-ppc-unwinding-test.patch
|
||||
Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
||||
|
||||
# Backported post gdb-6.8 release fixups.
|
||||
#Patch232: gdb-6.8-upstream.patch
|
||||
Patch232: gdb-6.8-upstream.patch
|
||||
|
||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||
Patch234: gdb-6.6-bz230000-power6-disassembly-test.patch
|
||||
@ -419,7 +419,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
|
||||
%if 0%{!?_with_upstream:1}
|
||||
|
||||
#%patch232 -p1
|
||||
%patch232 -p1
|
||||
%patch1 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
@ -523,7 +523,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
find -name "*.orig" | xargs rm -f
|
||||
! find -name "*.rej" # Should not happen.
|
||||
|
||||
%endif # 1%{?_with_upstream:0}
|
||||
%endif # 0%{!?_with_upstream:1}
|
||||
|
||||
# Change the version that gets printed at GDB startup, so it is Fedora
|
||||
# specific.
|
||||
@ -652,8 +652,11 @@ gcc -o ./orphanripper %{SOURCE2} -Wall -lutil
|
||||
mv -f ../../gdb/testsuite/$test ../gdb/testsuite/$test-DISABLED || :
|
||||
done
|
||||
|
||||
%if 0%{!?_with_upstream:1}
|
||||
# Run all the scheduled testsuite runs also in the PIE mode.
|
||||
# Upstream GDB would lock up the testsuite run for too long on its failures.
|
||||
CHECK="$(echo $CHECK|sed 's#check//unix/[^ ]*#& &/-fPIE/-pie#g')"
|
||||
%endif # 0%{!?_with_upstream:1}
|
||||
|
||||
for CURRENT in $CHECK
|
||||
do
|
||||
@ -710,7 +713,7 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
|
||||
ln -s gstack.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/pstack.1.gz
|
||||
ln -s gstack $RPM_BUILD_ROOT%{_bindir}/pstack
|
||||
%endif # 1%{?_with_upstream:0}
|
||||
%endif # 0%{!?_with_upstream:1}
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -745,7 +748,7 @@ fi
|
||||
%{_bindir}/pstack
|
||||
%{_mandir}/*/gstack.1*
|
||||
%{_mandir}/*/pstack.1*
|
||||
%endif # 1%{?_with_upstream:0}
|
||||
%endif # 0%{!?_with_upstream:1}
|
||||
%{_infodir}/annotate.info*
|
||||
%{_infodir}/gdb.info*
|
||||
%{_infodir}/gdbint.info*
|
||||
@ -758,6 +761,12 @@ fi
|
||||
%{_mandir}/*/gdbserver.1*
|
||||
|
||||
%changelog
|
||||
* Wed Apr 16 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-3
|
||||
- Fix ia64 compilation errors (Yi Zhan, BZ 442684).
|
||||
- Fix build on non-standard rpm-devel includes (Robert Scheck, BZ 442449).
|
||||
- Do not run the PIE mode for the testsuite during `--with upstream'.
|
||||
- Fix test of the crash on a sw watchpoint condition getting out of the scope.
|
||||
|
||||
* Fri Apr 11 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-2
|
||||
- Fix a regression due to PIE of reloading a changed exec file (BZ 433410).
|
||||
- Include also biarch libgcc on %%{multilib_64_archs} for the testsuite.
|
||||
@ -781,7 +790,7 @@ fi
|
||||
- Drop the unused `ChangeLog.RedHat' file stubs.
|
||||
- New rpm option `--with upstream' to drop the Fedora patches for testing.
|
||||
- Drop some no longer valid .spec file comments.
|
||||
- Include the Fortran dynamic arrays entry for %%changlog of 6.7.50.20080227-1.
|
||||
- Include the Fortran dynamic arrays entry for changelog of 6.7.50.20080227-1.
|
||||
|
||||
* Mon Mar 3 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.50.20080227-1
|
||||
- Upgrade to the upstream gdb-6.8 prerelease.
|
||||
|
Loading…
Reference in New Issue
Block a user