Remove gdb-opcodes-clflushopt-test.patch
Remove gdb-opcodes-clflushopt-test.patch. This patch tests that GDB can disassemble the clflushopt instruction correctly. Such disassembly is a feature of libopcode and is covered by the gas tests i386/x86-64-clflushopt.s and i386/clflushopt.s. Lets remove this test from GDB and just rely on the gas tests instead.
This commit is contained in:
parent
b1e9fbcc29
commit
7cd90204c9
@ -184,21 +184,17 @@ Patch043: gdb-rhbz1084404-ppc64-s390x-wrong-prologue-skip-O2-g-3of3.patch
|
||||
#=push+jan
|
||||
Patch044: gdb-fedora-libncursesw.patch
|
||||
|
||||
# Test clflushopt instruction decode (for RH BZ 1262471).
|
||||
#=fedoratest
|
||||
Patch045: gdb-opcodes-clflushopt-test.patch
|
||||
|
||||
# [aarch64] Fix hardware watchpoints (RH BZ 1261564).
|
||||
#=fedoratest
|
||||
Patch046: gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
Patch045: gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
|
||||
# Add messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
|
||||
#=fedora
|
||||
Patch047: gdb-container-rh-pkg.patch
|
||||
Patch046: gdb-container-rh-pkg.patch
|
||||
|
||||
# [dts+el7] [x86*] Bundle linux_perf.h for libipt (RH BZ 1256513).
|
||||
#=fedora
|
||||
Patch048: gdb-linux_perf-bundle.patch
|
||||
Patch047: gdb-linux_perf-bundle.patch
|
||||
|
||||
# Fix gdb-headless /usr/bin/ executables (BZ 1390251).
|
||||
#
|
||||
@ -207,20 +203,20 @@ Patch048: gdb-linux_perf-bundle.patch
|
||||
#
|
||||
# https://fedoraproject.org/wiki/Changes/Minimal_GDB_in_buildroot
|
||||
#=fedora
|
||||
Patch049: gdb-libexec-add-index.patch
|
||||
Patch048: gdb-libexec-add-index.patch
|
||||
|
||||
# [s390x] Backport arch12 instructions decoding (RH BZ 1553104).
|
||||
# =fedoratest
|
||||
Patch050: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
Patch049: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
|
||||
# [aarch64] Backport fix from Luis Machado for RH BZ 2177655.
|
||||
Patch051: gdb-rhbz2177655-aarch64-pauth-valid-regcache.patch
|
||||
Patch050: gdb-rhbz2177655-aarch64-pauth-valid-regcache.patch
|
||||
|
||||
# Backport "Fix crash in inside_main_func"
|
||||
# (Tom Tromey, RHBZ 2183595)
|
||||
Patch052: gdb-rhbz2183595-rustc-inside_main.patch
|
||||
Patch051: gdb-rhbz2183595-rustc-inside_main.patch
|
||||
|
||||
# Backport "Fix a potential illegal memory access in the BFD library..."
|
||||
# (Nick Clifton, binutils/29988)
|
||||
Patch053: gdb-binutils29988-read_indexed_address.patch
|
||||
Patch052: gdb-binutils29988-read_indexed_address.patch
|
||||
|
||||
|
@ -50,4 +50,3 @@
|
||||
%patch -p1 -P050
|
||||
%patch -p1 -P051
|
||||
%patch -p1 -P052
|
||||
%patch -p1 -P053
|
||||
|
@ -42,7 +42,6 @@ gdb-rhbz1149205-catch-syscall-after-fork-test.patch
|
||||
gdb-rhbz1186476-internal-error-unqualified-name-re-set-test.patch
|
||||
gdb-rhbz1084404-ppc64-s390x-wrong-prologue-skip-O2-g-3of3.patch
|
||||
gdb-fedora-libncursesw.patch
|
||||
gdb-opcodes-clflushopt-test.patch
|
||||
gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
gdb-container-rh-pkg.patch
|
||||
gdb-linux_perf-bundle.patch
|
||||
|
@ -1,62 +0,0 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Fedora GDB patches <invalid@email.com>
|
||||
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
||||
Subject: gdb-opcodes-clflushopt-test.patch
|
||||
|
||||
;; Test clflushopt instruction decode (for RH BZ 1262471).
|
||||
;;=fedoratest
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.arch/amd64-clflushopt.S b/gdb/testsuite/gdb.arch/amd64-clflushopt.S
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.arch/amd64-clflushopt.S
|
||||
@@ -0,0 +1,19 @@
|
||||
+/* Copyright 2016 Free Software Foundation, Inc.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 3 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+ This file is part of the gdb testsuite. */
|
||||
+
|
||||
+_start: .globl _start
|
||||
+ clflushopt (%edi)
|
||||
diff --git a/gdb/testsuite/gdb.arch/amd64-clflushopt.exp b/gdb/testsuite/gdb.arch/amd64-clflushopt.exp
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.arch/amd64-clflushopt.exp
|
||||
@@ -0,0 +1,25 @@
|
||||
+# Copyright 2016 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 3 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+if { ![istarget "x86_64-*-*"] && ![istarget "i?86-*-*"] } then {
|
||||
+ verbose "Skipping amd64 clflushopt test."
|
||||
+ return
|
||||
+}
|
||||
+
|
||||
+if [prepare_for_testing amd64-clflushopt.exp amd64-clflushopt amd64-clflushopt.S [list debug "additional_flags=-nostdlib"]] {
|
||||
+ return -1
|
||||
+}
|
||||
+
|
||||
+gdb_test "disas _start" "Dump of assembler code for function _start:\r\n *0x\[0-9a-f\]+ <\[+\]0>:\tclflushopt \\(%edi\\)\r\nEnd of assembler dump\\." "clflushopt"
|
7
gdb.spec
7
gdb.spec
@ -1249,6 +1249,13 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue May 2 2023 Andrew Burgess <aburgess@redhat.com>
|
||||
- Remove gdb-opcodes-clflushopt-test.patch. This patch tests that GDB
|
||||
can disassemble the clflushopt instruction correctly. Such
|
||||
disassembly is a feature of libopcode and is covered by the gas
|
||||
tests i386/x86-64-clflushopt.s and i386/clflushopt.s. Lets remove
|
||||
this test from GDB and just rely on the gas tests instead.
|
||||
|
||||
* Sat Apr 29 2023 Kevin Buettner <kevinb@redhat.com>
|
||||
- Remove gdb-6.7-charsign-test.patch. This patch originally contained
|
||||
some changes to GDB which were rejected by upstream maintainers. All
|
||||
|
Loading…
Reference in New Issue
Block a user