Remove gdb-6.7-charsign-test.patch
This patch originally contained some changes to GDB which were rejected by upstream maintainers. All that remained was a testcase which had a number of failures due to the rest of the work not being present in GDB.
This commit is contained in:
parent
231ea6585a
commit
b1e9fbcc29
@ -56,153 +56,149 @@ Patch013: gdb-6.6-buildid-locate-solib-missing-ids.patch
|
||||
#=push+jan
|
||||
Patch014: gdb-6.6-buildid-locate-rpm.patch
|
||||
|
||||
# Fix displaying of numeric char arrays as strings (BZ 224128).
|
||||
#=fedoratest: But it is failing anyway, one should check the behavior more.
|
||||
Patch015: gdb-6.7-charsign-test.patch
|
||||
|
||||
# Test PPC hiding of call-volatile parameter register.
|
||||
#=fedoratest
|
||||
Patch016: gdb-6.7-ppc-clobbered-registers-O2-test.patch
|
||||
Patch015: gdb-6.7-ppc-clobbered-registers-O2-test.patch
|
||||
|
||||
# Testsuite fixes for more stable/comparable results.
|
||||
#=fedoratest
|
||||
Patch017: gdb-6.7-testsuite-stable-results.patch
|
||||
Patch016: gdb-6.7-testsuite-stable-results.patch
|
||||
|
||||
# Test ia64 memory leaks of the code using libunwind.
|
||||
#=fedoratest
|
||||
Patch018: gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
Patch017: gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
|
||||
# Test hiding unexpected breakpoints on intentional step commands.
|
||||
#=fedoratest
|
||||
Patch019: gdb-6.5-missed-trap-on-step-test.patch
|
||||
Patch018: gdb-6.5-missed-trap-on-step-test.patch
|
||||
|
||||
# Test gcore memory and time requirements for large inferiors.
|
||||
#=fedoratest
|
||||
Patch020: gdb-6.5-gcore-buffer-limit-test.patch
|
||||
Patch019: gdb-6.5-gcore-buffer-limit-test.patch
|
||||
|
||||
# Test GCORE for shmid 0 shared memory mappings.
|
||||
#=fedoratest: But it is broken anyway, sometimes the case being tested is not reproducible.
|
||||
Patch021: gdb-6.3-mapping-zero-inode-test.patch
|
||||
Patch020: gdb-6.3-mapping-zero-inode-test.patch
|
||||
|
||||
# Test a crash on libraries missing the .text section.
|
||||
#=fedoratest
|
||||
Patch022: gdb-6.5-section-num-fixup-test.patch
|
||||
Patch021: gdb-6.5-section-num-fixup-test.patch
|
||||
|
||||
# Fix resolving of variables at locations lists in prelinked libs (BZ 466901).
|
||||
#=fedoratest
|
||||
Patch023: gdb-6.8-bz466901-backtrace-full-prelinked.patch
|
||||
Patch022: gdb-6.8-bz466901-backtrace-full-prelinked.patch
|
||||
|
||||
# New test for step-resume breakpoint placed in multiple threads at once.
|
||||
#=fedoratest
|
||||
Patch024: gdb-simultaneous-step-resume-breakpoint-test.patch
|
||||
Patch023: gdb-simultaneous-step-resume-breakpoint-test.patch
|
||||
|
||||
# Fix GNU/Linux core open: Can't read pathname for load map: Input/output error.
|
||||
# Fix regression of undisplayed missing shared libraries caused by a fix for.
|
||||
#=fedoratest: It should be in glibc: libc-alpha: <20091004161706.GA27450@.*>
|
||||
Patch025: gdb-core-open-vdso-warning.patch
|
||||
Patch024: gdb-core-open-vdso-warning.patch
|
||||
|
||||
# Workaround ccache making lineno non-zero for command-line definitions.
|
||||
#=fedoratest: ccache is rarely used and it is even fixed now.
|
||||
Patch026: gdb-ccache-workaround.patch
|
||||
Patch025: gdb-ccache-workaround.patch
|
||||
|
||||
# Testcase for "Do not make up line information" fix by Daniel Jacobowitz.
|
||||
#=fedoratest
|
||||
Patch027: gdb-lineno-makeup-test.patch
|
||||
Patch026: gdb-lineno-makeup-test.patch
|
||||
|
||||
# Test power7 ppc disassembly.
|
||||
#=fedoratest
|
||||
Patch028: gdb-ppc-power7-test.patch
|
||||
Patch027: gdb-ppc-power7-test.patch
|
||||
|
||||
# Fix follow-exec for C++ programs (bugreported by Martin Stransky).
|
||||
#=fedoratest
|
||||
Patch029: gdb-archer-next-over-throw-cxx-exec.patch
|
||||
Patch028: gdb-archer-next-over-throw-cxx-exec.patch
|
||||
|
||||
# Workaround librpm BZ 643031 due to its unexpected exit() calls (BZ 642879).
|
||||
#=push+jan
|
||||
Patch030: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
|
||||
Patch029: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
|
||||
|
||||
# [delayed-symfile] Test a backtrace regression on CFIs without DIE (BZ 614604).
|
||||
#=fedoratest
|
||||
Patch031: gdb-test-bt-cfi-without-die.patch
|
||||
Patch030: gdb-test-bt-cfi-without-die.patch
|
||||
|
||||
# Verify GDB Python built-in function gdb.solib_address exists (BZ # 634108).
|
||||
#=fedoratest
|
||||
Patch032: gdb-bz634108-solib_address.patch
|
||||
Patch031: gdb-bz634108-solib_address.patch
|
||||
|
||||
# New test gdb.arch/x86_64-pid0-core.exp for kernel PID 0 cores (BZ 611435).
|
||||
#=fedoratest
|
||||
Patch033: gdb-test-pid0-core.patch
|
||||
Patch032: gdb-test-pid0-core.patch
|
||||
|
||||
# [archer-tromey-delayed-symfile] New test gdb.dwarf2/dw2-aranges.exp.
|
||||
#=fedoratest
|
||||
Patch034: gdb-test-dw2-aranges.patch
|
||||
Patch033: gdb-test-dw2-aranges.patch
|
||||
|
||||
# Workaround PR libc/14166 for inferior calls of strstr.
|
||||
#=fedoratest: Compatibility with RHELs (unchecked which ones).
|
||||
Patch035: gdb-glibc-strstr-workaround.patch
|
||||
Patch034: gdb-glibc-strstr-workaround.patch
|
||||
|
||||
# Include testcase for `Unable to see a variable inside a module (XLF)' (BZ 823789).
|
||||
#=fedoratest
|
||||
Patch036: gdb-rhel5.9-testcase-xlf-var-inside-mod.patch
|
||||
Patch035: gdb-rhel5.9-testcase-xlf-var-inside-mod.patch
|
||||
|
||||
# Testcase for `Setting solib-absolute-prefix breaks vDSO' (BZ 818343).
|
||||
#=fedoratest
|
||||
Patch037: gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
|
||||
Patch036: gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
|
||||
|
||||
# Import regression test for `gdb/findvar.c:417: internal-error:
|
||||
# read_var_value: Assertion `frame' failed.' (RH BZ 947564) from RHEL 6.5.
|
||||
#=fedoratest
|
||||
Patch038: gdb-rhbz947564-findvar-assertion-frame-failed-testcase.patch
|
||||
Patch037: gdb-rhbz947564-findvar-assertion-frame-failed-testcase.patch
|
||||
|
||||
# Fix 'memory leak in infpy_read_memory()' (RH BZ 1007614)
|
||||
#=fedoratest
|
||||
Patch039: gdb-rhbz1007614-memleak-infpy_read_memory-test.patch
|
||||
Patch038: gdb-rhbz1007614-memleak-infpy_read_memory-test.patch
|
||||
|
||||
# Fix 'gdb gives highly misleading error when debuginfo pkg is present,
|
||||
# but not corresponding binary pkg' (RH BZ 981154).
|
||||
#=push+jan
|
||||
Patch040: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
|
||||
Patch039: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
|
||||
|
||||
# Testcase for '[SAP] Recursive dlopen causes SAP HANA installer to
|
||||
# crash.' (RH BZ 1156192).
|
||||
#=fedoratest
|
||||
Patch041: gdb-rhbz1156192-recursive-dlopen-test.patch
|
||||
Patch040: gdb-rhbz1156192-recursive-dlopen-test.patch
|
||||
|
||||
# Fix '`catch syscall' doesn't work for parent after `fork' is called'
|
||||
# (Philippe Waroquiers, RH BZ 1149205).
|
||||
#=fedoratest
|
||||
Patch042: gdb-rhbz1149205-catch-syscall-after-fork-test.patch
|
||||
Patch041: gdb-rhbz1149205-catch-syscall-after-fork-test.patch
|
||||
|
||||
# Fix 'backport GDB 7.4 fix to RHEL 6.6 GDB' [Original Sourceware bug
|
||||
# description: 'C++ (and objc): Internal error on unqualified name
|
||||
# re-set', PR 11657] (RH BZ 1186476).
|
||||
#=fedoratest
|
||||
Patch043: gdb-rhbz1186476-internal-error-unqualified-name-re-set-test.patch
|
||||
Patch042: gdb-rhbz1186476-internal-error-unqualified-name-re-set-test.patch
|
||||
|
||||
# Fix '[ppc64] and [s390x] wrong prologue skip on -O2 -g code' (Jan
|
||||
# Kratochvil, RH BZ 1084404).
|
||||
#=fedoratest
|
||||
Patch044: gdb-rhbz1084404-ppc64-s390x-wrong-prologue-skip-O2-g-3of3.patch
|
||||
Patch043: gdb-rhbz1084404-ppc64-s390x-wrong-prologue-skip-O2-g-3of3.patch
|
||||
|
||||
# Force libncursesw over libncurses to match the includes (RH BZ 1270534).
|
||||
#=push+jan
|
||||
Patch045: gdb-fedora-libncursesw.patch
|
||||
Patch044: gdb-fedora-libncursesw.patch
|
||||
|
||||
# Test clflushopt instruction decode (for RH BZ 1262471).
|
||||
#=fedoratest
|
||||
Patch046: gdb-opcodes-clflushopt-test.patch
|
||||
Patch045: gdb-opcodes-clflushopt-test.patch
|
||||
|
||||
# [aarch64] Fix hardware watchpoints (RH BZ 1261564).
|
||||
#=fedoratest
|
||||
Patch047: gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
Patch046: gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
|
||||
# Add messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
|
||||
#=fedora
|
||||
Patch048: gdb-container-rh-pkg.patch
|
||||
Patch047: gdb-container-rh-pkg.patch
|
||||
|
||||
# [dts+el7] [x86*] Bundle linux_perf.h for libipt (RH BZ 1256513).
|
||||
#=fedora
|
||||
Patch049: gdb-linux_perf-bundle.patch
|
||||
Patch048: gdb-linux_perf-bundle.patch
|
||||
|
||||
# Fix gdb-headless /usr/bin/ executables (BZ 1390251).
|
||||
#
|
||||
@ -211,20 +207,20 @@ Patch049: gdb-linux_perf-bundle.patch
|
||||
#
|
||||
# https://fedoraproject.org/wiki/Changes/Minimal_GDB_in_buildroot
|
||||
#=fedora
|
||||
Patch050: gdb-libexec-add-index.patch
|
||||
Patch049: gdb-libexec-add-index.patch
|
||||
|
||||
# [s390x] Backport arch12 instructions decoding (RH BZ 1553104).
|
||||
# =fedoratest
|
||||
Patch051: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
Patch050: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
|
||||
# [aarch64] Backport fix from Luis Machado for RH BZ 2177655.
|
||||
Patch052: gdb-rhbz2177655-aarch64-pauth-valid-regcache.patch
|
||||
Patch051: gdb-rhbz2177655-aarch64-pauth-valid-regcache.patch
|
||||
|
||||
# Backport "Fix crash in inside_main_func"
|
||||
# (Tom Tromey, RHBZ 2183595)
|
||||
Patch053: gdb-rhbz2183595-rustc-inside_main.patch
|
||||
Patch052: gdb-rhbz2183595-rustc-inside_main.patch
|
||||
|
||||
# Backport "Fix a potential illegal memory access in the BFD library..."
|
||||
# (Nick Clifton, binutils/29988)
|
||||
Patch054: gdb-binutils29988-read_indexed_address.patch
|
||||
Patch053: gdb-binutils29988-read_indexed_address.patch
|
||||
|
||||
|
@ -51,4 +51,3 @@
|
||||
%patch -p1 -P051
|
||||
%patch -p1 -P052
|
||||
%patch -p1 -P053
|
||||
%patch -p1 -P054
|
||||
|
@ -12,7 +12,6 @@ gdb-6.5-bz243845-stale-testing-zombie-test.patch
|
||||
gdb-6.6-buildid-locate.patch
|
||||
gdb-6.6-buildid-locate-solib-missing-ids.patch
|
||||
gdb-6.6-buildid-locate-rpm.patch
|
||||
gdb-6.7-charsign-test.patch
|
||||
gdb-6.7-ppc-clobbered-registers-O2-test.patch
|
||||
gdb-6.7-testsuite-stable-results.patch
|
||||
gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
|
@ -1,130 +0,0 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
||||
Subject: gdb-6.7-charsign-test.patch
|
||||
|
||||
;; Fix displaying of numeric char arrays as strings (BZ 224128).
|
||||
;;=fedoratest: But it is failing anyway, one should check the behavior more.
|
||||
|
||||
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=224128
|
||||
|
||||
2007-01-25 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* gdb.base/charsign.exp, gdb.base/charsign.c: New files.
|
||||
[ stripped ]
|
||||
|
||||
2007-10-19 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
Port to GDB-6.7 - only the testcase left, patch has been reverted,
|
||||
char-vectors restricted.
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.base/charsign.c b/gdb/testsuite/gdb.base/charsign.c
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.base/charsign.c
|
||||
@@ -0,0 +1,37 @@
|
||||
+/* This testcase is part of GDB, the GNU debugger.
|
||||
+
|
||||
+ Copyright 2007 Free Software Foundation, Inc.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 2 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program; if not, write to the Free Software
|
||||
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+
|
||||
+ Please email any bugs, comments, and/or additions to this file to:
|
||||
+ bug-gdb@prep.ai.mit.edu */
|
||||
+
|
||||
+int main()
|
||||
+{
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+char n[]="A";
|
||||
+signed char s[]="A";
|
||||
+unsigned char u[]="A";
|
||||
+
|
||||
+typedef char char_n;
|
||||
+typedef signed char char_s;
|
||||
+typedef unsigned char char_u;
|
||||
+
|
||||
+char_n n_typed[]="A";
|
||||
+char_s s_typed[]="A";
|
||||
+char_u u_typed[]="A";
|
||||
diff --git a/gdb/testsuite/gdb.base/charsign.exp b/gdb/testsuite/gdb.base/charsign.exp
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.base/charsign.exp
|
||||
@@ -0,0 +1,63 @@
|
||||
+# Copyright 2007 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 2 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+
|
||||
+set testfile charsign
|
||||
+set srcfile ${testfile}.c
|
||||
+set binfile [standard_output_file ${testfile}]
|
||||
+
|
||||
+proc do_test { cflags } {
|
||||
+ global srcdir
|
||||
+ global binfile
|
||||
+ global subdir
|
||||
+ global srcfile
|
||||
+ global gdb_prompt
|
||||
+
|
||||
+ if { [gdb_compile "${srcdir}/${subdir}/${srcfile}" "${binfile}" executable [list debug additional_flags=$cflags]] != "" } {
|
||||
+ untested "Couldn't compile test program"
|
||||
+ return -1
|
||||
+ }
|
||||
+
|
||||
+ # Get things started.
|
||||
+
|
||||
+ gdb_exit
|
||||
+ gdb_start
|
||||
+ gdb_reinitialize_dir $srcdir/$subdir
|
||||
+ gdb_load ${binfile}
|
||||
+
|
||||
+ # For C programs, "start" should stop in main().
|
||||
+
|
||||
+ gdb_test "p n" \
|
||||
+ "= \"A\""
|
||||
+ gdb_test "p s" \
|
||||
+ "= \\{65 'A', 0 '\\\\0'\\}"
|
||||
+ gdb_test "p u" \
|
||||
+ "= \\{65 'A', 0 '\\\\0'\\}"
|
||||
+ gdb_test "p n_typed" \
|
||||
+ "= \"A\""
|
||||
+ gdb_test "p s_typed" \
|
||||
+ "= \\{65 'A', 0 '\\\\0'\\}"
|
||||
+ gdb_test "p u_typed" \
|
||||
+ "= \\{65 'A', 0 '\\\\0'\\}"
|
||||
+}
|
||||
+
|
||||
+# The string identification works despite the compiler flags below due to
|
||||
+# gdbtypes.c:
|
||||
+# if (name && strcmp (name, "char") == 0)
|
||||
+# TYPE_FLAGS (type) |= TYPE_FLAG_NOSIGN;
|
||||
+
|
||||
+do_test {}
|
||||
+do_test {-fsigned-char}
|
||||
+do_test {-funsigned-char}
|
6
gdb.spec
6
gdb.spec
@ -1249,6 +1249,12 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Apr 29 2023 Kevin Buettner <kevinb@redhat.com>
|
||||
- Remove gdb-6.7-charsign-test.patch. This patch originally contained
|
||||
some changes to GDB which were rejected by upstream maintainers. All
|
||||
that remained was a testcase which had a number of failures due to
|
||||
the rest of the work not being present in GDB.
|
||||
|
||||
* Tue Apr 25 2023 Bruno Larsen <blarsen@redhat.com>
|
||||
- Remove gdb-6.5-bz109921-DW_AT_decl_file-test.patch. That patch was
|
||||
only a test for basic DWARF-2 support, ensuring that GDB found a
|
||||
|
Loading…
Reference in New Issue
Block a user