- Compilation fixup (-9 was never released).
This commit is contained in:
parent
d945816097
commit
2a6507443a
@ -265,7 +265,7 @@ diff -u -ruNp gdb-6.7.1-orig/gdb/i386-nat.c gdb-6.7.1/gdb/i386-nat.c
|
|||||||
|
|
||||||
--- gdb-6.5/gdb/ia64-linux-nat.c.orig 2008-01-12 15:47:40.000000000 +0100
|
--- gdb-6.5/gdb/ia64-linux-nat.c.orig 2008-01-12 15:47:40.000000000 +0100
|
||||||
+++ gdb-6.5/gdb/ia64-linux-nat.c 2008-01-12 15:57:58.000000000 +0100
|
+++ gdb-6.5/gdb/ia64-linux-nat.c 2008-01-12 15:57:58.000000000 +0100
|
||||||
@@ -675,12 +675,23 @@ ia64_linux_remove_watchpoint_callback (s
|
@@ -664,12 +664,23 @@ ia64_linux_remove_watchpoint_callback (s
|
||||||
args->len);
|
args->len);
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -276,8 +276,8 @@ diff -u -ruNp gdb-6.7.1-orig/gdb/i386-nat.c gdb-6.7.1/gdb/i386-nat.c
|
|||||||
+static int ia64_linux_detach_breakpoints_pid;
|
+static int ia64_linux_detach_breakpoints_pid;
|
||||||
+
|
+
|
||||||
/* Remove a watchpoint for all threads. */
|
/* Remove a watchpoint for all threads. */
|
||||||
int
|
static int
|
||||||
ia64_linux_remove_watchpoint (ptid_t ptid, CORE_ADDR addr, int len)
|
ia64_linux_remove_watchpoint (CORE_ADDR addr, int len)
|
||||||
{
|
{
|
||||||
struct linux_watchpoint args;
|
struct linux_watchpoint args;
|
||||||
|
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
|||||||
Version: 6.7.1
|
Version: 6.7.1
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
|
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -655,6 +655,9 @@ fi
|
|||||||
# don't include the files in include, they are part of binutils
|
# don't include the files in include, they are part of binutils
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 12 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-10
|
||||||
|
- Compilation fixup (-9 was never released).
|
||||||
|
|
||||||
* Sat Jan 12 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-9
|
* Sat Jan 12 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-9
|
||||||
- Fix also threaded inferiors for hardware watchpoints after the fork call.
|
- Fix also threaded inferiors for hardware watchpoints after the fork call.
|
||||||
- Test debugging statically linked threaded inferiors (BZ 239652).
|
- Test debugging statically linked threaded inferiors (BZ 239652).
|
||||||
|
Loading…
Reference in New Issue
Block a user