- Fix also threaded inferiors for hardware watchpoints after the fork call.
- Test debugging statically linked threaded inferiors (BZ 239652). - It requires recent glibc to work in this case properly. - Testcase cleanup fixup of the gcore memory and time requirements of 6.7.1-8.
This commit is contained in:
parent
3f52bbd141
commit
d945816097
@ -42,7 +42,7 @@ diff -u -X /home/jkratoch/.diffi.list -ruNp gdb-6.5/gdb/testsuite/gdb.base/gcore
|
||||
diff -u -X /home/jkratoch/.diffi.list -ruNp gdb-6.5/gdb/testsuite/gdb.base/gcore-excessive-memory.exp gdb-6.5-unknown/gdb/testsuite/gdb.base/gcore-excessive-memory.exp
|
||||
--- gdb-6.5/gdb/testsuite/gdb.base/gcore-excessive-memory.exp 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ gdb-6.5-unknown/gdb/testsuite/gdb.base/gcore-excessive-memory.exp 2008-01-08 11:47:32.000000000 +0100
|
||||
@@ -0,0 +1,98 @@
|
||||
@@ -0,0 +1,101 @@
|
||||
+# Copyright 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
@ -141,3 +141,6 @@ diff -u -X /home/jkratoch/.diffi.list -ruNp gdb-6.5/gdb/testsuite/gdb.base/gcore
|
||||
+gdb_test "gcore $corefile" "Saved corefile \[^\n\r\]*" "Save the core file"
|
||||
+
|
||||
+verbose -log "kb_found after gcore = [expr [memory_v_pages_get] * $pagesize / 1024]"
|
||||
+
|
||||
+# Cleanup.
|
||||
+exec kill -9 $pid_of_bin
|
||||
|
File diff suppressed because it is too large
Load Diff
25
gdb-6.6-threads-static-test.patch
Normal file
25
gdb-6.6-threads-static-test.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- gdb-6.6/gdb/testsuite/gdb.threads/staticthreads.exp-orig 2005-04-30 21:56:47.000000000 +0200
|
||||
+++ gdb-6.6/gdb/testsuite/gdb.threads/staticthreads.exp 2008-01-11 14:30:15.000000000 +0100
|
||||
@@ -44,9 +44,21 @@ gdb_load ${binfile}
|
||||
gdb_test "set print sevenbit-strings" ""
|
||||
|
||||
|
||||
+runto_main
|
||||
+
|
||||
+# See if we get excessive LWP there (patched glibc with unpatched GDB):
|
||||
+# * 2 Thread 135661664 (LWP 3856) main () at threadloop.c:41
|
||||
+# 1 process 3856 main () at threadloop.c:41
|
||||
+
|
||||
+set test "info threads on start"
|
||||
+gdb_test_multiple "info threads" "$test" {
|
||||
+ -re "^info threads\r?\n\[^\r\n\]* Thread \[^\r\n\]*\r?\n$gdb_prompt" {
|
||||
+ pass "$test"
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
# See if the static multi-threaded program runs.
|
||||
|
||||
-runto_main
|
||||
gdb_test "break sem_post"
|
||||
set test "Continue to main's call of sem_post"
|
||||
gdb_test_multiple "continue" "$test" {
|
15
gdb.spec
15
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
||||
Version: 6.7.1
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
@ -316,6 +316,8 @@ Patch277: gdb-6.6-vdso-i386-on-amd64-warning.patch
|
||||
Patch278: gdb-6.6-cu-ranges.patch
|
||||
|
||||
# Fix hardware watchpoints after inferior forks-off some process.
|
||||
# Threaded `set follow-fork-mode child' still not fixed there, glibc fixes reqd.
|
||||
# `set detach-on-fork off' not fixed there in general - it already assert-fails.
|
||||
Patch280: gdb-6.6-multifork-debugreg.patch
|
||||
|
||||
# Fix displaying of numeric char arrays as strings (BZ 224128).
|
||||
@ -340,6 +342,10 @@ Patch294: gdb-6.7-bz426600-DW_TAG_interface_type-test.patch
|
||||
# Test gcore memory and time requirements for large inferiors.
|
||||
Patch296: gdb-6.5-gcore-buffer-limit-test.patch
|
||||
|
||||
# Test debugging statically linked threaded inferiors (BZ 239652).
|
||||
# - It requires recent glibc to work in this case properly.
|
||||
Patch298: gdb-6.6-threads-static-test.patch
|
||||
|
||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu gettext
|
||||
BuildRequires: flex bison sharutils expat-devel
|
||||
Requires: readline
|
||||
@ -491,6 +497,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch293 -p1
|
||||
%patch294 -p1
|
||||
%patch296 -p1
|
||||
%patch298 -p1
|
||||
|
||||
# Change the version that gets printed at GDB startup, so it is RedHat
|
||||
# specific.
|
||||
@ -648,6 +655,12 @@ fi
|
||||
# don't include the files in include, they are part of binutils
|
||||
|
||||
%changelog
|
||||
* Sat Jan 12 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-9
|
||||
- Fix also threaded inferiors for hardware watchpoints after the fork call.
|
||||
- Test debugging statically linked threaded inferiors (BZ 239652).
|
||||
- It requires recent glibc to work in this case properly.
|
||||
- Testcase cleanup fixup of the gcore memory and time requirements of 6.7.1-8.
|
||||
|
||||
* Thu Jan 10 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-8
|
||||
- Fix detaching from a threaded formerly stopped process with non-primary
|
||||
thread currently active (general BZ 233852).
|
||||
|
Loading…
Reference in New Issue
Block a user