4.4.1-15
This commit is contained in:
parent
dad43f9003
commit
ef4f83143f
@ -1,2 +1,2 @@
|
||||
fastjar-0.97.tar.gz
|
||||
gcc-4.4.1-20090916.tar.bz2
|
||||
gcc-4.4.1-20090918.tar.bz2
|
||||
|
15
gcc.spec
15
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20090916
|
||||
%global SVNREV 151746
|
||||
%global DATE 20090918
|
||||
%global SVNREV 151835
|
||||
%global gcc_version 4.4.1
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 14
|
||||
%global gcc_release 15
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%global include_gappletviewer 1
|
||||
@ -162,7 +162,7 @@ Patch18: gcc44-libstdc++-docs.patch
|
||||
Patch19: gcc44-vta-cfgexpand-ptr-mode-pr41248.patch
|
||||
Patch20: gcc44-powerpc-libgcc_s_so.patch
|
||||
Patch21: gcc44-pr41175.patch
|
||||
Patch22: gcc44-rh518303.patch
|
||||
Patch22: gcc44-ppc64-aixdesc.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
|
||||
@ -471,7 +471,7 @@ which are required to compile with the GNAT.
|
||||
%patch19 -p0 -b .vta-cfgexpand-ptr-mode-pr41248~
|
||||
%patch20 -p0 -b .powerpc-libgcc_s_so~
|
||||
%patch21 -p0 -b .pr41175~
|
||||
%patch22 -p0 -b .rh518303~
|
||||
%patch22 -p0 -b .ppc64-aixdesc~
|
||||
|
||||
# This testcase doesn't compile.
|
||||
rm libjava/testsuite/libjava.lang/PR35020*
|
||||
@ -1827,6 +1827,11 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Fri Sep 18 2009 Jakub Jelinek <jakub@redhat.com> 4.4.1-15
|
||||
- for now disable out of line gpr/fpr saving on ppc with -m64 -Os -mcall-aixdesc
|
||||
- fix DW_AT_decl_{file,location} for DW_TAG_structure_type for C structs
|
||||
with forward declarations (#523810)
|
||||
|
||||
* Wed Sep 16 2009 Jakub Jelinek <jakub@redhat.com> 4.4.1-14
|
||||
- update from gcc-4_4-branch
|
||||
- PRs fortran/39876, tree-optimization/41101
|
||||
|
24
gcc44-ppc64-aixdesc.patch
Normal file
24
gcc44-ppc64-aixdesc.patch
Normal file
@ -0,0 +1,24 @@
|
||||
2009-09-16 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* config/rs6000/sysv4.h (FP_SAVE_INLINE, GP_SAVE_INLINE): Disable
|
||||
out of line gpr/fpr saving for -m64 -Os -mcall-aixdesc.
|
||||
|
||||
--- gcc/config/rs6000/sysv4.h.jj 2009-09-16 14:46:19.000000000 +0200
|
||||
+++ gcc/config/rs6000/sysv4.h 2009-09-16 14:46:19.000000000 +0200
|
||||
@@ -273,12 +273,14 @@ do { \
|
||||
/* Define cutoff for using external functions to save floating point.
|
||||
When optimizing for size, use external functions when profitable. */
|
||||
#define FP_SAVE_INLINE(FIRST_REG) (optimize_size \
|
||||
+ && (!TARGET_64BIT || !DOT_SYMBOLS) \
|
||||
? ((FIRST_REG) == 62 \
|
||||
|| (FIRST_REG) == 63) \
|
||||
: (FIRST_REG) < 64)
|
||||
/* And similarly for general purpose registers. */
|
||||
-#define GP_SAVE_INLINE(FIRST_REG) ((FIRST_REG) < 32 \
|
||||
- && !optimize_size)
|
||||
+#define GP_SAVE_INLINE(FIRST_REG) ((FIRST_REG) < 32 \
|
||||
+ && (!optimize_size \
|
||||
+ || (TARGET_64BIT && DOT_SYMBOLS)))
|
||||
|
||||
/* Put jump tables in read-only memory, rather than in .text. */
|
||||
#define JUMP_TABLES_IN_TEXT_SECTION 0
|
@ -1,30 +0,0 @@
|
||||
2009-09-09 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* integrate.c (set_block_abstract_flags): Call
|
||||
set_decl_abstract_flags also on BLOCK_NONLOCALIZED_VARs.
|
||||
|
||||
--- gcc/integrate.c.jj 2009-03-04 12:12:03.000000000 +0100
|
||||
+++ gcc/integrate.c 2009-09-09 18:07:07.000000000 +0200
|
||||
@@ -167,6 +167,7 @@ set_block_abstract_flags (tree stmt, int
|
||||
{
|
||||
tree local_decl;
|
||||
tree subblock;
|
||||
+ unsigned int i;
|
||||
|
||||
BLOCK_ABSTRACT (stmt) = setting;
|
||||
|
||||
@@ -175,6 +176,14 @@ set_block_abstract_flags (tree stmt, int
|
||||
local_decl = TREE_CHAIN (local_decl))
|
||||
set_decl_abstract_flags (local_decl, setting);
|
||||
|
||||
+ for (i = 0; i < BLOCK_NUM_NONLOCALIZED_VARS (stmt); i++)
|
||||
+ {
|
||||
+ local_decl = BLOCK_NONLOCALIZED_VAR (stmt, i);
|
||||
+ if ((TREE_CODE (local_decl) == VAR_DECL && !TREE_STATIC (local_decl))
|
||||
+ || TREE_CODE (local_decl) == PARM_DECL)
|
||||
+ set_decl_abstract_flags (local_decl, setting);
|
||||
+ }
|
||||
+
|
||||
for (subblock = BLOCK_SUBBLOCKS (stmt);
|
||||
subblock != NULL_TREE;
|
||||
subblock = BLOCK_CHAIN (subblock))
|
Loading…
Reference in New Issue
Block a user