7.1.1-4
This commit is contained in:
parent
dcf86feb99
commit
e7ba2ccc61
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
||||
/gcc-7.1.1-20170503.tar.bz2
|
||||
/gcc-7.1.1-20170526.tar.bz2
|
||||
/gcc-7.1.1-20170622.tar.bz2
|
||||
/gcc-7.1.1-20170708.tar.bz2
|
||||
|
22
gcc.spec
22
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20170622
|
||||
%global SVNREV 249497
|
||||
%global DATE 20170708
|
||||
%global SVNREV 250082
|
||||
%global gcc_version 7.1.1
|
||||
%global gcc_major 7
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 3
|
||||
%global gcc_release 4
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -232,6 +232,7 @@ Patch8: gcc7-no-add-needed.patch
|
||||
Patch9: gcc7-aarch64-async-unw-tables.patch
|
||||
Patch10: gcc7-foffload-default.patch
|
||||
Patch11: gcc7-Wno-format-security.patch
|
||||
Patch12: gcc7-rh1467526.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -821,6 +822,7 @@ package or when debugging this package.
|
||||
%patch9 -p0 -b .aarch64-async-unw-tables~
|
||||
%patch10 -p0 -b .foffload-default~
|
||||
%patch11 -p0 -b .Wno-format-security~
|
||||
%patch12 -p0 -b .rh1467526~
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
@ -3238,6 +3240,20 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Jul 8 2017 Jakub Jelinek <jakub@redhat.com> 7.1.1-4
|
||||
- update from the 7 branch
|
||||
- PRs c++/54769, c++/61022, c++/72801, c++/79056, c++/81164, c++/81180,
|
||||
c++/81187, c++/81188, c++/81204, c++/81215, c++/81257, driver/31468,
|
||||
driver/56469, gcov-profile/53915, gcov-profile/81080, ipa/79849,
|
||||
ipa/79850, ipa/80663, ipa/81112, libfortran/81195, libgfortran/53029,
|
||||
libstdc++/81221, middle-end/80692, middle-end/80902, middle-end/81007,
|
||||
middle-end/81207, other/80589, other/80909, sanitizer/80879,
|
||||
sanitizer/81209, target/79155, target/79799, target/80618,
|
||||
target/80966, target/81294, target/81300, target/81305, target/81348,
|
||||
tree-optimization/80612, tree-optimization/81083,
|
||||
tree-optimization/81192
|
||||
- fix ppc* float128 ifunc (#1467526)
|
||||
|
||||
* Thu Jun 22 2017 Jakub Jelinek <jakub@redhat.com> 7.1.1-3
|
||||
- update from the 7 branch
|
||||
- PRs ada/80921, ada/81070, ada/81105, c++/60063, c++/66297, c++/70844,
|
||||
|
57
gcc7-rh1467526.patch
Normal file
57
gcc7-rh1467526.patch
Normal file
@ -0,0 +1,57 @@
|
||||
2017-07-07 Peter Bergner <bergner@vnet.ibm.com>
|
||||
|
||||
* config/rs6000/float128-ifunc.c: Don't include auxv.h.
|
||||
(have_ieee_hw_p): Delete function.
|
||||
(SW_OR_HW) Use __builtin_cpu_supports().
|
||||
|
||||
--- libgcc/config/rs6000/float128-ifunc.c (revision 250060)
|
||||
+++ libgcc/config/rs6000/float128-ifunc.c (revision 250061)
|
||||
@@ -45,47 +45,7 @@
|
||||
#error "This module must not be compiled with IEEE 128-bit hardware support"
|
||||
#endif
|
||||
|
||||
-#include <sys/auxv.h>
|
||||
-
|
||||
-/* Use the namespace clean version of getauxval. However, not all versions of
|
||||
- sys/auxv.h declare it, so declare it here. This code is intended to be
|
||||
- temporary until a suitable version of __builtin_cpu_supports is added that
|
||||
- allows us to tell quickly if the machine supports IEEE 128-bit hardware. */
|
||||
-extern unsigned long __getauxval (unsigned long);
|
||||
-
|
||||
-static int
|
||||
-have_ieee_hw_p (void)
|
||||
-{
|
||||
- static int ieee_hw_p = -1;
|
||||
-
|
||||
- if (ieee_hw_p < 0)
|
||||
- {
|
||||
- char *p = (char *) __getauxval (AT_PLATFORM);
|
||||
-
|
||||
- ieee_hw_p = 0;
|
||||
-
|
||||
- /* Don't use atoi/strtol/strncmp/etc. These may require the normal
|
||||
- environment to be setup to set errno to 0, and the ifunc resolvers run
|
||||
- before the whole glibc environment is initialized. */
|
||||
- if (p && p[0] == 'p' && p[1] == 'o' && p[2] == 'w' && p[3] == 'e'
|
||||
- && p[4] == 'r')
|
||||
- {
|
||||
- long n = 0;
|
||||
- char ch;
|
||||
-
|
||||
- p += 5;
|
||||
- while ((ch = *p++) >= '0' && (ch <= '9'))
|
||||
- n = (n * 10) + (ch - '0');
|
||||
-
|
||||
- if (n >= 9)
|
||||
- ieee_hw_p = 1;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- return ieee_hw_p;
|
||||
-}
|
||||
-
|
||||
-#define SW_OR_HW(SW, HW) (have_ieee_hw_p () ? HW : SW)
|
||||
+#define SW_OR_HW(SW, HW) (__builtin_cpu_supports ("ieee128") ? HW : SW)
|
||||
|
||||
/* Resolvers. */
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-7.1.1-20170622.tar.bz2) = 55de9c43036acfffd2ef77ee93c4c54f7f50b63611108a12c7a01b17e71a38f54e8ceb3866041c6c385f98ad974c7e969686856a2134d18a5c170c91317b2f41
|
||||
SHA512 (gcc-7.1.1-20170708.tar.bz2) = 30a93b618f0288e8e9741c253cb5ea35fee150eaca4418d3467aff2b3a4eec8e2728ee40610ef38fba123abd7960b53dce42b7f2aff7f17d6beedb25cd73f1c9
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.bz2) = 38f97c9297ad108568352a4d28277455a3c01fd8b7864e798037e5006b6f757022e874bbf3f165775fe3b873781bc108137bbeb42dd5ed3c7d3e6747746fa918
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.bz2) = 95b577a06a93bb044dbc8033e550cb36bcf2ab2687da030a7318cdc90e7467ed49665e247dcafb5ff4a7e92cdc264291d19728bd17fab902fb64b22491269330
|
||||
|
Loading…
Reference in New Issue
Block a user