4.7.0-0.3
This commit is contained in:
parent
a539bf4094
commit
e1c663c977
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/gcc-4.6.1-20110708.tar.bz2
|
||||
/gcc-4.6.1-20110715.tar.bz2
|
||||
/gcc-4.7.0-20120103.tar.bz2
|
||||
/gcc-4.7.0-20120104.tar.bz2
|
||||
|
17
gcc.spec
17
gcc.spec
@ -1,8 +1,10 @@
|
||||
%global DATE 20120103
|
||||
%global SVNREV 182847
|
||||
%global DATE 20120104
|
||||
%global SVNREV 182887
|
||||
%global gcc_version 4.7.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
# Please keep gcc_release at 0 while gcc-%{gcc_version} hasn't
|
||||
# been released yet, instead increment the digit in Release:.
|
||||
%global gcc_release 0
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
@ -46,7 +48,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, Java, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.2%{?dist}
|
||||
Release: %{gcc_release}.3%{?dist}
|
||||
# libgcc, libgfortran, libmudflap, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -170,6 +172,7 @@ Patch12: gcc47-libstdc++-docs.patch
|
||||
Patch13: gcc47-no-add-needed.patch
|
||||
Patch14: gcc47-ppl-0.10.patch
|
||||
Patch15: gcc47-libitm-fno-exceptions.patch
|
||||
Patch16: gcc47-pr51746.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -669,6 +672,7 @@ package or when debugging this package.
|
||||
%patch14 -p0 -b .ppl-0.10~
|
||||
%endif
|
||||
%patch15 -p0 -b .libitm-fno-exceptions~
|
||||
%patch16 -p0 -b .pr51746~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -2614,6 +2618,13 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Wed Jan 4 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-0.3
|
||||
- update from trunk
|
||||
- PRs bootstrap/51006, bootstrap/51734, c++/29273, c++/51064, c++/51738,
|
||||
debug/51695, fortran/49693, fortran/50981, middle-end/51696,
|
||||
middle-end/51750, other/51163, other/51164, tree-optimization/49651
|
||||
- fix up libitm.so.1
|
||||
|
||||
* Tue Jan 3 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-0.2
|
||||
- update from trunk
|
||||
- PRs bootstrap/51686, bootstrap/51725, c++/15867, c++/16603, c++/20140,
|
||||
|
@ -6,21 +6,23 @@
|
||||
|
||||
--- libitm/Makefile.am.jj 2011-12-20 13:47:57.000000000 +0100
|
||||
+++ libitm/Makefile.am 2011-12-22 09:14:06.663469165 +0100
|
||||
@@ -72,6 +72,7 @@ endif
|
||||
@@ -72,6 +72,8 @@ endif
|
||||
if ARCH_X86_AVX
|
||||
x86_avx.lo : XCFLAGS += -mavx
|
||||
endif
|
||||
+beginend.lo : CXXFLAGS += -fno-exceptions
|
||||
+beginend.lo : CXXCOMPILE += -fno-exceptions
|
||||
+beginend.lo : LTCXXCOMPILE += -fno-exceptions
|
||||
|
||||
if ARCH_FUTEX
|
||||
libitm_la_SOURCES += futex.cc
|
||||
--- libitm/Makefile.in.jj 2011-12-20 13:47:57.000000000 +0100
|
||||
+++ libitm/Makefile.in 2011-12-22 09:14:29.466329944 +0100
|
||||
@@ -1278,6 +1278,7 @@ vpath % $(strip $(search_path))
|
||||
@@ -1278,6 +1278,8 @@ vpath % $(strip $(search_path))
|
||||
@LIBITM_BUILD_VERSIONED_SHLIB_SUN_TRUE@@LIBITM_BUILD_VERSIONED_SHLIB_TRUE@ > $@ || (rm -f $@ ; exit 1)
|
||||
@ARCH_X86_TRUE@x86_sse.lo : XCFLAGS += -msse
|
||||
@ARCH_X86_AVX_TRUE@x86_avx.lo : XCFLAGS += -mavx
|
||||
+beginend.lo : CXXFLAGS += -fno-exceptions
|
||||
+beginend.lo : CXXCOMPILE += -fno-exceptions
|
||||
+beginend.lo : LTCXXCOMPILE += -fno-exceptions
|
||||
|
||||
all-local: $(STAMP_GENINSRC)
|
||||
|
||||
|
16
gcc47-pr51746.patch
Normal file
16
gcc47-pr51746.patch
Normal file
@ -0,0 +1,16 @@
|
||||
2012-01-04 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR debug/51746
|
||||
* var-tracking.c (add_stores): For COND_EXEC allow oval to be NULL.
|
||||
|
||||
--- gcc/var-tracking.c.jj 2012-01-01 19:54:46.000000000 +0100
|
||||
+++ gcc/var-tracking.c 2012-01-04 11:30:44.033223790 +0100
|
||||
@@ -5519,7 +5519,7 @@ add_stores (rtx loc, const_rtx expr, voi
|
||||
gcc_assert (oval != v);
|
||||
gcc_assert (REG_P (oloc) || MEM_P (oloc));
|
||||
|
||||
- if (!cselib_preserved_value_p (oval))
|
||||
+ if (oval && !cselib_preserved_value_p (oval))
|
||||
{
|
||||
micro_operation moa;
|
||||
|
Loading…
Reference in New Issue
Block a user