9.0.1-0.6
This commit is contained in:
parent
d228ee264c
commit
e0c920a406
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@
|
||||
/gcc-9.0.1-20190209.tar.xz
|
||||
/gcc-9.0.1-20190215.tar.xz
|
||||
/gcc-9.0.1-20190219.tar.xz
|
||||
/gcc-9.0.1-20190221.tar.xz
|
||||
|
21
gcc.spec
21
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20190219
|
||||
%global SVNREV 269023
|
||||
%global DATE 20190221
|
||||
%global SVNREV 269078
|
||||
%global gcc_version 9.0.1
|
||||
%global gcc_major 9
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 0.6
|
||||
%global gcc_release 0.7
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -256,9 +256,6 @@ Patch10: gcc9-rh1574936.patch
|
||||
Patch11: gcc9-d-shared-libphobos.patch
|
||||
Patch12: gcc9-pr89014.patch
|
||||
Patch13: gcc9-pr89093.patch
|
||||
Patch14: gcc9-s390x-bootstrap-fix.patch
|
||||
Patch15: gcc9-pr88714.patch
|
||||
Patch16: gcc9-pr89402.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -771,9 +768,6 @@ to NVidia PTX capable devices if available.
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr89014~
|
||||
%patch13 -p0 -b .pr89093~
|
||||
%patch14 -p0 -b .s390x-bootstrap~
|
||||
%patch15 -p0 -b .pr88714~
|
||||
%patch16 -p0 -b .pr89402~
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
@ -2962,6 +2956,15 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Feb 21 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.6
|
||||
- update from trunk
|
||||
- PRs c++/84536, c++/87513, c++/87921, c++/88368, c++/88380, c++/88572,
|
||||
c++/88690, c++/89403, c++/89405, c/89410, fortran/86119,
|
||||
fortran/89384, hsa/89302, libstdc++/89402, libstdc++/89416,
|
||||
middle-end/89091, middle-end/89392, middle-end/89412,
|
||||
middle-end/89415, sanitizer/89409, target/86487, target/87412,
|
||||
target/88100
|
||||
|
||||
* Tue Feb 19 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.6
|
||||
- update from trunk
|
||||
- PRs c++/88680, c++/89217, c++/89315, c++/89336, c++/89356, c++/89383,
|
||||
|
@ -1,39 +0,0 @@
|
||||
2019-02-18 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR bootstrap/88714
|
||||
* constraints.md (q): Remove.
|
||||
* config/arm/ldrdstrd.md (*arm_ldrd, *arm_strd): Use rk constraint
|
||||
instead of q.
|
||||
|
||||
--- gcc/config/arm/constraints.md.jj 2019-01-01 12:37:27.032812929 +0100
|
||||
+++ gcc/config/arm/constraints.md 2019-02-18 20:18:51.816941795 +0100
|
||||
@@ -90,9 +90,6 @@ (define_constraint "PJ"
|
||||
(define_register_constraint "k" "STACK_REG"
|
||||
"@internal The stack register.")
|
||||
|
||||
-(define_register_constraint "q" "(TARGET_ARM && TARGET_LDRD) ? CORE_REGS : GENERAL_REGS"
|
||||
- "@internal In ARM state with LDRD support, core registers, otherwise general registers.")
|
||||
-
|
||||
(define_register_constraint "b" "TARGET_THUMB ? BASE_REGS : NO_REGS"
|
||||
"@internal
|
||||
Thumb only. The union of the low registers and the stack register.")
|
||||
--- gcc/config/arm/ldrdstrd.md.jj 2019-02-18 20:19:34.976233961 +0100
|
||||
+++ gcc/config/arm/ldrdstrd.md 2019-02-18 20:19:54.555912842 +0100
|
||||
@@ -159,7 +159,7 @@ (define_peephole2 ; swap the destination
|
||||
(define_insn "*arm_ldrd"
|
||||
[(parallel [(set (match_operand:SI 0 "s_register_operand" "=r")
|
||||
(match_operand:SI 2 "memory_operand" "m"))
|
||||
- (set (match_operand:SI 1 "s_register_operand" "=q")
|
||||
+ (set (match_operand:SI 1 "s_register_operand" "=rk")
|
||||
(match_operand:SI 3 "memory_operand" "m"))])]
|
||||
"TARGET_LDRD && TARGET_ARM && reload_completed
|
||||
&& valid_operands_ldrd_strd (operands, true)"
|
||||
@@ -180,7 +180,7 @@ (define_insn "*arm_strd"
|
||||
[(parallel [(set (match_operand:SI 2 "memory_operand" "=m")
|
||||
(match_operand:SI 0 "s_register_operand" "r"))
|
||||
(set (match_operand:SI 3 "memory_operand" "=m")
|
||||
- (match_operand:SI 1 "s_register_operand" "q"))])]
|
||||
+ (match_operand:SI 1 "s_register_operand" "rk"))])]
|
||||
"TARGET_LDRD && TARGET_ARM && reload_completed
|
||||
&& valid_operands_ldrd_strd (operands, false)"
|
||||
{
|
@ -1,16 +0,0 @@
|
||||
2019-02-19 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR libstdc++/89402
|
||||
* src/c++98/compatibility-ldbl.cc (_ZNKSt4hashIeEclEe): Add
|
||||
_GLIBCXX_PURE to the alias declaration.
|
||||
|
||||
--- libstdc++-v3/src/c++98/compatibility-ldbl.cc.jj 2019-01-01 12:39:41.530606161 +0100
|
||||
+++ libstdc++-v3/src/c++98/compatibility-ldbl.cc 2019-02-19 16:12:52.402123217 +0100
|
||||
@@ -75,6 +75,6 @@ namespace std _GLIBCXX_VISIBILITY(defaul
|
||||
// and std::hash<long double>::operator()
|
||||
// are the same, no need to duplicate them.
|
||||
extern "C" void _ZNKSt4hashIeEclEe (void)
|
||||
- __attribute__((alias ("_ZNKSt3tr14hashIeEclEe")));
|
||||
+ _GLIBCXX_PURE __attribute__((alias ("_ZNKSt3tr14hashIeEclEe")));
|
||||
|
||||
#endif
|
@ -1,17 +0,0 @@
|
||||
--- libgo/go/internal/cpu/cpu_gccgo.c.jj 2019-02-16 07:57:27.882179972 +0100
|
||||
+++ libgo/go/internal/cpu/cpu_gccgo.c 2019-02-16 08:36:37.241900882 +0100
|
||||
@@ -71,7 +71,7 @@ struct xgetbv_ret xgetbv(void) {
|
||||
|
||||
#endif /* defined(__i386__) || defined(__x86_64__) */
|
||||
|
||||
-#ifdef __s390__
|
||||
+#ifdef __s390x__
|
||||
|
||||
struct facilityList {
|
||||
uint64_t bits[4];
|
||||
@@ -184,4 +184,4 @@ struct queryResult klmdQuery() {
|
||||
return ret;
|
||||
}
|
||||
|
||||
-#endif /* defined(__s390__) */
|
||||
+#endif /* defined(__s390x__) */
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-9.0.1-20190219.tar.xz) = 5c4b8f38bc87c19337cb4b7fdbc4910eefabc43f06f4224087f7b4879750722a0b508cd214f0ac880c23ed8f8deb803442cbbe1e7ea6f8f24c6a6365e8d0a1a7
|
||||
SHA512 (gcc-9.0.1-20190221.tar.xz) = 2a83371869c2b5cc52b789236db2a55cf59294e0a8e7ae1e44d4dac873bbecd7daa33bcd15c0a7bce2941f8c68329de1f88d6ac09effb3c9e04f76902227a3b9
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
||||
|
Loading…
Reference in New Issue
Block a user