13.0.1-0.11
This commit is contained in:
parent
85fff34818
commit
dc8f6e461b
1
.gitignore
vendored
1
.gitignore
vendored
@ -97,3 +97,4 @@
|
||||
/gcc-13.0.1-20230321.tar.xz
|
||||
/nvptx-tools-93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b.tar.xz
|
||||
/gcc-13.0.1-20230324.tar.xz
|
||||
/gcc-13.0.1-20230329.tar.xz
|
||||
|
26
gcc.spec
26
gcc.spec
@ -1,5 +1,5 @@
|
||||
%global DATE 20230324
|
||||
%global gitrev 053e16ff35e0921f66d5b48f2b2e4a51eca89e43
|
||||
%global DATE 20230329
|
||||
%global gitrev 5864cb72cba24f25ae864298e85b553f0cadee5d
|
||||
%global gcc_version 13.0.1
|
||||
%global gcc_major 13
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
@ -136,7 +136,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.10%{?dist}
|
||||
Release: %{gcc_release}.11%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -286,7 +286,6 @@ Patch8: gcc13-no-add-needed.patch
|
||||
Patch9: gcc13-Wno-format-security.patch
|
||||
Patch10: gcc13-rh1574936.patch
|
||||
Patch11: gcc13-d-shared-libphobos.patch
|
||||
Patch12: gcc13-pr109230.patch
|
||||
|
||||
Patch50: isl-rh2155127.patch
|
||||
|
||||
@ -863,7 +862,6 @@ so that there cannot be any synchronization problems.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr109230~
|
||||
|
||||
%patch50 -p0 -b .rh2155127~
|
||||
touch -r isl-0.24/m4/ax_prog_cxx_for_build.m4 isl-0.24/m4/ax_prog_cc_for_build.m4
|
||||
@ -3460,6 +3458,24 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Mar 29 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.11
|
||||
- update from trunk
|
||||
- PRs analyzer/109098, bootstrap/84402, bootstrap/109310, c++/105481,
|
||||
c++/106969, c++/107163, c++/109309, c++/109320, c++/109321, c/107002,
|
||||
fortran/104321, fortran/104949, fortran/109314, gcov-profile/109297,
|
||||
ipa/105685, ipa/106124, libgcc/108891, libstdc++/103387,
|
||||
libstdc++/109288, libstdc++/109299, lto/109263, middle-end/106190,
|
||||
other/109163, other/109293, rtl-optimization/109187,
|
||||
rtl-optimization/109237, target/106282, target/109072, target/109082,
|
||||
target/109140, target/109167, target/109276, target/109296,
|
||||
target/109312, tree-optimization/54498, tree-optimization/106912,
|
||||
tree-optimization/107087, tree-optimization/108129,
|
||||
tree-optimization/108357, tree-optimization/109154,
|
||||
tree-optimization/109230, tree-optimization/109238,
|
||||
tree-optimization/109265, tree-optimization/109274,
|
||||
tree-optimization/109301, tree-optimization/109327,
|
||||
tree-optimization/109331
|
||||
|
||||
* Fri Mar 24 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.10
|
||||
- update from trunk
|
||||
- PRs analyzer/109239, c++/105996, c++/108390, c++/108795, c++/109177,
|
||||
|
@ -1,51 +0,0 @@
|
||||
2023-03-21 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR tree-optimization/109230
|
||||
* match.pd (fneg/fadd simplify): Verify also odd permutation indexes.
|
||||
|
||||
* gcc.dg/pr109230.c: New test.
|
||||
|
||||
--- gcc/match.pd.jj 2023-02-18 12:38:30.967022708 +0100
|
||||
+++ gcc/match.pd 2023-03-21 19:59:40.209634256 +0100
|
||||
@@ -8096,6 +8096,7 @@ and,
|
||||
scalar_mode inner_mode = GET_MODE_INNER (vec_mode);
|
||||
}
|
||||
(if (sel.series_p (0, 2, 0, 2)
|
||||
+ && sel.series_p (1, 2, nelts + 1, 2)
|
||||
&& GET_MODE_2XWIDER_MODE (inner_mode).exists (&wide_elt_mode)
|
||||
&& multiple_p (GET_MODE_NUNITS (vec_mode), 2, &wide_nunits)
|
||||
&& related_vector_mode (vec_mode, wide_elt_mode,
|
||||
--- gcc/testsuite/gcc.dg/pr109230.c.jj 2023-03-21 20:03:52.811979268 +0100
|
||||
+++ gcc/testsuite/gcc.dg/pr109230.c 2023-03-21 20:03:35.884224342 +0100
|
||||
@@ -0,0 +1,31 @@
|
||||
+/* PR tree-optimization/109230 */
|
||||
+/* { dg-do run } */
|
||||
+/* { dg-options "-O2 -Wno-psabi" } */
|
||||
+
|
||||
+#if __SIZEOF_FLOAT__ == __SIZEOF_INT__
|
||||
+typedef float V __attribute__((vector_size (4 * sizeof (float))));
|
||||
+typedef int VI __attribute__((vector_size (4 * sizeof (float))));
|
||||
+
|
||||
+__attribute__((noipa)) V
|
||||
+foo (V x, V y)
|
||||
+{
|
||||
+ V a = x - y;
|
||||
+ V b = y + x;
|
||||
+ return __builtin_shuffle (b, a, (VI) { 0, 5, 2, 3 });
|
||||
+}
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ V a = (V) { 1.0f, 2.0f, 3.0f, 4.0f };
|
||||
+ V b = (V) { 8.0f, 9.0f, 10.0f, 11.0f };
|
||||
+ V c = foo (a, b);
|
||||
+ if (c[0] != 9.0f || c[1] != -7.0f || c[2] != 13.0f || c[3] != 15.0f)
|
||||
+ __builtin_abort ();
|
||||
+}
|
||||
+#else
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+}
|
||||
+#endif
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-13.0.1-20230324.tar.xz) = 17f0cdd640232508d316cc02664a2e159a97fa2253b3884862f97f02e60bed45630dfd1811472fdc2215d094a2ac3e7cd05011364f069ca14f741db055d6cd9f
|
||||
SHA512 (gcc-13.0.1-20230329.tar.xz) = 58a45335495f2c15c569ee6594bdf1b99a0ee57df01b268b2682b8d219d306e377aa019925ee59936eb0c464cba63c42e8f23e912f13ba9209642a3f74f95d42
|
||||
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
||||
SHA512 (newlib-cygwin-9e09d6ed83cce4777a5950412647ccc603040409.tar.xz) = bef3fa04f7b1a915fc1356ebed114698b5cc835e9fa04b0becff05a9efc76c59fb376482990873d222d7acdcfee3c4f30f5a4cb7f3be1f291f1fa5f1c7a9d983
|
||||
SHA512 (nvptx-tools-93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b.tar.xz) = c719fad8689b2b6f3c888d0308604ddef884037d71ec3e755c68052d30075a181c29358fda516833ace437921b17602b147be7886317be94ec9736faa8cb52be
|
||||
|
Loading…
Reference in New Issue
Block a user