Update from Fedora gcc 11.2.1-1.
Also enable LTO profilebootstrap. Resolves: #1986141, #1986836
This commit is contained in:
parent
e718b9dd90
commit
d4ddc0e23f
22
gcc.spec
22
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20210623
|
||||
%global gitrev cab23df287db6bf4e3d8207e72726b40a4b11058
|
||||
%global gcc_version 11.1.1
|
||||
%global DATE 20210728
|
||||
%global gitrev 134ab8155c937122663513b76afa8e64ad61fe99
|
||||
%global gcc_version 11.2.1
|
||||
%global gcc_major 11
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 6
|
||||
%global gcc_release 1
|
||||
%global nvptx_tools_gitrev 5f6f343a302d620b0868edab376c00b15741e39e
|
||||
%global newlib_cygwin_gitrev 50e2a63b04bdd018484605fbb954fd1bd5147fa0
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -119,7 +119,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.1%{?dist}
|
||||
Release: %{gcc_release}%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -1075,6 +1075,11 @@ CONFIGURE_OPTS="\
|
||||
%endif
|
||||
%ifnarch sparc sparcv9 ppc
|
||||
--build=%{gcc_target_platform} \
|
||||
%endif
|
||||
%if 0%{?fedora} >= 35 || 0%{?rhel} >= 9
|
||||
%ifarch x86_64 %{ix86} ppc64le s390x
|
||||
--with-build-config=bootstrap-lto --enable-link-serialization=1 \
|
||||
%endif
|
||||
%endif
|
||||
"
|
||||
|
||||
@ -3128,6 +3133,13 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jul 28 2021 Marek Polacek <polacek@redhat.com> 11.2.1-1
|
||||
- update from releases/gcc-11-branch (#1986836)
|
||||
- GCC 11.2 release
|
||||
- PRs middle-end/101586, rtl-optimization/101562
|
||||
- enable LTO profiledbootstrap on x86_64, i?86, ppc64le and s390x for rhel9
|
||||
(#1986141)
|
||||
|
||||
* Wed Jun 23 2021 David Malcolm <dmalcolm@redhat.com> 11.1.1-6.1
|
||||
- drop patch that retained broken std::call_once symbols
|
||||
(#1937700, PR libstdc++/99341)
|
||||
|
@ -16,7 +16,7 @@ libgomp/
|
||||
|
||||
--- gcc/gcc.c.jj 2017-01-17 10:28:40.000000000 +0100
|
||||
+++ gcc/gcc.c 2017-01-20 16:26:29.649962902 +0100
|
||||
@@ -290,6 +290,10 @@ static const char *spec_host_machine = D
|
||||
@@ -319,6 +319,10 @@ static const char *spec_host_machine = D
|
||||
|
||||
static char *offload_targets = NULL;
|
||||
|
||||
@ -27,7 +27,7 @@ libgomp/
|
||||
/* Nonzero if cross-compiling.
|
||||
When -b is used, the value comes from the `specs' file. */
|
||||
|
||||
@@ -4457,7 +4461,10 @@ process_command (unsigned int decoded_op
|
||||
@@ -4828,7 +4832,10 @@ process_command (unsigned int decoded_op
|
||||
/* If the user didn't specify any, default to all configured offload
|
||||
targets. */
|
||||
if (ENABLE_OFFLOADING && offload_targets == NULL)
|
||||
@ -37,9 +37,9 @@ libgomp/
|
||||
+ offload_targets_default = true;
|
||||
+ }
|
||||
|
||||
if (output_file
|
||||
&& strcmp (output_file, "-") != 0
|
||||
@@ -7693,6 +7700,8 @@ driver::maybe_putenv_OFFLOAD_TARGETS ()
|
||||
/* Handle -gtoggle as it would later in toplev.c:process_options to
|
||||
make the debug-level-gt spec function work as expected. */
|
||||
@@ -8494,6 +8501,8 @@ driver::maybe_putenv_OFFLOAD_TARGETS ()
|
||||
obstack_grow (&collect_obstack, offload_targets,
|
||||
strlen (offload_targets) + 1);
|
||||
xputenv (XOBFINISH (&collect_obstack, char *));
|
||||
|
@ -4,7 +4,7 @@
|
||||
<a class="link" href="https://www.fsf.org" target="_top">FSF
|
||||
</a>
|
||||
</p><p>
|
||||
+ Release 11.0.0
|
||||
+ Release 11.2.1
|
||||
+ </p><p>
|
||||
Permission is granted to copy, distribute and/or modify this
|
||||
document under the terms of the GNU Free Documentation
|
||||
@ -17,7 +17,7 @@
|
||||
</p><p>
|
||||
- The API documentation, rendered into HTML, can be viewed online
|
||||
+ The API documentation, rendered into HTML, can be viewed locally
|
||||
+ <a class="link" href="api/index.html" target="_top">for the 11.0.0 release</a>,
|
||||
+ <a class="link" href="api/index.html" target="_top">for the 11.2.1 release</a>,
|
||||
+ online
|
||||
<a class="link" href="http://gcc.gnu.org/onlinedocs/" target="_top">for each GCC release</a>
|
||||
and
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-11.1.1-20210623.tar.xz) = 2d639148af6a8b25127735df8fc4a29dbda3fe835caeaf1cc9d3c4373d69444f1b2c93cc751cbf19076c1ff412fcb8cfacce41c12985b0c7429260c89c62a894
|
||||
SHA512 (gcc-11.2.1-20210728.tar.xz) = 2234298652f882151aead486bb22481ba8181df69b9c7c5d73b8aa505ace58462fcd0b482680f466e2d21dc47e869651c7dbf224b65791ca47204dab01e89e7c
|
||||
SHA512 (isl-0.18.tar.bz2) = 85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94
|
||||
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
||||
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
||||
|
Loading…
Reference in New Issue
Block a user