GCC 11.4 release

Resolves: #2193180
This commit is contained in:
Marek Polacek 2023-06-06 11:23:41 -04:00
parent 6f06cfb3fc
commit c8780334e2
6 changed files with 101 additions and 20 deletions

1
.gitignore vendored
View File

@ -46,3 +46,4 @@
/gcc-11.2.1-20220401.tar.xz
/gcc-11.3.1-20220421.tar.xz
/gcc-11.3.1-20221121.tar.xz
/gcc-11.4.1-20230605.tar.xz

View File

@ -1,10 +1,10 @@
%global DATE 20221121
%global gitrev 643e61c61b308f9c572da4ccd5f730fb
%global gcc_version 11.3.1
%global DATE 20230605
%global gitrev 2c7f17ca0b642790d74cca6c798196e9053a4bcf
%global gcc_version 11.4.1
%global gcc_major 11
# Note, gcc_release must be integer, if you want to add suffixes to
# %%{release}, append them after %%{gcc_release} on Release: line.
%global gcc_release 4
%global gcc_release 2
%global nvptx_tools_gitrev 5f6f343a302d620b0868edab376c00b15741e39e
%global newlib_cygwin_gitrev 50e2a63b04bdd018484605fbb954fd1bd5147fa0
%global _unpackaged_files_terminate_build 0
@ -128,7 +128,7 @@
Summary: Various compilers (C, C++, Objective-C, ...)
Name: gcc
Version: %{gcc_version}
Release: %{gcc_release}.4%{?dist}
Release: %{gcc_release}%{?dist}
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
# GCC Runtime Exception.
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
@ -290,6 +290,7 @@ Patch26: gcc11-Wmismatched-dealloc-doc.patch
Patch27: gcc11-s390x-regarg-1.patch
Patch28: gcc11-s390x-regarg-2.patch
Patch29: gcc11-s390x-regarg-3.patch
Patch30: gcc11-testsuite-fixes.patch
Patch100: gcc11-fortran-fdec-duplicates.patch
Patch101: gcc11-fortran-flogical-as-integer.patch
@ -885,6 +886,7 @@ mark them as cross compiled.
%patch27 -p1 -b .s390x-regarg-1~
%patch28 -p1 -b .s390x-regarg-2~
%patch29 -p1 -b .s390x-regarg-3~
%patch30 -p1 -b .testsuite~
%if 0%{?rhel} >= 9
%patch100 -p1 -b .fortran-fdec-duplicates~
@ -3578,6 +3580,62 @@ end
%endif
%changelog
* Mon Jun 5 2023 Marek Polacek <polacek@redhat.com> 11.4.1-2
- update from releases/gcc-11-branch (#2193180)
- GCC 11.4 release
- PRs bootstrap/90543, c++/53932, c++/69410, c++/92752, c++/98056,
c++/98821, c++/100295, c++/100474, c++/101118, c++/101869,
c++/102780, c++/103871, c++/104527, c++/105406, c++/105996,
c++/106188, c++/106675, c++/106713, c++/106740, c++/107065,
c++/107163, c++/107179, c++/107558, c++/107579, c++/107864,
c++/108138, c++/108180, c++/108365, c++/108468, c++/108474,
c++/108607, c++/108975, c++/108998, c++/109096, c++/109164, c/107127,
c/107465, c/109151, d/107592, d/108050, d/108877, d/109108,
debug/106719, debug/108573, debug/108716, debug/108967, driver/106624,
fortran/85877, fortran/95107, fortran/96024, fortran/96025,
fortran/99036, fortran/103259, fortran/104332, fortran/106209,
fortran/106945, fortran/107576, fortran/107872, fortran/108131,
fortran/108349, fortran/108420, fortran/108421, fortran/108451,
fortran/108453, fortran/108501, fortran/108502, fortran/108527,
fortran/108529, fortran/108609, fortran/108937, fortran/109186,
fortran/109511, fortran/109846, ipa/105685, ipa/106124, ipa/107944,
libquadmath/87204, libquadmath/94756, libstdc++/91456,
libstdc++/103934, libstdc++/104866, libstdc++/104875,
libstdc++/105844, libstdc++/106183, libstdc++/107801,
libstdc++/107814, libstdc++/108030, libstdc++/108118,
libstdc++/108265, libstdc++/108636, libstdc++/108856,
libstdc++/108952, libstdc++/109064, libstdc++/109261,
libstdc++/109949, lto/109263, middle-end/104450, middle-end/104464,
middle-end/106190, middle-end/107317, middle-end/108237,
middle-end/108264, middle-end/108435, middle-end/108459,
middle-end/108546, middle-end/108625, middle-end/108685,
middle-end/108854, other/108560, other/109306,
rtl-optimization/106751, rtl-optimization/107482,
rtl-optimization/108193, rtl-optimization/108596,
rtl-optimization/109585, target/70243, target/90458, target/96373,
target/98776, target/100758, target/104871, target/104921,
target/105554, target/105599, target/106736, target/106875,
target/107568, target/107714, target/107863, target/108272,
target/108348, target/108589, target/108699, target/108807,
target/108812, target/108881, target/109067, target/109140,
target/109276, testsuite/47334, testsuite/103823, testsuite/108151,
testsuite/108973, testsuite/108985, tree-optimization/105484,
tree-optimization/106809, tree-optimization/107107,
tree-optimization/107212, tree-optimization/107254,
tree-optimization/107323, tree-optimization/107451,
tree-optimization/107554, tree-optimization/107898,
tree-optimization/107997, tree-optimization/108068,
tree-optimization/108076, tree-optimization/108095,
tree-optimization/108199, tree-optimization/108498,
tree-optimization/108688, tree-optimization/108692,
tree-optimization/108821, tree-optimization/108950,
tree-optimization/109176, tree-optimization/109410,
tree-optimization/109473, tree-optimization/109491,
tree-optimization/109502, tree-optimization/109573,
tree-optimization/109724, tree-optimization/109778
- PRs fortran/100607, libstdc++/109822, target/109954,
tree-optimization/109505
* Wed Mar 29 2023 Marek Polacek <polacek@redhat.com> 11.3.1-4.4
- s390x: add support for register arguments preserving (#2168204)

View File

@ -47,15 +47,15 @@ index c1aceb8404a..25432b5040d 100755
--- a/c++tools/configure
+++ b/c++tools/configure
@@ -631,6 +631,7 @@ ac_ct_CC
CFLAGS
CC
GREP
CXXCPP
LD_PICFLAG
+enable_host_bind_now
PICFLAG
MAINTAINER
CXX_AUX_TOOLS
@@ -704,6 +705,7 @@ enable_c___tools
enable_maintainer_mode
enable_checking
enable_default_pie
enable_host_pie
+enable_host_bind_now
@ -63,7 +63,7 @@ index c1aceb8404a..25432b5040d 100755
'
ac_precious_vars='build_alias
@@ -1336,6 +1338,7 @@ Optional Features:
configurey bits
yes,no,all,none,release.
--enable-default-pie enable Position Independent Executable as default
--enable-host-pie build host code as PIE
+ --enable-host-bind-now link host code as BIND_NOW
@ -84,7 +84,7 @@ index c1aceb8404a..25432b5040d 100755
+
# Check if O_CLOEXEC is defined by fcntl
ac_ext=c
diff --git a/c++tools/configure.ac b/c++tools/configure.ac
index 1e42689f2eb..d3f23f66f00 100644
--- a/c++tools/configure.ac

View File

@ -121,32 +121,32 @@ index 742816e4253..88087009383 100755
--- a/c++tools/configure
+++ b/c++tools/configure
@@ -630,7 +630,8 @@ CPP
ac_ct_CC
CFLAGS
CC
EGREP
GREP
CXXCPP
-PIEFLAG
+LD_PICFLAG
+PICFLAG
MAINTAINER
CXX_AUX_TOOLS
AUTOHEADER
@@ -702,6 +703,7 @@ enable_option_checking
enable_c___tools
@@ -700,6 +701,7 @@ enable_c___tools
enable_maintainer_mode
enable_checking
enable_default_pie
+enable_host_pie
with_gcc_major_version_only
'
ac_precious_vars='build_alias
@@ -1333,6 +1335,7 @@ Optional Features:
enable maintainer mode. Add rules to rebuild
configurey bits
only specific categories of checks. Categories are:
yes,no,all,none,release.
--enable-default-pie enable Position Independent Executable as default
+ --enable-host-pie build host code as PIE
Optional Packages:
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
@@ -2992,12 +2995,20 @@ test "$maintainer_mode" = yes && MAINTAI
@@ -2990,12 +2993,20 @@ fi
# Check whether --enable-default-pie was given.
# Check whether --enable-default-pie was given.
if test "${enable_default_pie+set}" = set; then :
@ -168,7 +168,7 @@ index 742816e4253..88087009383 100755
+
# Check if O_CLOEXEC is defined by fcntl
ac_ext=c
diff --git a/c++tools/configure.ac b/c++tools/configure.ac
index 6662b5ad7c9..1e42689f2eb 100644
--- a/c++tools/configure.ac

View File

@ -0,0 +1,22 @@
diff --git a/libstdc++-v3/testsuite/26_numerics/gcd/gcd_neg.cc b/libstdc++-v3/testsuite/26_numerics/gcd/gcd_neg.cc
index b0277b3f4d1..425daff317a 100644
--- a/libstdc++-v3/testsuite/26_numerics/gcd/gcd_neg.cc
+++ b/libstdc++-v3/testsuite/26_numerics/gcd/gcd_neg.cc
@@ -53,3 +53,6 @@ test01()
// { dg-prune-output "does not have integral type" }
// { dg-prune-output "non-integral type" }
// { dg-prune-output "invalid specialization" }
+// These show up with -Wp,-D_GLIBCXX_ASSERTIONS.
+// { dg-prune-output "invalid operands" }
+// { dg-prune-output "wrong type argument" }
diff --git a/libstdc++-v3/testsuite/26_numerics/lcm/lcm_neg.cc b/libstdc++-v3/testsuite/26_numerics/lcm/lcm_neg.cc
index 8cabfe2ea2f..a14d373c461 100644
--- a/libstdc++-v3/testsuite/26_numerics/lcm/lcm_neg.cc
+++ b/libstdc++-v3/testsuite/26_numerics/lcm/lcm_neg.cc
@@ -53,3 +53,6 @@ test01()
// { dg-prune-output "does not have integral type" }
// { dg-prune-output "non-integral type" }
// { dg-prune-output "invalid specialization" }
+// These show up with -Wp,-D_GLIBCXX_ASSERTIONS.
+// { dg-prune-output "invalid operands" }
+// { dg-prune-output "wrong type argument" }

View File

@ -1,4 +1,4 @@
SHA512 (gcc-11.3.1-20221121.tar.xz) = c4e484b7cd8b54925cd420aa9d4a22d27ad1557b481c882e952ed65e7709cfc9c044111f2d194f06349d6510672e23b9d8c8da9f1ec070f453bb4ce74f885095
SHA512 (gcc-11.4.1-20230605.tar.xz) = 524e57dc5e4d0622597de820a2126621607222492acdfb8c11865b8eff8fe3efc41270856e7ee4b054007f35e8fd4dc7f336274c7a34009ec67d2e9a491d2724
SHA512 (isl-0.18.tar.bz2) = 85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7