4.9.1-1
This commit is contained in:
parent
b63748e323
commit
c204df3143
10
gcc.spec
10
gcc.spec
@ -196,9 +196,8 @@ Patch12: gcc49-no-add-needed.patch
|
||||
Patch14: gcc49-pr56493.patch
|
||||
Patch15: gcc49-color-auto.patch
|
||||
Patch16: gcc49-libgo-p224.patch
|
||||
Patch17: gcc49-pr61673.patch
|
||||
Patch18: gcc49-aarch64-async-unw-tables.patch
|
||||
Patch19: gcc49-aarch64-GNU_STACK.patch
|
||||
Patch17: gcc49-aarch64-async-unw-tables.patch
|
||||
Patch18: gcc49-aarch64-GNU_STACK.patch
|
||||
|
||||
Patch1100: cloog-%{cloog_version}-ppc64le-config.patch
|
||||
|
||||
@ -725,9 +724,8 @@ package or when debugging this package.
|
||||
%endif
|
||||
%patch16 -p0 -b .libgo-p224~
|
||||
rm -f libgo/go/crypto/elliptic/p224{,_test}.go
|
||||
%patch17 -p0 -b .pr61673~
|
||||
%patch18 -p0 -b .aarch64-async-unw-tables~
|
||||
%patch19 -p0 -b .aarch64-GNU_STACK~
|
||||
%patch17 -p0 -b .aarch64-async-unw-tables~
|
||||
%patch18 -p0 -b .aarch64-GNU_STACK~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
|
@ -1,72 +0,0 @@
|
||||
2014-07-02 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR rtl-optimization/61673
|
||||
* combine.c (simplify_comparison): Test just mode's sign bit
|
||||
in tmode rather than the sign bit and any bits above it.
|
||||
|
||||
* gcc.c-torture/execute/pr61673.c: New test.
|
||||
|
||||
--- gcc/combine.c.jj 2014-03-28 20:49:52.892077022 +0100
|
||||
+++ gcc/combine.c 2014-07-02 16:56:02.260456040 +0200
|
||||
@@ -11987,7 +11987,7 @@ simplify_comparison (enum rtx_code code,
|
||||
= (unsigned HOST_WIDE_INT) 1 << (GET_MODE_BITSIZE (mode) - 1);
|
||||
op0 = simplify_gen_binary (AND, tmode,
|
||||
gen_lowpart (tmode, op0),
|
||||
- gen_int_mode (sign, mode));
|
||||
+ gen_int_mode (sign, tmode));
|
||||
code = (code == LT) ? NE : EQ;
|
||||
break;
|
||||
}
|
||||
--- gcc/testsuite/gcc.c-torture/execute/pr61673.c.jj 2014-07-02 17:17:01.398908630 +0200
|
||||
+++ gcc/testsuite/gcc.c-torture/execute/pr61673.c 2014-07-02 17:12:36.000000000 +0200
|
||||
@@ -0,0 +1,50 @@
|
||||
+/* PR rtl-optimization/61673 */
|
||||
+
|
||||
+char e;
|
||||
+
|
||||
+__attribute__((noinline, noclone)) void
|
||||
+bar (char x)
|
||||
+{
|
||||
+ if (x != 0x54 && x != (char) 0x87)
|
||||
+ __builtin_abort ();
|
||||
+}
|
||||
+
|
||||
+__attribute__((noinline, noclone)) void
|
||||
+foo (const char *x)
|
||||
+{
|
||||
+ char d = x[0];
|
||||
+ int c = d;
|
||||
+ if ((c >= 0 && c <= 0x7f) == 0)
|
||||
+ e = d;
|
||||
+ bar (d);
|
||||
+}
|
||||
+
|
||||
+__attribute__((noinline, noclone)) void
|
||||
+baz (const char *x)
|
||||
+{
|
||||
+ char d = x[0];
|
||||
+ int c = d;
|
||||
+ if ((c >= 0 && c <= 0x7f) == 0)
|
||||
+ e = d;
|
||||
+}
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ const char c[] = { 0x54, 0x87 };
|
||||
+ e = 0x21;
|
||||
+ foo (c);
|
||||
+ if (e != 0x21)
|
||||
+ __builtin_abort ();
|
||||
+ foo (c + 1);
|
||||
+ if (e != 0x87)
|
||||
+ __builtin_abort ();
|
||||
+ e = 0x21;
|
||||
+ baz (c);
|
||||
+ if (e != 0x21)
|
||||
+ __builtin_abort ();
|
||||
+ baz (c + 1);
|
||||
+ if (e != 0x87)
|
||||
+ __builtin_abort ();
|
||||
+ return 0;
|
||||
+}
|
Loading…
Reference in New Issue
Block a user