8.0.1-0.13
This commit is contained in:
parent
7c58fda150
commit
c0ae016cb4
1
.gitignore
vendored
1
.gitignore
vendored
@ -35,3 +35,4 @@
|
|||||||
/gcc-8.0.1-20180130.tar.xz
|
/gcc-8.0.1-20180130.tar.xz
|
||||||
/gcc-8.0.1-20180131.tar.xz
|
/gcc-8.0.1-20180131.tar.xz
|
||||||
/gcc-8.0.1-20180207.tar.xz
|
/gcc-8.0.1-20180207.tar.xz
|
||||||
|
/gcc-8.0.1-20180210.tar.xz
|
||||||
|
25
gcc.spec
25
gcc.spec
@ -1,10 +1,10 @@
|
|||||||
%global DATE 20180207
|
%global DATE 20180210
|
||||||
%global SVNREV 257452
|
%global SVNREV 257551
|
||||||
%global gcc_version 8.0.1
|
%global gcc_version 8.0.1
|
||||||
%global gcc_major 8
|
%global gcc_major 8
|
||||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||||
# %{release}, append them after %{gcc_release} on Release: line.
|
# %{release}, append them after %{gcc_release} on Release: line.
|
||||||
%global gcc_release 0.12
|
%global gcc_release 0.13
|
||||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||||
%global _unpackaged_files_terminate_build 0
|
%global _unpackaged_files_terminate_build 0
|
||||||
@ -235,7 +235,7 @@ Patch9: gcc8-aarch64-async-unw-tables.patch
|
|||||||
Patch10: gcc8-foffload-default.patch
|
Patch10: gcc8-foffload-default.patch
|
||||||
Patch11: gcc8-Wno-format-security.patch
|
Patch11: gcc8-Wno-format-security.patch
|
||||||
Patch12: gcc8-rh1512529-aarch64.patch
|
Patch12: gcc8-rh1512529-aarch64.patch
|
||||||
Patch13: gcc8-pr84252.patch
|
Patch13: gcc8-lvu-revert.patch
|
||||||
|
|
||||||
Patch1000: nvptx-tools-no-ptxas.patch
|
Patch1000: nvptx-tools-no-ptxas.patch
|
||||||
Patch1001: nvptx-tools-build.patch
|
Patch1001: nvptx-tools-build.patch
|
||||||
@ -795,7 +795,7 @@ to NVidia PTX capable devices if available.
|
|||||||
%patch10 -p0 -b .foffload-default~
|
%patch10 -p0 -b .foffload-default~
|
||||||
%patch11 -p0 -b .Wno-format-security~
|
%patch11 -p0 -b .Wno-format-security~
|
||||||
%patch12 -p0 -b .rh1512529-aarch64~
|
%patch12 -p0 -b .rh1512529-aarch64~
|
||||||
%patch13 -p0 -b .pr84252~
|
%patch13 -p0 -b .lvu-revert~
|
||||||
|
|
||||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||||
@ -3057,6 +3057,21 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 10 2018 Jakub Jelinek <jakub@redhat.com> 8.0.1-0.13
|
||||||
|
- update from the trunk
|
||||||
|
- PRs c++/77522, c++/80567, c++/81610, c++/81917, c++/83204, c++/83659,
|
||||||
|
c++/83806, c++/84082, c++/84182, c++/84296, c/84293, fortran/56691,
|
||||||
|
fortran/68560, fortran/82049, fortran/82994, lto/84212, lto/84213,
|
||||||
|
middle-end/84237, rtl-optimization/57193, rtl-optimization/83459,
|
||||||
|
rtl-optimization/84068, rtl-optimization/84308, sanitizer/84285,
|
||||||
|
target/81143, target/83008, target/83926, target/84113, target/84226,
|
||||||
|
target/84300, target/PR84295, tree-optimization/84037,
|
||||||
|
tree-optimization/84136, tree-optimization/84224,
|
||||||
|
tree-optimization/84232, tree-optimization/84233,
|
||||||
|
tree-optimization/84238, tree-optimization/84265,
|
||||||
|
tree-optimization/84278
|
||||||
|
- temporarily revert LVU stuff, until it settles down
|
||||||
|
|
||||||
* Wed Feb 7 2018 Jakub Jelinek <jakub@redhat.com> 8.0.1-0.12
|
* Wed Feb 7 2018 Jakub Jelinek <jakub@redhat.com> 8.0.1-0.12
|
||||||
- update from the trunk
|
- update from the trunk
|
||||||
- PRs c++/71662, c++/82782, c++/83796, c++/84059, c++/84125, c++/84126,
|
- PRs c++/71662, c++/82782, c++/83796, c++/84059, c++/84125, c++/84126,
|
||||||
|
@ -1,50 +0,0 @@
|
|||||||
2018-02-07 Jakub Jelinek <jakub@redhat.com>
|
|
||||||
|
|
||||||
PR debug/84252
|
|
||||||
* var-tracking.c (vt_add_function_parameter): Punt for non-onepart
|
|
||||||
PARALLEL incoming that failed vt_get_decl_and_offset check.
|
|
||||||
|
|
||||||
* gcc.target/aarch64/pr84252.c: New test.
|
|
||||||
|
|
||||||
--- gcc/var-tracking.c.jj 2018-01-04 00:43:15.007702432 +0100
|
|
||||||
+++ gcc/var-tracking.c 2018-02-07 12:47:09.735980882 +0100
|
|
||||||
@@ -9653,6 +9653,7 @@ vt_add_function_parameter (tree parm)
|
|
||||||
poly_int64 offset;
|
|
||||||
dataflow_set *out;
|
|
||||||
decl_or_value dv;
|
|
||||||
+ bool incoming_ok = true;
|
|
||||||
|
|
||||||
if (TREE_CODE (parm) != PARM_DECL)
|
|
||||||
return;
|
|
||||||
@@ -9743,6 +9744,7 @@ vt_add_function_parameter (tree parm)
|
|
||||||
|
|
||||||
if (!vt_get_decl_and_offset (incoming, &decl, &offset))
|
|
||||||
{
|
|
||||||
+ incoming_ok = false;
|
|
||||||
if (MEM_P (incoming))
|
|
||||||
{
|
|
||||||
/* This means argument is passed by invisible reference. */
|
|
||||||
@@ -9861,6 +9863,10 @@ vt_add_function_parameter (tree parm)
|
|
||||||
{
|
|
||||||
int i;
|
|
||||||
|
|
||||||
+ /* The following code relies on vt_get_decl_and_offset returning true for
|
|
||||||
+ incoming, which might not be always the case. */
|
|
||||||
+ if (!incoming_ok)
|
|
||||||
+ return;
|
|
||||||
for (i = 0; i < XVECLEN (incoming, 0); i++)
|
|
||||||
{
|
|
||||||
rtx reg = XEXP (XVECEXP (incoming, 0, i), 0);
|
|
||||||
--- gcc/testsuite/gcc.target/aarch64/pr84252.c.jj 2018-02-07 14:01:27.987436160 +0100
|
|
||||||
+++ gcc/testsuite/gcc.target/aarch64/pr84252.c 2018-02-07 13:59:47.736644299 +0100
|
|
||||||
@@ -0,0 +1,10 @@
|
|
||||||
+/* PR debug/84252 */
|
|
||||||
+/* { dg-do compile } */
|
|
||||||
+/* { dg-options "-g -O2" } */
|
|
||||||
+
|
|
||||||
+struct S { __Int32x4_t b[2]; };
|
|
||||||
+
|
|
||||||
+void
|
|
||||||
+foo (struct S x)
|
|
||||||
+{
|
|
||||||
+}
|
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (gcc-8.0.1-20180207.tar.xz) = 1846a80298e5cea659c386558ba53ccbc005436a1669aef7e3faa8dd9813fbaaf5b76f495461b08b1515f206515134d578272f3d827c165faee484e746f70e05
|
SHA512 (gcc-8.0.1-20180210.tar.xz) = 23d9af44e3c8fce98d5614ee5540d9119f5727eddacb217a15e8c8b38eae1ca66fd7d67d4015d2899d34cbbb7df87c5ce5ce13aa7779746973a1bf8b1c959bb0
|
||||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
||||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
||||||
|
Loading…
Reference in New Issue
Block a user