4.7.0-0.12
This commit is contained in:
parent
f2ce251d7b
commit
af901f0d9b
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@
|
||||
/gcc-4.7.0-20120123.tar.bz2
|
||||
/gcc-4.7.0-20120126.tar.bz2
|
||||
/gcc-4.7.0-20120206.tar.bz2
|
||||
/gcc-4.7.0-20120208.tar.bz2
|
||||
|
27
gcc.spec
27
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20120206
|
||||
%global SVNREV 183946
|
||||
%global DATE 20120208
|
||||
%global SVNREV 184012
|
||||
%global gcc_version 4.7.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.11
|
||||
%global gcc_release 0.12
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -175,8 +175,8 @@ Patch13: gcc47-no-add-needed.patch
|
||||
Patch14: gcc47-ppl-0.10.patch
|
||||
Patch15: gcc47-libitm-fno-exceptions.patch
|
||||
Patch16: gcc47-pr51950.patch
|
||||
Patch17: gcc47-pr52060.patch
|
||||
Patch18: gcc47-pr52132.patch
|
||||
Patch17: gcc47-pr52132.patch
|
||||
Patch18: gcc47-pr52165.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -679,8 +679,8 @@ package or when debugging this package.
|
||||
%endif
|
||||
%patch15 -p0 -b .libitm-fno-exceptions~
|
||||
%patch16 -p0 -b .pr51950~
|
||||
%patch17 -p0 -b .pr52060~
|
||||
%patch18 -p0 -b .pr52132~
|
||||
%patch17 -p0 -b .pr52132~
|
||||
%patch18 -p0 -b .pr52165~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -1859,6 +1859,7 @@ fi
|
||||
%dir %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/lto1
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/lto-wrapper
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/liblto_plugin.so*
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/rpmver
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/stddef.h
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/stdarg.h
|
||||
@ -2011,7 +2012,6 @@ fi
|
||||
%dir %{_prefix}/libexec/gcc/%{gcc_target_platform}
|
||||
%dir %{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/cc1
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/liblto_plugin.so*
|
||||
|
||||
%files -n libgcc
|
||||
%defattr(-,root,root,-)
|
||||
@ -2641,6 +2641,17 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Wed Feb 8 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-0.12
|
||||
- update from trunk
|
||||
- PRs c++/52035, fortran/51514, gcov-profile/52150, libstdc++/51296,
|
||||
libstdc++/51906, middle-end/24306, middle-end/51994,
|
||||
middle-end/52074, rtl-optimization/52139, rtl-optimization/52170,
|
||||
target/40068, target/52152, target/52154, target/52155,
|
||||
tree-optimization/46886
|
||||
- fix up build on ppc*
|
||||
- don't look for lto plugin/lto-wrapper if -E/-S/-c or in cpp
|
||||
- move liblto_plugin.so* back into gcc subpackage
|
||||
|
||||
* Mon Feb 6 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-0.11
|
||||
- update from trunk
|
||||
- PRs bootstrap/52039, bootstrap/52041, bootstrap/52058, c++/48680,
|
||||
|
@ -5,7 +5,6 @@
|
||||
* config/gnu-user.h (LINK_EH_SPEC): Likewise.
|
||||
* config/alpha/elf.h (LINK_EH_SPEC): Likewise.
|
||||
* config/ia64/linux.h (LINK_EH_SPEC): Likewise.
|
||||
* config/freebsd-spec.h (LINK_EH_SPEC): Likewise.
|
||||
|
||||
--- gcc/config/alpha/elf.h.jj 2011-01-03 12:52:31.118056764 +0100
|
||||
+++ gcc/config/alpha/elf.h 2011-01-04 18:14:10.931874160 +0100
|
||||
@ -51,14 +50,3 @@
|
||||
#endif
|
||||
|
||||
#define CPP_OS_LINUX_SPEC "-D__unix__ -D__gnu_linux__ -D__linux__ \
|
||||
--- gcc/config/freebsd-spec.h.jj 2011-12-21 20:32:34.998649834 +0100
|
||||
+++ gcc/config/freebsd-spec.h 2012-01-17 17:55:03.528567495 +0100
|
||||
@@ -135,7 +135,7 @@ is built with the --enable-threads confi
|
||||
#endif
|
||||
|
||||
#if defined(HAVE_LD_EH_FRAME_HDR)
|
||||
-#define LINK_EH_SPEC "%{!static:--eh-frame-hdr} "
|
||||
+#define LINK_EH_SPEC "--no-add-needed %{!static:--eh-frame-hdr} "
|
||||
#endif
|
||||
|
||||
#ifdef TARGET_LIBC_PROVIDES_SSP
|
||||
|
@ -1,132 +0,0 @@
|
||||
2012-02-06 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR rtl-optimization/52060
|
||||
* combine.c (try_combine): Add i0src_copy and i0src_copy2 variables,
|
||||
copy i1src to i1src_copy whenever added_sets_2 && i1_feeds_i2_n already
|
||||
before i1dest -> i1src substitution in newpat, copy i0src to i0src_copy
|
||||
and/or i0src_copy2 when needed.
|
||||
|
||||
* gcc.dg/torture/pr52060.c: New test.
|
||||
|
||||
--- gcc/combine.c.jj 2012-02-03 13:31:41.000000000 +0100
|
||||
+++ gcc/combine.c 2012-02-06 17:49:40.000000000 +0100
|
||||
@@ -2591,8 +2591,8 @@ try_combine (rtx i3, rtx i2, rtx i1, rtx
|
||||
rtx i3dest_killed = 0;
|
||||
/* SET_DEST and SET_SRC of I2, I1 and I0. */
|
||||
rtx i2dest = 0, i2src = 0, i1dest = 0, i1src = 0, i0dest = 0, i0src = 0;
|
||||
- /* Copy of SET_SRC of I1, if needed. */
|
||||
- rtx i1src_copy = 0;
|
||||
+ /* Copy of SET_SRC of I1 and I0, if needed. */
|
||||
+ rtx i1src_copy = 0, i0src_copy = 0, i0src_copy2 = 0;
|
||||
/* Set if I2DEST was reused as a scratch register. */
|
||||
bool i2scratch = false;
|
||||
/* The PATTERNs of I0, I1, and I2, or a copy of them in certain cases. */
|
||||
@@ -3246,6 +3246,11 @@ try_combine (rtx i3, rtx i2, rtx i1, rtx
|
||||
n_occurrences = 0;
|
||||
subst_low_luid = DF_INSN_LUID (i1);
|
||||
|
||||
+ /* If the following substitution will modify I1SRC, make a copy of it
|
||||
+ for the case where it is substituted for I1DEST in I2PAT later. */
|
||||
+ if (added_sets_2 && i1_feeds_i2_n)
|
||||
+ i1src_copy = copy_rtx (i1src);
|
||||
+
|
||||
/* If I0 feeds into I1 and I0DEST is in I0SRC, we need to make a unique
|
||||
copy of I1SRC each time we substitute it, in order to avoid creating
|
||||
self-referential RTL when we will be substituting I0SRC for I0DEST
|
||||
@@ -3273,10 +3278,14 @@ try_combine (rtx i3, rtx i2, rtx i1, rtx
|
||||
return 0;
|
||||
}
|
||||
|
||||
- /* If the following substitution will modify I1SRC, make a copy of it
|
||||
- for the case where it is substituted for I1DEST in I2PAT later. */
|
||||
- if (i0_feeds_i1_n && added_sets_2 && i1_feeds_i2_n)
|
||||
- i1src_copy = copy_rtx (i1src);
|
||||
+ /* If the following substitution will modify I0SRC, make a copy of it
|
||||
+ for the case where it is substituted for I0DEST in I1PAT later. */
|
||||
+ if (added_sets_1 && i0_feeds_i1_n)
|
||||
+ i0src_copy = copy_rtx (i0src);
|
||||
+ /* And a copy for I0DEST in I2PAT substitution. */
|
||||
+ if (added_sets_2 && ((i0_feeds_i1_n && i1_feeds_i2_n)
|
||||
+ || (i0_feeds_i2_n)))
|
||||
+ i0src_copy2 = copy_rtx (i0src);
|
||||
|
||||
n_occurrences = 0;
|
||||
subst_low_luid = DF_INSN_LUID (i0);
|
||||
@@ -3342,7 +3351,7 @@ try_combine (rtx i3, rtx i2, rtx i1, rtx
|
||||
{
|
||||
rtx t = i1pat;
|
||||
if (i0_feeds_i1_n)
|
||||
- t = subst (t, i0dest, i0src, 0, 0, 0);
|
||||
+ t = subst (t, i0dest, i0src_copy ? i0src_copy : i0src, 0, 0, 0);
|
||||
|
||||
XVECEXP (newpat, 0, --total_sets) = t;
|
||||
}
|
||||
@@ -3353,7 +3362,7 @@ try_combine (rtx i3, rtx i2, rtx i1, rtx
|
||||
t = subst (t, i1dest, i1src_copy ? i1src_copy : i1src, 0, 0,
|
||||
i0_feeds_i1_n && i0dest_in_i0src);
|
||||
if ((i0_feeds_i1_n && i1_feeds_i2_n) || i0_feeds_i2_n)
|
||||
- t = subst (t, i0dest, i0src, 0, 0, 0);
|
||||
+ t = subst (t, i0dest, i0src_copy2 ? i0src_copy2 : i0src, 0, 0, 0);
|
||||
|
||||
XVECEXP (newpat, 0, --total_sets) = t;
|
||||
}
|
||||
--- gcc/testsuite/gcc.dg/torture/pr52060.c.jj 2012-02-06 18:35:51.215511107 +0100
|
||||
+++ gcc/testsuite/gcc.dg/torture/pr52060.c 2012-02-06 18:34:18.000000000 +0100
|
||||
@@ -0,0 +1,57 @@
|
||||
+/* PR rtl-optimization/52060 */
|
||||
+/* { dg-do run { target int32plus } } */
|
||||
+
|
||||
+extern void abort (void);
|
||||
+union U { float f; unsigned int i; };
|
||||
+
|
||||
+static inline __attribute__((always_inline)) unsigned int
|
||||
+foo (float x)
|
||||
+{
|
||||
+ union U u;
|
||||
+ unsigned int a, b, c;
|
||||
+ int d;
|
||||
+ int e;
|
||||
+ u.f = x;
|
||||
+ d = ((unsigned) u.i >> 23) & 0xFF;
|
||||
+ c = d < 126 ? 0 : ~0;
|
||||
+ e = 127 + 30 - d;
|
||||
+ a = (u.i << 8) | 0x80000000U;
|
||||
+ b = a & ((1 << e) - 1);
|
||||
+ a = a >> e;
|
||||
+ c &= (b | (a & 2)) ? ~0 : ~1;
|
||||
+ a = ((a + 1U) >> 1) & c;
|
||||
+ return a;
|
||||
+}
|
||||
+
|
||||
+__attribute__((noinline)) unsigned int
|
||||
+bar (float x)
|
||||
+{
|
||||
+ unsigned int a, b, c;
|
||||
+ static const unsigned int d[128] =
|
||||
+ {
|
||||
+ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+ 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
|
||||
+ 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
|
||||
+ 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2,
|
||||
+ 3, 3, 3, 3, 3, 3, 3, 3, 4, 4, 4, 4, 5, 5, 6, 7
|
||||
+ };
|
||||
+ a = foo (1048575.0f * x);
|
||||
+ c = d[a >> 13];
|
||||
+ b = (c << 13) | ((a >> (7 - c)) & 0x1fff);
|
||||
+ return b;
|
||||
+}
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ union U u;
|
||||
+ u.f = 1048575.0f;
|
||||
+ if (sizeof (u.i) == sizeof (u.f)
|
||||
+ && u.i == 0x497ffff0U
|
||||
+ && bar (1.0f) != 65535)
|
||||
+ abort ();
|
||||
+ return 0;
|
||||
+}
|
27
gcc47-pr52165.patch
Normal file
27
gcc47-pr52165.patch
Normal file
@ -0,0 +1,27 @@
|
||||
2012-02-08 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR debug/52165
|
||||
* var-tracking.c (emit_note_insn_var_location): If
|
||||
EMIT_NOTE_BEFORE_INSN and insn is NOTE_INSN_CALL_ARG_LOCATION,
|
||||
emit it before next non-NOTE_INSN_CALL_ARG_LOCATION
|
||||
non-NOTE_DURING_CALL_P insn.
|
||||
|
||||
--- gcc/var-tracking.c.jj 2012-01-30 00:10:01.000000000 +0100
|
||||
+++ gcc/var-tracking.c 2012-02-08 16:20:54.808523330 +0100
|
||||
@@ -8225,9 +8225,14 @@ emit_note_insn_var_location (void **varp
|
||||
/* Make sure that the call related notes come first. */
|
||||
while (NEXT_INSN (insn)
|
||||
&& NOTE_P (insn)
|
||||
- && NOTE_DURING_CALL_P (insn))
|
||||
+ && ((NOTE_KIND (insn) == NOTE_INSN_VAR_LOCATION
|
||||
+ && NOTE_DURING_CALL_P (insn))
|
||||
+ || NOTE_KIND (insn) == NOTE_INSN_CALL_ARG_LOCATION))
|
||||
insn = NEXT_INSN (insn);
|
||||
- if (NOTE_P (insn) && NOTE_DURING_CALL_P (insn))
|
||||
+ if (NOTE_P (insn)
|
||||
+ && ((NOTE_KIND (insn) == NOTE_INSN_VAR_LOCATION
|
||||
+ && NOTE_DURING_CALL_P (insn))
|
||||
+ || NOTE_KIND (insn) == NOTE_INSN_CALL_ARG_LOCATION))
|
||||
note = emit_note_after (NOTE_INSN_VAR_LOCATION, insn);
|
||||
else
|
||||
note = emit_note_before (NOTE_INSN_VAR_LOCATION, insn);
|
Loading…
Reference in New Issue
Block a user