Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/gcc.git#3f45c9c1656e3a105f589a0accd9a542cff51d92
This commit is contained in:
parent
00073ce2d6
commit
af40302023
2
.gitignore
vendored
2
.gitignore
vendored
@ -19,5 +19,3 @@
|
||||
/gcc-10.2.1-20200916.tar.xz
|
||||
/gcc-10.2.1-20201005.tar.xz
|
||||
/gcc-10.2.1-20201016.tar.xz
|
||||
/gcc-10.2.1-20201102.tar.xz
|
||||
/gcc-10.2.1-20201112.tar.xz
|
||||
|
33
gcc.spec
33
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20201112
|
||||
%global gitrev 86495efb7a403b1ee3419fb3b3b1aaf26345ada5
|
||||
%global DATE 20201016
|
||||
%global gitrev b55a9d01144097312b48281486c03e83cf03fde5
|
||||
%global gcc_version 10.2.1
|
||||
%global gcc_major 10
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 8
|
||||
%global gcc_release 6
|
||||
%global nvptx_tools_gitrev 5f6f343a302d620b0868edab376c00b15741e39e
|
||||
%global newlib_cygwin_gitrev 50e2a63b04bdd018484605fbb954fd1bd5147fa0
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -171,7 +171,7 @@ BuildRequires: texinfo, texinfo-tex, /usr/bin/pod2man
|
||||
BuildRequires: systemtap-sdt-devel >= 1.3
|
||||
BuildRequires: gmp-devel >= 4.1.2-8, mpfr-devel >= 3.1.0, libmpc-devel >= 0.8.1
|
||||
BuildRequires: python3-devel, /usr/bin/python
|
||||
BuildRequires: gcc, gcc-c++, make
|
||||
BuildRequires: gcc, gcc-c++
|
||||
%if %{build_go}
|
||||
BuildRequires: hostname, procps
|
||||
%endif
|
||||
@ -248,8 +248,6 @@ Requires: glibc >= 2.16
|
||||
%endif
|
||||
Requires: libgcc >= %{version}-%{release}
|
||||
Requires: libgomp = %{version}-%{release}
|
||||
# lto-wrapper invokes make
|
||||
Requires: make
|
||||
%if !%{build_ada}
|
||||
Obsoletes: gcc-gnat < %{version}-%{release}
|
||||
%endif
|
||||
@ -274,7 +272,6 @@ Patch12: gcc10-pr96383.patch
|
||||
Patch13: gcc10-pr96939.patch
|
||||
Patch14: gcc10-pr96939-2.patch
|
||||
Patch15: gcc10-pr96939-3.patch
|
||||
Patch16: gcc10-pr97060.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -791,7 +788,6 @@ to NVidia PTX capable devices if available.
|
||||
%patch14 -p0 -b .pr96939-2~
|
||||
%patch15 -p0 -b .pr96939-3~
|
||||
find gcc/testsuite -name \*.pr96939~ | xargs rm -f
|
||||
%patch16 -p0 -b .pr97060~
|
||||
|
||||
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
||||
|
||||
@ -3058,27 +3054,6 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Nov 12 2020 Jakub Jelinek <jakub@redhat.com> 10.2.1-8
|
||||
- update from releases/gcc-10 branch
|
||||
- PRs c++/97412, fortran/92793, fortran/97652, libstdc++/92285,
|
||||
libstdc++/96269, libstdc++/97362, libstdc++/97731, middle-end/97392,
|
||||
target/85486, target/97360, target/97638, target/97685,
|
||||
testsuite/80219, testsuite/85303, testsuite/97688, testsuite/97797,
|
||||
tree-optimization/97633, tree-optimization/97764
|
||||
- fix up Fortran ICE on operator with CHARACTER operand (#1895612,
|
||||
PR fortran/97768)
|
||||
- emit DW_AT_declaration on declaration-only DIEs (#1889516, PR debug/97060)
|
||||
- add BuildRequires: make and Requires: make, the latter for -flto reasons
|
||||
|
||||
* Mon Nov 2 2020 Jakub Jelinek <jakub@redhat.com> 10.2.1-7
|
||||
- update from releases/gcc-10 branch
|
||||
- PRs c++/95132, c++/96241, c++/97010, c++/97197, c++/97328, fortran/95979,
|
||||
ipa/96394, ipa/97404, libstdc++/97132, lto/97508,
|
||||
rtl-optimization/97386, rtl-optimization/97439, sanitizer/97294,
|
||||
sanitizer/97414, target/96759, target/96914, target/97291,
|
||||
target/97327, target/97506, testsuite/95886, tree-optimization/97081,
|
||||
tree-optimization/97456
|
||||
|
||||
* Fri Oct 16 2020 Jakub Jelinek <jakub@redhat.com> 10.2.1-6
|
||||
- update from releases/gcc-10 branch
|
||||
- PRs c++/88115, c++/96229, fortran/97272, libstdc++/95788, libstdc++/97273,
|
||||
|
@ -1,34 +0,0 @@
|
||||
2020-11-11 Jason Merrill <jason@redhat.com>
|
||||
|
||||
PR debug/97060
|
||||
* dwarf2out.c (gen_subprogram_die): It's a declaration
|
||||
if DECL_INITIAL isn't set.
|
||||
|
||||
* gcc.dg/debug/dwarf2/pr97060.c: New test.
|
||||
|
||||
--- gcc/dwarf2out.c
|
||||
+++ gcc/dwarf2out.c
|
||||
@@ -22859,6 +22859,7 @@ gen_subprogram_die (tree decl, dw_die_ref context_die)
|
||||
available.
|
||||
*/
|
||||
int declaration = (current_function_decl != decl
|
||||
+ || (!DECL_INITIAL (decl) && !origin)
|
||||
|| class_or_namespace_scope_p (context_die));
|
||||
|
||||
/* A declaration that has been previously dumped needs no
|
||||
--- gcc/testsuite/gcc.dg/debug/dwarf2/pr97060.c
|
||||
+++ gcc/testsuite/gcc.dg/debug/dwarf2/pr97060.c
|
||||
@@ -0,0 +1,13 @@
|
||||
+/* PR debug/97060 */
|
||||
+/* { dg-do compile } */
|
||||
+/* { dg-options "-g -dA" } */
|
||||
+/* { dg-final { scan-assembler-times "DW_AT_declaration" 2 } } */
|
||||
+
|
||||
+extern int foo (unsigned int, unsigned int);
|
||||
+
|
||||
+int
|
||||
+bar (void)
|
||||
+{
|
||||
+ foo (1, 2);
|
||||
+ return 0;
|
||||
+}
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-10.2.1-20201112.tar.xz) = 6f624eee77c0a35939978d59e7411764343a29d969a25e1a78c5fa27fc74b539c4a65c591f5699268cfe118df0054b5996b49b6cd2c02ce105ff86b5b935b2a1
|
||||
SHA512 (gcc-10.2.1-20201016.tar.xz) = d324b7c872210a14aabdc117567ae6eff98d40ee8bf7a705a8caf1330d698e167016fb98f095ab56de43140e5f19932775ff3d5757434e3f78f2eec57d3dd1c4
|
||||
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
||||
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
||||
|
Loading…
Reference in New Issue
Block a user