9.0.1-0.2
This commit is contained in:
parent
d895623061
commit
a6c3c8f082
1
.gitignore
vendored
1
.gitignore
vendored
@ -60,3 +60,4 @@
|
|||||||
/gcc-9.0.0-20190119.tar.xz
|
/gcc-9.0.0-20190119.tar.xz
|
||||||
/gcc-9.0.0-20190121.tar.xz
|
/gcc-9.0.0-20190121.tar.xz
|
||||||
/gcc-9.0.1-20190123.tar.xz
|
/gcc-9.0.1-20190123.tar.xz
|
||||||
|
/gcc-9.0.1-20190129.tar.xz
|
||||||
|
23
gcc.spec
23
gcc.spec
@ -1,10 +1,10 @@
|
|||||||
%global DATE 20190123
|
%global DATE 20190129
|
||||||
%global SVNREV 268193
|
%global SVNREV 268371
|
||||||
%global gcc_version 9.0.1
|
%global gcc_version 9.0.1
|
||||||
%global gcc_major 9
|
%global gcc_major 9
|
||||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||||
%global gcc_release 0.1
|
%global gcc_release 0.2
|
||||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||||
%global _unpackaged_files_terminate_build 0
|
%global _unpackaged_files_terminate_build 0
|
||||||
@ -256,6 +256,7 @@ Patch10: gcc9-rh1574936.patch
|
|||||||
Patch11: gcc9-d-shared-libphobos.patch
|
Patch11: gcc9-d-shared-libphobos.patch
|
||||||
Patch12: gcc9-pr88714.patch
|
Patch12: gcc9-pr88714.patch
|
||||||
Patch13: gcc9-pr89014.patch
|
Patch13: gcc9-pr89014.patch
|
||||||
|
Patch14: gcc9-pr89093.patch
|
||||||
|
|
||||||
Patch1000: nvptx-tools-no-ptxas.patch
|
Patch1000: nvptx-tools-no-ptxas.patch
|
||||||
Patch1001: nvptx-tools-build.patch
|
Patch1001: nvptx-tools-build.patch
|
||||||
@ -761,6 +762,7 @@ to NVidia PTX capable devices if available.
|
|||||||
%patch11 -p0 -b .d-shared-libphobos~
|
%patch11 -p0 -b .d-shared-libphobos~
|
||||||
%patch12 -p0 -b .pr88714~
|
%patch12 -p0 -b .pr88714~
|
||||||
%patch13 -p0 -b .pr89014~
|
%patch13 -p0 -b .pr89014~
|
||||||
|
%patch14 -p0 -b .pr89093~
|
||||||
|
|
||||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||||
@ -2949,6 +2951,21 @@ end
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 29 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.2
|
||||||
|
- update from trunk
|
||||||
|
- PRs c++/66676, c++/88358, c++/88815, c++/88865, c++/88969, c++/88976,
|
||||||
|
c++/89001, c++/89024, c++/89089, c/86125, c/88886, c/89045, d/89042,
|
||||||
|
debug/87295, debug/89006, debug/89076, fortran/57553, fortran/70696,
|
||||||
|
fortran/85780, fortran/88929, gcc/87763, gcov-profile/88994,
|
||||||
|
ipa/88933, ipa/89104, libfortran/89020, libgcc/88931, libstdc++/68737,
|
||||||
|
libstdc++/88840, lto/87187, middle-end/86308, middle-end/89002,
|
||||||
|
middle-end/89015, middle-end/89037, preprocessor/88974,
|
||||||
|
rtl-optimization/88846, rtl-optimization/88948, target/85711,
|
||||||
|
target/87214, target/88998, target/89073, testsuite/89064,
|
||||||
|
tree-optimization/86865, tree-optimization/88739,
|
||||||
|
tree-optimization/89027, tree-optimization/89049
|
||||||
|
- make sure ARM unwinder doesn't use VFP registers (#1670069, PR target/89093)
|
||||||
|
|
||||||
* Wed Jan 23 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.1
|
* Wed Jan 23 2019 Jakub Jelinek <jakub@redhat.com> 9.0.1-0.1
|
||||||
- update from trunk
|
- update from trunk
|
||||||
- PRs c++/87893, c++/88293, c++/88757, c++/88984, c/44715, driver/89014,
|
- PRs c++/87893, c++/88293, c++/88757, c++/88984, c/44715, driver/89014,
|
||||||
|
114
gcc9-pr89093.patch
Normal file
114
gcc9-pr89093.patch
Normal file
@ -0,0 +1,114 @@
|
|||||||
|
2019-01-29 Ramana Radhakrishnan <ramana.radhakrishnan@arm.com>
|
||||||
|
|
||||||
|
PR target/89093
|
||||||
|
* config/arm/arm-cpus.in: Add -mfpu=none support.
|
||||||
|
* config/arm/arm-tables.opt: Likewise.
|
||||||
|
* config/arm/arm.c (arm_options_perform_arch_sanity_checks): Remove
|
||||||
|
error for no FPU.
|
||||||
|
|
||||||
|
* config/arm/pr-support.c: Add #pragma GCC target ("fpu=none").
|
||||||
|
* config/arm/unwind-arm.c: Likewise.
|
||||||
|
* unwind-c.c: Likewise, #ifdef __arm__ only.
|
||||||
|
|
||||||
|
* libsupc++/eh_personality.cc: Add #pragma GCC target ("fpu=none")
|
||||||
|
for __arm__.
|
||||||
|
|
||||||
|
--- gcc/config/arm/arm-cpus.in
|
||||||
|
+++ gcc/config/arm/arm-cpus.in
|
||||||
|
@@ -128,6 +128,7 @@ define feature cmse
|
||||||
|
|
||||||
|
# Floating point and Neon extensions.
|
||||||
|
# VFPv1 is not supported in GCC.
|
||||||
|
+define feature nofp
|
||||||
|
|
||||||
|
# Vector floating point v2.
|
||||||
|
define feature vfpv2
|
||||||
|
@@ -258,6 +259,7 @@ define fgroup ARMv8m_main ARMv7m armv8 cmse
|
||||||
|
define fgroup ARMv8r ARMv8a
|
||||||
|
|
||||||
|
# Useful combinations.
|
||||||
|
+define fgroup NONE nofp
|
||||||
|
define fgroup VFPv2 vfpv2
|
||||||
|
define fgroup VFPv3 VFPv2 vfpv3
|
||||||
|
define fgroup VFPv4 VFPv3 vfpv4 fp16conv
|
||||||
|
@@ -1394,6 +1396,9 @@ end cpu cortex-r52
|
||||||
|
# begin fpu <name>
|
||||||
|
# isa <isa-flags-list>
|
||||||
|
# end fpu <name>
|
||||||
|
+begin fpu none
|
||||||
|
+isa NONE FP_DBL
|
||||||
|
+end fpu none
|
||||||
|
|
||||||
|
begin fpu vfp
|
||||||
|
isa VFPv2 FP_DBL
|
||||||
|
--- gcc/config/arm/arm-tables.opt
|
||||||
|
+++ gcc/config/arm/arm-tables.opt
|
||||||
|
@@ -353,6 +353,9 @@ Enum
|
||||||
|
Name(arm_fpu) Type(enum fpu_type)
|
||||||
|
Known ARM FPUs (for use with the -mfpu= option):
|
||||||
|
|
||||||
|
+EnumValue
|
||||||
|
+Enum(arm_fpu) String(none) Value(TARGET_FPU_none)
|
||||||
|
+
|
||||||
|
EnumValue
|
||||||
|
Enum(arm_fpu) String(vfp) Value(TARGET_FPU_vfp)
|
||||||
|
|
||||||
|
--- gcc/config/arm/arm.c
|
||||||
|
+++ gcc/config/arm/arm.c
|
||||||
|
@@ -3759,8 +3759,6 @@ arm_options_perform_arch_sanity_checks (void)
|
||||||
|
else if (TARGET_HARD_FLOAT_ABI)
|
||||||
|
{
|
||||||
|
arm_pcs_default = ARM_PCS_AAPCS_VFP;
|
||||||
|
- if (!bitmap_bit_p (arm_active_target.isa, isa_bit_vfpv2))
|
||||||
|
- error ("-mfloat-abi=hard: selected processor lacks an FPU");
|
||||||
|
}
|
||||||
|
else
|
||||||
|
arm_pcs_default = ARM_PCS_AAPCS;
|
||||||
|
--- libgcc/config/arm/pr-support.c
|
||||||
|
+++ libgcc/config/arm/pr-support.c
|
||||||
|
@@ -21,6 +21,8 @@
|
||||||
|
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||||
|
<http://www.gnu.org/licenses/>. */
|
||||||
|
|
||||||
|
+#pragma GCC target ("fpu=none")
|
||||||
|
+
|
||||||
|
#include "unwind.h"
|
||||||
|
|
||||||
|
/* We add a prototype for abort here to avoid creating a dependency on
|
||||||
|
--- libgcc/config/arm/unwind-arm.c
|
||||||
|
+++ libgcc/config/arm/unwind-arm.c
|
||||||
|
@@ -21,6 +21,8 @@
|
||||||
|
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||||
|
<http://www.gnu.org/licenses/>. */
|
||||||
|
|
||||||
|
+#pragma GCC target ("fpu=none")
|
||||||
|
+
|
||||||
|
#include "unwind.h"
|
||||||
|
|
||||||
|
/* Misc constants. */
|
||||||
|
--- libgcc/unwind-c.c
|
||||||
|
+++ libgcc/unwind-c.c
|
||||||
|
@@ -24,6 +24,10 @@ a copy of the GCC Runtime Library Except
|
||||||
|
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||||
|
<http://www.gnu.org/licenses/>. */
|
||||||
|
|
||||||
|
+#ifdef __arm__
|
||||||
|
+#pragma GCC target ("fpu=none")
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#include "tconfig.h"
|
||||||
|
#include "tsystem.h"
|
||||||
|
#include "auto-target.h"
|
||||||
|
--- libstdc++-v3/libsupc++/eh_personality.cc
|
||||||
|
+++ libstdc++-v3/libsupc++/eh_personality.cc
|
||||||
|
@@ -22,6 +22,10 @@
|
||||||
|
// see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
|
||||||
|
// <http://www.gnu.org/licenses/>.
|
||||||
|
|
||||||
|
+#ifdef __arm__
|
||||||
|
+#pragma GCC target ("fpu=none")
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#include <bits/c++config.h>
|
||||||
|
#include <cstdlib>
|
||||||
|
#include <bits/exception_defines.h>
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (gcc-9.0.1-20190123.tar.xz) = 640e27164ec6624366af3fdcb9f1bd399c47bd1a8adc57a0f5f0214493354a218d1cdc7c8e60bb9323baf01c3e2ef09233d57896b3e3047149064b1c353b6b8c
|
SHA512 (gcc-9.0.1-20190129.tar.xz) = 541c90431c4a30df62ceb3552693a450f6a95bc6244f5e1c13ca3f4eb3b5837e19731f9b2cbe83892c6d4ef37192b3309e8d248940931507040350e8450d98e3
|
||||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.xz) = 94f7089365296f7dfa485107b4143bebc850a81586f3460fd896bbbb6ba099a00217d4042133424fd2183b352132f4fd367e6a60599bdae2a26dfd48a77d0e04
|
||||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.xz) = a688cb12cf805950a5abbb13b52f45c81dbee98e310b7ed57ae20e76dbfa5964a16270148374a6426d177db71909d28360490f091c86a5d19d4faa5127beeee1
|
||||||
|
Loading…
Reference in New Issue
Block a user