5.3.1-2
This commit is contained in:
parent
04e43e85d1
commit
a04a33c99f
7
gcc.spec
7
gcc.spec
@ -3,7 +3,7 @@
|
||||
%global gcc_version 5.3.1
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 1
|
||||
%global gcc_release 2
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global _performance_build 1
|
||||
# Hardening slows the compiler way too much.
|
||||
@ -207,6 +207,7 @@ Patch12: gcc5-libgo-p224.patch
|
||||
Patch13: gcc5-aarch64-async-unw-tables.patch
|
||||
Patch14: gcc5-libsanitize-aarch64-va42.patch
|
||||
Patch15: gcc5-pr65689.patch
|
||||
Patch16: gcc5-rh1279639.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -774,6 +775,7 @@ rm -f libgo/go/crypto/elliptic/p224{,_test}.go
|
||||
%patch13 -p0 -b .aarch64-async-unw-tables~
|
||||
%patch14 -p0 -b .libsanitize-aarch64-va42~
|
||||
%patch15 -p0 -b .pr65689~
|
||||
%patch16 -p0 -b .rh1279639~
|
||||
sed -i -e 's/ -Wl,-z,nodlopen//g' gcc/ada/gcc-interface/Makefile.in
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
@ -3095,6 +3097,9 @@ fi
|
||||
%doc rpm.doc/changelogs/libcc1/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 8 2015 Jakub Jelinek <jakub@redhat.com> 5.3.1-2
|
||||
- work around doxygen 1.8.10 bugs (#1279639)
|
||||
|
||||
* Mon Dec 7 2015 Jakub Jelinek <jakub@redhat.com> 5.3.1-1
|
||||
- update from the 5 branch
|
||||
- GCC 5.3 release
|
||||
|
38
gcc5-rh1279639.patch
Normal file
38
gcc5-rh1279639.patch
Normal file
@ -0,0 +1,38 @@
|
||||
# Workaround doxygen 1.8.10 bugs.
|
||||
--- libstdc++-v3/doc/doxygen/user.cfg.in
|
||||
+++ libstdc++-v3/doc/doxygen/user.cfg.in
|
||||
@@ -895,7 +895,6 @@ INPUT = @srcdir@/doc/doxygen/doxygroups.cc \
|
||||
include/ext/pb_ds/detail/binary_heap_ \
|
||||
include/ext/pb_ds/detail/binomial_heap_ \
|
||||
include/ext/pb_ds/detail/binomial_heap_base_ \
|
||||
- include/ext/pb_ds/detail/bin_search_tree_ \
|
||||
include/ext/pb_ds/detail/branch_policy \
|
||||
include/ext/pb_ds/detail/cc_hash_table_map_ \
|
||||
include/ext/pb_ds/detail/eq_fn \
|
||||
@@ -1965,18 +1964,6 @@ GENERATE_XML = @do_xml@
|
||||
|
||||
XML_OUTPUT = xml
|
||||
|
||||
-# The XML_SCHEMA tag can be used to specify a XML schema, which can be used by a
|
||||
-# validating XML parser to check the syntax of the XML files.
|
||||
-# This tag requires that the tag GENERATE_XML is set to YES.
|
||||
-
|
||||
-XML_SCHEMA =
|
||||
-
|
||||
-# The XML_DTD tag can be used to specify a XML DTD, which can be used by a
|
||||
-# validating XML parser to check the syntax of the XML files.
|
||||
-# This tag requires that the tag GENERATE_XML is set to YES.
|
||||
-
|
||||
-XML_DTD =
|
||||
-
|
||||
# If the XML_PROGRAMLISTING tag is set to YES doxygen will dump the program
|
||||
# listings (including syntax highlighting and cross-referencing information) to
|
||||
# the XML output. Note that enabling this will significantly increase the size
|
||||
@@ -2135,6 +2122,7 @@ PREDEFINED = __cplusplus=201103L \
|
||||
_GLIBCXX_USE_CONSTEXPR=constexpr \
|
||||
"_GLIBCXX_THROW(E)= " \
|
||||
_GLIBCXX_NOEXCEPT=noexcept \
|
||||
+ "_GLIBCXX_NOEXCEPT_IF(E)=noexcept(E)" \
|
||||
_GLIBCXX_NOTHROW=noexcept \
|
||||
_GLIBCXX_USE_NOEXCEPT=noexcept \
|
||||
_GLIBCXX_USE_WCHAR_T \
|
Loading…
Reference in New Issue
Block a user