4.7.0-0.5
This commit is contained in:
parent
d962a92335
commit
9414f6f26c
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
|||||||
/gcc-4.7.0-20120103.tar.bz2
|
/gcc-4.7.0-20120103.tar.bz2
|
||||||
/gcc-4.7.0-20120104.tar.bz2
|
/gcc-4.7.0-20120104.tar.bz2
|
||||||
/gcc-4.7.0-20120105.tar.bz2
|
/gcc-4.7.0-20120105.tar.bz2
|
||||||
|
/gcc-4.7.0-20120106.tar.bz2
|
||||||
|
24
gcc.spec
24
gcc.spec
@ -1,9 +1,9 @@
|
|||||||
%global DATE 20120105
|
%global DATE 20120106
|
||||||
%global SVNREV 182927
|
%global SVNREV 182962
|
||||||
%global gcc_version 4.7.0
|
%global gcc_version 4.7.0
|
||||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||||
# %{release}, append them after %{gcc_release} on Release: line.
|
# %{release}, append them after %{gcc_release} on Release: line.
|
||||||
%global gcc_release 0.4
|
%global gcc_release 0.5
|
||||||
%global _unpackaged_files_terminate_build 0
|
%global _unpackaged_files_terminate_build 0
|
||||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||||
@ -12,7 +12,7 @@
|
|||||||
%global build_ada 0
|
%global build_ada 0
|
||||||
%endif
|
%endif
|
||||||
%global build_java 1
|
%global build_java 1
|
||||||
%ifarch %{ix86} x86_64 ppc ppc64 s390 s390x
|
%ifarch %{ix86} x86_64 ppc ppc64
|
||||||
%global build_go 1
|
%global build_go 1
|
||||||
%else
|
%else
|
||||||
%global build_go 0
|
%global build_go 0
|
||||||
@ -174,6 +174,8 @@ Patch12: gcc47-libstdc++-docs.patch
|
|||||||
Patch13: gcc47-no-add-needed.patch
|
Patch13: gcc47-no-add-needed.patch
|
||||||
Patch14: gcc47-ppl-0.10.patch
|
Patch14: gcc47-ppl-0.10.patch
|
||||||
Patch15: gcc47-libitm-fno-exceptions.patch
|
Patch15: gcc47-libitm-fno-exceptions.patch
|
||||||
|
Patch16: gcc47-pr47333.patch
|
||||||
|
Patch17: gcc47-pr50127.patch
|
||||||
|
|
||||||
Patch1000: fastjar-0.97-segfault.patch
|
Patch1000: fastjar-0.97-segfault.patch
|
||||||
Patch1001: fastjar-0.97-len1.patch
|
Patch1001: fastjar-0.97-len1.patch
|
||||||
@ -673,6 +675,8 @@ package or when debugging this package.
|
|||||||
%patch14 -p0 -b .ppl-0.10~
|
%patch14 -p0 -b .ppl-0.10~
|
||||||
%endif
|
%endif
|
||||||
%patch15 -p0 -b .libitm-fno-exceptions~
|
%patch15 -p0 -b .libitm-fno-exceptions~
|
||||||
|
%patch16 -p0 -b .pr47333~
|
||||||
|
%patch17 -p0 -b .pr50127~
|
||||||
|
|
||||||
%if 0%{?_enable_debug_packages}
|
%if 0%{?_enable_debug_packages}
|
||||||
cat > split-debuginfo.sh <<\EOF
|
cat > split-debuginfo.sh <<\EOF
|
||||||
@ -949,8 +953,11 @@ CC="$CC" CFLAGS="$OPT_FLAGS" CXXFLAGS="`echo $OPT_FLAGS | sed 's/ -Wall / /g'`"
|
|||||||
--build=%{gcc_target_platform}
|
--build=%{gcc_target_platform}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#GCJFLAGS="$OPT_FLAGS" make %{?_smp_mflags} BOOT_CFLAGS="$OPT_FLAGS" bootstrap
|
%ifarch %{arm} sparc sparcv9 sparc64
|
||||||
|
GCJFLAGS="$OPT_FLAGS" make %{?_smp_mflags} BOOT_CFLAGS="$OPT_FLAGS" bootstrap
|
||||||
|
%else
|
||||||
GCJFLAGS="$OPT_FLAGS" make %{?_smp_mflags} BOOT_CFLAGS="$OPT_FLAGS" profiledbootstrap
|
GCJFLAGS="$OPT_FLAGS" make %{?_smp_mflags} BOOT_CFLAGS="$OPT_FLAGS" profiledbootstrap
|
||||||
|
%endif
|
||||||
|
|
||||||
# Make generated man pages even if Pod::Man is not new enough
|
# Make generated man pages even if Pod::Man is not new enough
|
||||||
perl -pi -e 's/head3/head2/' ../contrib/texi2pod.pl
|
perl -pi -e 's/head3/head2/' ../contrib/texi2pod.pl
|
||||||
@ -2618,6 +2625,13 @@ fi
|
|||||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 6 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-0.5
|
||||||
|
- update from trunk
|
||||||
|
- PRs c++/51541, fortran/48946, libstdc++/51504, lto/51774,
|
||||||
|
rtl-optimization/51771, target/51681, tree-optimization/51315
|
||||||
|
- disable go on s390{,x}
|
||||||
|
- disable profiledbootstrap on arm and sparc* for now
|
||||||
|
|
||||||
* Thu Jan 5 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-0.4
|
* Thu Jan 5 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-0.4
|
||||||
- update from trunk
|
- update from trunk
|
||||||
- PRs bootstrap/51072, bootstrap/51648, debug/51746, debug/51762,
|
- PRs bootstrap/51072, bootstrap/51648, debug/51746, debug/51762,
|
||||||
|
24
gcc47-pr47333.patch
Normal file
24
gcc47-pr47333.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
2012-01-06 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
PR target/47333
|
||||||
|
* cgraphunit.c (cgraph_optimize): Call output_weakrefs
|
||||||
|
before emitting functions.
|
||||||
|
|
||||||
|
--- gcc/cgraphunit.c.jj 2011-12-15 08:06:54.000000000 +0100
|
||||||
|
+++ gcc/cgraphunit.c 2012-01-06 14:50:50.291364878 +0100
|
||||||
|
@@ -2187,6 +2187,7 @@ cgraph_optimize (void)
|
||||||
|
#endif
|
||||||
|
bitmap_obstack_release (NULL);
|
||||||
|
cgraph_mark_functions_to_output ();
|
||||||
|
+ output_weakrefs ();
|
||||||
|
|
||||||
|
cgraph_state = CGRAPH_STATE_EXPANSION;
|
||||||
|
if (!flag_toplevel_reorder)
|
||||||
|
@@ -2201,7 +2202,6 @@ cgraph_optimize (void)
|
||||||
|
varpool_assemble_pending_decls ();
|
||||||
|
}
|
||||||
|
|
||||||
|
- output_weakrefs ();
|
||||||
|
cgraph_process_new_functions ();
|
||||||
|
cgraph_state = CGRAPH_STATE_FINISHED;
|
||||||
|
|
27
gcc47-pr50127.patch
Normal file
27
gcc47-pr50127.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
2012-01-06 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
PR gcov-profile/50127
|
||||||
|
* bb-reorder.c (partition_hot_cold_basic_blocks): Clear
|
||||||
|
bb->aux before running df_analyze.
|
||||||
|
|
||||||
|
--- gcc/bb-reorder.c.jj 2011-11-10 18:09:12.000000000 +0100
|
||||||
|
+++ gcc/bb-reorder.c 2012-01-06 13:47:39.619401395 +0100
|
||||||
|
@@ -2219,6 +2219,7 @@ static unsigned
|
||||||
|
partition_hot_cold_basic_blocks (void)
|
||||||
|
{
|
||||||
|
VEC(edge, heap) *crossing_edges;
|
||||||
|
+ basic_block bb;
|
||||||
|
|
||||||
|
if (n_basic_blocks <= NUM_FIXED_BLOCKS + 1)
|
||||||
|
return 0;
|
||||||
|
@@ -2254,6 +2255,10 @@ partition_hot_cold_basic_blocks (void)
|
||||||
|
|
||||||
|
add_reg_crossing_jump_notes ();
|
||||||
|
|
||||||
|
+ /* Clear bb->aux fields that the above routines were using. */
|
||||||
|
+ FOR_EACH_BB (bb)
|
||||||
|
+ bb->aux = NULL;
|
||||||
|
+
|
||||||
|
VEC_free (edge, heap, crossing_edges);
|
||||||
|
|
||||||
|
/* ??? FIXME: DF generates the bb info for a block immediately.
|
Loading…
Reference in New Issue
Block a user