11.0.0-0.10
This commit is contained in:
parent
d92ecedc14
commit
8c7fac2bb2
18
gcc.spec
18
gcc.spec
@ -1,5 +1,5 @@
|
|||||||
%global DATE 20201217
|
%global DATE 20201216
|
||||||
%global gitrev cefb7ee9ef972ce42e8e54a65ef972386b8897d9
|
%global gitrev ada196afb999077a634220ace175f349418e3078
|
||||||
%global gcc_version 11.0.0
|
%global gcc_version 11.0.0
|
||||||
%global gcc_major 11
|
%global gcc_major 11
|
||||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||||
@ -119,7 +119,7 @@
|
|||||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||||
Name: gcc
|
Name: gcc
|
||||||
Version: %{gcc_version}
|
Version: %{gcc_version}
|
||||||
Release: %{gcc_release}.9%{?dist}
|
Release: %{gcc_release}.10%{?dist}
|
||||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||||
# GCC Runtime Exception.
|
# GCC Runtime Exception.
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||||
@ -274,6 +274,7 @@ Patch10: gcc11-rh1574936.patch
|
|||||||
Patch11: gcc11-d-shared-libphobos.patch
|
Patch11: gcc11-d-shared-libphobos.patch
|
||||||
Patch12: gcc11-pr98282.patch
|
Patch12: gcc11-pr98282.patch
|
||||||
Patch13: gcc11-pr98338-workaround.patch
|
Patch13: gcc11-pr98338-workaround.patch
|
||||||
|
Patch14: gcc11-c++tools.patch
|
||||||
|
|
||||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||||
# target triple.
|
# target triple.
|
||||||
@ -787,6 +788,7 @@ to NVidia PTX capable devices if available.
|
|||||||
%patch11 -p0 -b .d-shared-libphobos~
|
%patch11 -p0 -b .d-shared-libphobos~
|
||||||
%patch12 -p0 -b .pr98282~
|
%patch12 -p0 -b .pr98282~
|
||||||
%patch13 -p0 -b .pr98338-workaround~
|
%patch13 -p0 -b .pr98338-workaround~
|
||||||
|
%patch14 -p0 -b .c++tools~
|
||||||
|
|
||||||
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
||||||
|
|
||||||
@ -3071,13 +3073,9 @@ end
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Dec 17 2020 Jakub Jelinek <jakub@redhat.com> 11.0.0-0.9
|
* Thu Dec 17 2020 Jakub Jelinek <jakub@redhat.com> 11.0.0-0.10
|
||||||
- update from trunk
|
- apply workaround for profiledbootstrap x86_64 failure
|
||||||
- PRs c/98047, c/98260, fortran/98284, libstdc++/46447, libstdc++/93151,
|
- put g++-mapper-server into the right directory
|
||||||
libstdc++/96083, libstdc++/98319, rtl-optimization/98271,
|
|
||||||
rtl-optimization/98276, sanitizer/97868, target/98146, target/98280,
|
|
||||||
tree-optimization/96239, tree-optimization/98272,
|
|
||||||
tree-optimization/98279
|
|
||||||
|
|
||||||
* Wed Dec 16 2020 Jakub Jelinek <jakub@redhat.com> 11.0.0-0.8
|
* Wed Dec 16 2020 Jakub Jelinek <jakub@redhat.com> 11.0.0-0.8
|
||||||
- update from trunk
|
- update from trunk
|
||||||
|
86
gcc11-c++tools.patch
Normal file
86
gcc11-c++tools.patch
Normal file
@ -0,0 +1,86 @@
|
|||||||
|
2020-12-17 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
* configure.ac: Add GCC_BASE_VER.
|
||||||
|
* Makefile.in (version): Remove variable.
|
||||||
|
(gcc_version): New variable.
|
||||||
|
(libexecsubdir): Use $(gcc_version) instead of $(version).
|
||||||
|
* configure: Regenerated.
|
||||||
|
|
||||||
|
--- c++tools/configure.ac.jj 2020-12-16 23:38:34.091923526 +0100
|
||||||
|
+++ c++tools/configure.ac 2020-12-17 00:02:48.221661922 +0100
|
||||||
|
@@ -206,6 +206,9 @@ if test $ac_cv_inet_ntop = yes; then
|
||||||
|
[Define if inet_ntop provided.])
|
||||||
|
fi
|
||||||
|
|
||||||
|
+# Determine what GCC version number to use in filesystem paths.
|
||||||
|
+GCC_BASE_VER
|
||||||
|
+
|
||||||
|
AC_CONFIG_HEADERS([config.h])
|
||||||
|
AC_CONFIG_FILES([Makefile])
|
||||||
|
|
||||||
|
--- c++tools/Makefile.in.jj 2020-12-16 23:38:34.091923526 +0100
|
||||||
|
+++ c++tools/Makefile.in 2020-12-17 00:01:54.419263424 +0100
|
||||||
|
@@ -20,8 +20,8 @@ prefix := @prefix@
|
||||||
|
bindir := @bindir@
|
||||||
|
libexecdir := @libexecdir@
|
||||||
|
target_noncanonical := @target_noncanonical@
|
||||||
|
-version := $(shell cat $(srcdir)/../gcc/BASE-VER)
|
||||||
|
-libexecsubdir := $(libexecdir)/gcc/$(target_noncanonical)/$(version)
|
||||||
|
+gcc_version := $(shell @get_gcc_base_ver@ $(srcdir)/../gcc/BASE-VER)
|
||||||
|
+libexecsubdir := $(libexecdir)/gcc/$(target_noncanonical)/$(gcc_version)
|
||||||
|
INSTALL_PROGRAM := @INSTALL_PROGRAM@
|
||||||
|
INSTALL_STRIP_PROGRAM := $(srcdir)/../install-sh -c -s
|
||||||
|
AUTOCONF := @AUTOCONF@
|
||||||
|
--- c++tools/configure.jj 2020-12-16 23:38:34.091923526 +0100
|
||||||
|
+++ c++tools/configure 2020-12-17 00:02:53.849599006 +0100
|
||||||
|
@@ -585,6 +585,7 @@ ac_unique_file="c++tools"
|
||||||
|
ac_unique_file="server.cc"
|
||||||
|
ac_subst_vars='LTLIBOBJS
|
||||||
|
LIBOBJS
|
||||||
|
+get_gcc_base_ver
|
||||||
|
ac_ct_CC
|
||||||
|
CFLAGS
|
||||||
|
CC
|
||||||
|
@@ -658,6 +659,7 @@ ac_user_opts='
|
||||||
|
enable_option_checking
|
||||||
|
enable_c___tools
|
||||||
|
enable_maintainer_mode
|
||||||
|
+with_gcc_major_version_only
|
||||||
|
'
|
||||||
|
ac_precious_vars='build_alias
|
||||||
|
host_alias
|
||||||
|
@@ -1287,6 +1289,12 @@ Optional Features:
|
||||||
|
enable maintainer mode. Add rules to rebuild
|
||||||
|
configurey bits
|
||||||
|
|
||||||
|
+Optional Packages:
|
||||||
|
+ --with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
|
||||||
|
+ --without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
|
||||||
|
+ --with-gcc-major-version-only
|
||||||
|
+ use only GCC major number in filesystem paths
|
||||||
|
+
|
||||||
|
Some influential environment variables:
|
||||||
|
CXX C++ compiler command
|
||||||
|
CXXFLAGS C++ compiler flags
|
||||||
|
@@ -3557,6 +3565,21 @@ $as_echo "#define HAVE_INET_NTOP 1" >>co
|
||||||
|
|
||||||
|
fi
|
||||||
|
|
||||||
|
+# Determine what GCC version number to use in filesystem paths.
|
||||||
|
+
|
||||||
|
+ get_gcc_base_ver="cat"
|
||||||
|
+
|
||||||
|
+# Check whether --with-gcc-major-version-only was given.
|
||||||
|
+if test "${with_gcc_major_version_only+set}" = set; then :
|
||||||
|
+ withval=$with_gcc_major_version_only; if test x$with_gcc_major_version_only = xyes ; then
|
||||||
|
+ get_gcc_base_ver="sed -e 's/^\([0-9]*\).*/\1/'"
|
||||||
|
+ fi
|
||||||
|
+
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
ac_config_headers="$ac_config_headers config.h"
|
||||||
|
|
||||||
|
ac_config_files="$ac_config_files Makefile"
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (gcc-11.0.0-20201217.tar.xz) = b13a21a3caf9867595be06b46e3ee8f9b1439d017378f508145b21e753b758ca099e2f07d105a7bfc0ee44061f7bed1ae5bc79bf7e156cd891e08c8fe3b47460
|
SHA512 (gcc-11.0.0-20201216.tar.xz) = 5624f905eafa693434ca16df9df9b3d7dff6d01d335fb690bee124d5f62cec6f2273a4b13cbe85eac33b00d2e556bfeb246444558c4a33747629529a2bd560ad
|
||||||
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
||||||
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
||||||
|
Loading…
Reference in New Issue
Block a user