10.0.1-0.4
This commit is contained in:
parent
576d41c1c6
commit
7de85a2603
2
gcc.spec
2
gcc.spec
@ -259,6 +259,7 @@ Patch8: gcc10-foffload-default.patch
|
|||||||
Patch9: gcc10-Wno-format-security.patch
|
Patch9: gcc10-Wno-format-security.patch
|
||||||
Patch10: gcc10-rh1574936.patch
|
Patch10: gcc10-rh1574936.patch
|
||||||
Patch11: gcc10-d-shared-libphobos.patch
|
Patch11: gcc10-d-shared-libphobos.patch
|
||||||
|
Patch12: gcc10-libcpp-lex-workaround.patch
|
||||||
|
|
||||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||||
# target triple.
|
# target triple.
|
||||||
@ -770,6 +771,7 @@ to NVidia PTX capable devices if available.
|
|||||||
%patch10 -p0 -b .rh1574936~
|
%patch10 -p0 -b .rh1574936~
|
||||||
%endif
|
%endif
|
||||||
%patch11 -p0 -b .d-shared-libphobos~
|
%patch11 -p0 -b .d-shared-libphobos~
|
||||||
|
%patch12 -p0 -b .libcpp-lex-workaround~
|
||||||
|
|
||||||
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
||||||
|
|
||||||
|
20
gcc10-libcpp-lex-workaround.patch
Normal file
20
gcc10-libcpp-lex-workaround.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- libcpp/lex.c 2020-01-12 11:54:38.565380941 +0100
|
||||||
|
+++ libcpp/lex.c 2020-01-21 14:35:36.182794214 +0100
|
||||||
|
@@ -752,7 +752,7 @@ search_line_fast (const uchar *s, const
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
-#elif defined (__ARM_NEON) && defined (__ARM_64BIT_STATE)
|
||||||
|
+#elif defined (__ARM_NEON) && defined (__ARM_64BIT_STATE) && __has_include("arm_bf16.h")
|
||||||
|
#include "arm_neon.h"
|
||||||
|
|
||||||
|
/* This doesn't have to be the exact page size, but no system may use
|
||||||
|
@@ -847,7 +847,7 @@ done:
|
||||||
|
+ __builtin_ctz (found));
|
||||||
|
}
|
||||||
|
|
||||||
|
-#elif defined (__ARM_NEON)
|
||||||
|
+#elif defined (__ARM_NEON) && __has_include("arm_bf16.h")
|
||||||
|
#include "arm_neon.h"
|
||||||
|
|
||||||
|
static const uchar *
|
Loading…
Reference in New Issue
Block a user