4.4.0-0.17
This commit is contained in:
parent
522700d7f6
commit
74d9670684
@ -1,3 +1,3 @@
|
|||||||
fastjar-0.97.tar.gz
|
fastjar-0.97.tar.gz
|
||||||
gcc-4.4.0-20090206.tar.bz2
|
gcc-4.4.0-20090211.tar.bz2
|
||||||
cloog-ppl-0.15.tar.gz
|
cloog-ppl-0.15.tar.gz
|
||||||
|
19
gcc.spec
19
gcc.spec
@ -1,9 +1,9 @@
|
|||||||
%define DATE 20090206
|
%define DATE 20090211
|
||||||
%define SVNREV 143986
|
%define SVNREV 144103
|
||||||
%define gcc_version 4.4.0
|
%define gcc_version 4.4.0
|
||||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||||
# %{release}, append them after %{gcc_release} on Release: line.
|
# %{release}, append them after %{gcc_release} on Release: line.
|
||||||
%define gcc_release 0.16
|
%define gcc_release 0.17
|
||||||
%define _unpackaged_files_terminate_build 0
|
%define _unpackaged_files_terminate_build 0
|
||||||
%define multilib_64_archs sparc64 ppc64 s390x x86_64
|
%define multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||||
%define include_gappletviewer 1
|
%define include_gappletviewer 1
|
||||||
@ -140,6 +140,7 @@ Patch16: gcc44-libgomp-omp_h-multilib.patch
|
|||||||
Patch20: gcc44-libtool-no-rpath.patch
|
Patch20: gcc44-libtool-no-rpath.patch
|
||||||
Patch21: gcc44-cloog-dl.patch
|
Patch21: gcc44-cloog-dl.patch
|
||||||
Patch22: gcc44-raw-string.patch
|
Patch22: gcc44-raw-string.patch
|
||||||
|
Patch23: gcc44-rh479912.patch
|
||||||
|
|
||||||
Patch1000: fastjar-0.97-segfault.patch
|
Patch1000: fastjar-0.97-segfault.patch
|
||||||
|
|
||||||
@ -426,6 +427,7 @@ which are required to compile with the GNAT.
|
|||||||
%patch21 -p0 -b .cloog-dl~
|
%patch21 -p0 -b .cloog-dl~
|
||||||
%endif
|
%endif
|
||||||
%patch22 -p0 -b .raw-string~
|
%patch22 -p0 -b .raw-string~
|
||||||
|
%patch23 -p0 -b .rh479912~
|
||||||
|
|
||||||
# This testcase doesn't compile.
|
# This testcase doesn't compile.
|
||||||
rm libjava/testsuite/libjava.lang/PR35020*
|
rm libjava/testsuite/libjava.lang/PR35020*
|
||||||
@ -1631,7 +1633,6 @@ fi
|
|||||||
|
|
||||||
%files -n libgcj-devel
|
%files -n libgcj-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_prefix}/bin/addr2name.awk
|
|
||||||
%dir %{_prefix}/lib/gcc
|
%dir %{_prefix}/lib/gcc
|
||||||
%dir %{_prefix}/lib/gcc/%{gcc_target_platform}
|
%dir %{_prefix}/lib/gcc/%{gcc_target_platform}
|
||||||
%dir %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}
|
%dir %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}
|
||||||
@ -1761,6 +1762,16 @@ fi
|
|||||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 11 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-0.17
|
||||||
|
- update from trunk
|
||||||
|
- fix ICE on xen (PR target/39139)
|
||||||
|
- PRs c++/34397, c++/35147, c++/36744, c++/37737, c++/38649, c++/39109,
|
||||||
|
c/35434, c/36432, c/39035, c/39084, middle-end/35202,
|
||||||
|
middle-end/38953, middle-end/38981, middle-end/39124,
|
||||||
|
middle-end/39127, target/39118, target/39119, testsuite/33300,
|
||||||
|
tree-optimization/39132
|
||||||
|
- force emitting .debug_info for empty CUs with -g3 (#479912)
|
||||||
|
|
||||||
* Fri Feb 6 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-0.16
|
* Fri Feb 6 2009 Jakub Jelinek <jakub@redhat.com> 4.4.0-0.16
|
||||||
- update from trunk
|
- update from trunk
|
||||||
- don't emit thunks for versioned functions (PR c++/39106)
|
- don't emit thunks for versioned functions (PR c++/39106)
|
||||||
|
18
gcc44-rh479912.patch
Normal file
18
gcc44-rh479912.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
2009-02-11 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
* dwarf2out.c (dwarf2out_finish): Force output of comp_unit_die
|
||||||
|
for -g3.
|
||||||
|
|
||||||
|
--- gcc/dwarf2out.c.jj 2008-12-11 09:46:59.000000000 +0100
|
||||||
|
+++ gcc/dwarf2out.c 2009-02-11 15:10:06.000000000 +0100
|
||||||
|
@@ -16699,7 +16699,9 @@ dwarf2out_finish (const char *filename)
|
||||||
|
for (node = limbo_die_list; node; node = node->next)
|
||||||
|
output_comp_unit (node->die, 0);
|
||||||
|
|
||||||
|
- output_comp_unit (comp_unit_die, 0);
|
||||||
|
+ /* Output the main compilation unit if non-empty or if .debug_macinfo
|
||||||
|
+ has been emitted. */
|
||||||
|
+ output_comp_unit (comp_unit_die, debug_info_level >= DINFO_LEVEL_VERBOSE);
|
||||||
|
|
||||||
|
/* Output the abbreviation table. */
|
||||||
|
switch_to_section (debug_abbrev_section);
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
2659f09c2e43ef8b7d4406321753f1b2 fastjar-0.97.tar.gz
|
2659f09c2e43ef8b7d4406321753f1b2 fastjar-0.97.tar.gz
|
||||||
fff465378cb0ccdec9a3c8b1f109fe54 gcc-4.4.0-20090206.tar.bz2
|
563b17cabc73a7f8c7a9e3c1c89356e3 gcc-4.4.0-20090211.tar.bz2
|
||||||
716b7a0823f96c9d02c1703a9c47d387 cloog-ppl-0.15.tar.gz
|
716b7a0823f96c9d02c1703a9c47d387 cloog-ppl-0.15.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user