Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/gcc.git#9b91a5481906298ed85361f99721171043abf120
This commit is contained in:
parent
04268627ee
commit
72081a4a1a
1
.gitignore
vendored
1
.gitignore
vendored
@ -32,3 +32,4 @@
|
||||
/gcc-11.0.0-20210119.tar.xz
|
||||
/gcc-11.0.0-20210123.tar.xz
|
||||
/gcc-11.0.0-20210130.tar.xz
|
||||
/gcc-11.0.0-20210210.tar.xz
|
||||
|
28
gcc.spec
28
gcc.spec
@ -1,5 +1,5 @@
|
||||
%global DATE 20210130
|
||||
%global gitrev 17ea13f46910e81a4891636c35aec2b3dabe5879
|
||||
%global DATE 20210210
|
||||
%global gitrev ca24474172e3b0805f9f016bf2a6ef0352aeb755
|
||||
%global gcc_version 11.0.0
|
||||
%global gcc_major 11
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
@ -119,7 +119,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.18%{?dist}
|
||||
Release: %{gcc_release}.19%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -809,6 +809,9 @@ to NVidia PTX capable devices if available.
|
||||
%endif
|
||||
|
||||
rm -f libgomp/testsuite/*/*task-detach*
|
||||
%ifarch %{arm}
|
||||
rm -f gcc/testsuite/go.test/test/fixedbugs/issue19182.go
|
||||
%endif
|
||||
|
||||
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
||||
|
||||
@ -3093,6 +3096,25 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 10 2021 Jakub Jelinek <jakub@redhat.com> 11.0.0-0.19
|
||||
- update from trunk
|
||||
- PRs analyzer/93355, analyzer/96374, analyzer/98575, analyzer/98918,
|
||||
c++/20408, c++/84494, c++/90926, c++/95192, c++/96199, c++/96462,
|
||||
c++/96905, c++/97804, c++/97878, c++/98295, c++/98326, c++/98355,
|
||||
c++/98531, c++/98570, c++/98717, c++/98802, c++/98835, c++/98899,
|
||||
c++/98926, c++/98929, c++/98944, c++/98947, c++/98951, c++/98994,
|
||||
c/97882, c/97932, d/98910, d/98921, debug/98656, driver/98943,
|
||||
fortran/91862, fortran/98913, libstdc++/70303, libstdc++/99021,
|
||||
lto/96591, lto/98912, lto/98971, middle-end/97172, middle-end/97487,
|
||||
middle-end/97971, middle-end/98465, middle-end/98974,
|
||||
middle-end/99004, preprocessor/98882, rtl-optimization/96015,
|
||||
target/97510, target/98172, target/98537, target/98743, target/98957,
|
||||
testsuite/98243, testsuite/98325, tree-optimization/97960,
|
||||
tree-optimization/98287, tree-optimization/98499,
|
||||
tree-optimization/98848, tree-optimization/98855,
|
||||
tree-optimization/98863, tree-optimization/98928,
|
||||
tree-optimization/98937, tree-optimization/99017
|
||||
|
||||
* Sat Jan 30 2021 Jakub Jelinek <jakub@redhat.com> 11.0.0-0.18
|
||||
- update from trunk
|
||||
- PRs ada/98228, bootstrap/98839, c++/33661, c++/88548, c++/94775,
|
||||
|
@ -100,7 +100,7 @@
|
||||
|
||||
--- libcpp/expr.c.jj 2019-01-09 13:01:22.415535734 +0100
|
||||
+++ libcpp/expr.c 2019-01-11 18:16:23.444726882 +0100
|
||||
@@ -788,16 +788,17 @@ cpp_classify_number (cpp_reader *pfile,
|
||||
@@ -803,16 +803,17 @@ cpp_classify_number (cpp_reader *pfile,
|
||||
if ((result & CPP_N_WIDTH) == CPP_N_LARGE
|
||||
&& CPP_OPTION (pfile, cpp_warn_long_long))
|
||||
{
|
||||
@ -123,4 +123,4 @@
|
||||
+ : N_("use of C99 long long integer constant"));
|
||||
}
|
||||
|
||||
result |= CPP_N_INTEGER;
|
||||
if ((result & CPP_N_SIZE_T) == CPP_N_SIZE_T
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-11.0.0-20210130.tar.xz) = 8f7a43910a8097a146987c1f336cd51fff2c236ecdf3e1e46b87a6f0336f40483922d997d8a95f26b35b97e91879fbb3a3840492ef823110a280f29745d437f8
|
||||
SHA512 (gcc-11.0.0-20210210.tar.xz) = 7820ba74e26edc4bb89e63b5b6010dff672b844ba69697a78fcc00b5163f377aa6e352d4f52aa62325ff13ee6778ac23683f7b489404de3a9bb66ceae738f319
|
||||
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
||||
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
||||
|
Loading…
Reference in New Issue
Block a user