12.0.1-0.16
This commit is contained in:
parent
665f9ff9cb
commit
7198391f75
1
.gitignore
vendored
1
.gitignore
vendored
@ -69,3 +69,4 @@
|
||||
/gcc-12.0.1-20220308.tar.xz
|
||||
/gcc-12.0.1-20220401.tar.xz
|
||||
/gcc-12.0.1-20220411.tar.xz
|
||||
/gcc-12.0.1-20220413.tar.xz
|
||||
|
20
gcc.spec
20
gcc.spec
@ -1,5 +1,5 @@
|
||||
%global DATE 20220411
|
||||
%global gitrev c520f3606c4d0f971a172e17c55b06aec363a417
|
||||
%global DATE 20220413
|
||||
%global gitrev 33917d2d6edc9112702294db6ab14b580a8d7a97
|
||||
%global gcc_version 12.0.1
|
||||
%global gcc_major 12
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
@ -125,7 +125,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.15%{?dist}
|
||||
Release: %{gcc_release}.16%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -275,7 +275,6 @@ Patch8: gcc12-no-add-needed.patch
|
||||
Patch9: gcc12-Wno-format-security.patch
|
||||
Patch10: gcc12-rh1574936.patch
|
||||
Patch11: gcc12-d-shared-libphobos.patch
|
||||
Patch12: gcc12-pr105214.patch
|
||||
|
||||
Patch100: gcc12-fortran-fdec-duplicates.patch
|
||||
Patch101: gcc12-fortran-flogical-as-integer.patch
|
||||
@ -809,7 +808,6 @@ so that there cannot be any synchronization problems.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr105214~
|
||||
|
||||
%if 0%{?rhel} >= 9
|
||||
%patch100 -p1 -b .fortran-fdec-duplicates~
|
||||
@ -3227,6 +3225,18 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Apr 13 2022 Jakub Jelinek <jakub@redhat.com> 12.0.1-0.16
|
||||
- update from trunk
|
||||
- PRs c++/97296, c++/98249, c++/100111, c++/103105, c++/104142, c++/104669,
|
||||
c++/105223, c++/105233, c++/105245, jit/104071, jit/104072,
|
||||
jit/104073, jit/104293, middle-end/105253, middle-end/105259,
|
||||
rtl-optimization/105211, target/95325, target/97348, target/101755,
|
||||
target/102146, target/103623, target/104144, target/104894,
|
||||
target/105213, target/105214, target/105234, testsuite/105183,
|
||||
tree-optimization/104912, tree-optimization/105226,
|
||||
tree-optimization/105232, tree-optimization/105235,
|
||||
tree-optimization/105250, tree-optimization/105263
|
||||
|
||||
* Mon Apr 11 2022 Jakub Jelinek <jakub@redhat.com> 12.0.1-0.15
|
||||
- update from trunk
|
||||
- PRs analyzer/102208, analyzer/103892, c++/91618, c++/92385, c++/96604,
|
||||
|
@ -1,38 +0,0 @@
|
||||
2022-04-11 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR target/105214
|
||||
* config/i386/i386-expand.cc (ix86_emit_i387_log1p): Call
|
||||
do_pending_stack_adjust.
|
||||
|
||||
* gcc.dg/asan/pr105214.c: New test.
|
||||
|
||||
--- gcc/config/i386/i386-expand.cc.jj 2022-04-03 21:50:36.001635947 +0200
|
||||
+++ gcc/config/i386/i386-expand.cc 2022-04-11 15:17:43.943430658 +0200
|
||||
@@ -17291,6 +17291,8 @@ void ix86_emit_i387_log1p (rtx op0, rtx
|
||||
rtx cst, cstln2, cst1;
|
||||
rtx_insn *insn;
|
||||
|
||||
+ do_pending_stack_adjust ();
|
||||
+
|
||||
cst = const_double_from_real_value
|
||||
(REAL_VALUE_ATOF ("0.29289321881345247561810596348408353", XFmode), XFmode);
|
||||
cstln2 = force_reg (XFmode, standard_80387_constant_rtx (4)); /* fldln2 */
|
||||
--- gcc/testsuite/gcc.dg/asan/pr105214.c.jj 2022-04-11 15:21:05.467608711 +0200
|
||||
+++ gcc/testsuite/gcc.dg/asan/pr105214.c 2022-04-11 15:22:10.559697224 +0200
|
||||
@@ -0,0 +1,16 @@
|
||||
+/* PR target/105214 */
|
||||
+/* { dg-do compile } */
|
||||
+/* { dg-skip-if "" { *-*-* } { "*" } { "-O2" } } */
|
||||
+/* { dg-options "-Ofast -fnon-call-exceptions -fexceptions -fstack-check=generic -fsanitize=address -fno-finite-math-only -fsignaling-nans -fno-associative-math" } */
|
||||
+
|
||||
+float f;
|
||||
+void bar (int *);
|
||||
+
|
||||
+void
|
||||
+foo (void)
|
||||
+{
|
||||
+ int a[1600], b[1];
|
||||
+ f += __builtin_log1pf (f);
|
||||
+ bar (a);
|
||||
+ bar (b);
|
||||
+}
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-12.0.1-20220411.tar.xz) = c611c45dfa5c9c367203f6273e24c4ba03bb56a8dc8954e7b26b9fc0de60a2aefe2a2d12098daad827d2c0ad71ba1092b0d7f808eb9e8cf929ad22154176fda0
|
||||
SHA512 (gcc-12.0.1-20220413.tar.xz) = 6500348f3f4e22f0ddc6ac332a1e6f64eb2684772c67401ddd98c96aabc1ce665cd088161c5878cfc24defa240f587af962ac38d9cbe94044261239be63dc47a
|
||||
SHA512 (isl-0.18.tar.bz2) = 85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94
|
||||
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
||||
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
||||
|
Loading…
Reference in New Issue
Block a user