13.0.1-0.15
This commit is contained in:
parent
52a79c17ee
commit
6fdcb2b9e5
1
.gitignore
vendored
1
.gitignore
vendored
@ -101,3 +101,4 @@
|
||||
/gcc-13.0.1-20230401.tar.xz
|
||||
/gcc-13.0.1-20230404.tar.xz
|
||||
/gcc-13.0.1-20230418.tar.xz
|
||||
/gcc-13.0.1-20230419.tar.xz
|
||||
|
13
gcc.spec
13
gcc.spec
@ -1,5 +1,5 @@
|
||||
%global DATE 20230418
|
||||
%global gitrev 90e2966fefb872b610765ac4f89ad9bcab43d72c
|
||||
%global DATE 20230419
|
||||
%global gitrev fa3dfe9cf38be8a7cb0e7d0c11c67e8767f8e008
|
||||
%global gcc_version 13.0.1
|
||||
%global gcc_major 13
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
@ -136,7 +136,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.14%{?dist}
|
||||
Release: %{gcc_release}.15%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -286,7 +286,6 @@ Patch8: gcc13-no-add-needed.patch
|
||||
Patch9: gcc13-Wno-format-security.patch
|
||||
Patch10: gcc13-rh1574936.patch
|
||||
Patch11: gcc13-d-shared-libphobos.patch
|
||||
Patch12: gcc13-pr108969.patch
|
||||
|
||||
Patch50: isl-rh2155127.patch
|
||||
|
||||
@ -863,7 +862,6 @@ so that there cannot be any synchronization problems.
|
||||
%patch -P10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch -P11 -p0 -b .d-shared-libphobos~
|
||||
%patch -P12 -p0 -b .pr108969~
|
||||
|
||||
%patch -P50 -p0 -b .rh2155127~
|
||||
touch -r isl-0.24/m4/ax_prog_cxx_for_build.m4 isl-0.24/m4/ax_prog_cc_for_build.m4
|
||||
@ -3460,6 +3458,11 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Apr 19 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.15
|
||||
- update from trunk and releases/gcc-13 branch
|
||||
- GCC 13.1-rc2
|
||||
- PRs c++/109556, target/106602
|
||||
|
||||
* Tue Apr 18 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.14
|
||||
- update from trunk and releases/gcc-13 branch
|
||||
- PRs analyzer/108722, bootstrap/109510, c++/109277, c++/109357, c++/109420,
|
||||
|
@ -1,29 +0,0 @@
|
||||
libstdc++: Fix preprocessor condition in linker script [PR108969]
|
||||
|
||||
The linker script is preprocessed with $(top_builddir)/config.h not the
|
||||
include/$target/bits/c++config.h version, which means that configure
|
||||
macros do not have the _GLIBCXX_ prefix yet.
|
||||
|
||||
The _GLIBCXX_SYMVER_GNU and _GLIBCXX_SHARED checks are redundant,
|
||||
because the gnu.ver file is only used for _GLIBCXX_SYMVER_GNU and the
|
||||
linker script is only used for the shared library. Remove those.
|
||||
|
||||
libstdc++-v3/ChangeLog:
|
||||
|
||||
PR libstdc++/108969
|
||||
* config/abi/pre/gnu.ver: Fix preprocessor condition.
|
||||
|
||||
--- libstdc++-v3/config/abi/pre/gnu.ver
|
||||
+++ libstdc++-v3/config/abi/pre/gnu.ver
|
||||
@@ -2512,9 +2512,8 @@ GLIBCXX_3.4.31 {
|
||||
_ZNKSt12__shared_ptrINSt10filesystem28recursive_directory_iterator10_Dir_stackELN9__gnu_cxx12_Lock_policyE[012]EEcvbEv;
|
||||
_ZNKSt12__shared_ptrINSt10filesystem7__cxx1128recursive_directory_iterator10_Dir_stackELN9__gnu_cxx12_Lock_policyE[012]EEcvbEv;
|
||||
|
||||
-#if defined(_GLIBCXX_SYMVER_GNU) && defined(_GLIBCXX_SHARED) \
|
||||
- && defined(_GLIBCXX_HAVE_AS_SYMVER_DIRECTIVE) \
|
||||
- && defined(_GLIBCXX_HAVE_SYMVER_SYMBOL_RENAMING_RUNTIME_SUPPORT)
|
||||
+#if defined(HAVE_AS_SYMVER_DIRECTIVE) \
|
||||
+ && defined(HAVE_SYMVER_SYMBOL_RENAMING_RUNTIME_SUPPORT)
|
||||
# See src/c++98/globals_io.cc
|
||||
_ZSt3cin;
|
||||
_ZSt4cout;
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-13.0.1-20230418.tar.xz) = 2015b135608474d16dde00cccf03a405898494eb2988048e781b9ae64e3b8a7a6d3b4faf3ca30185ec9e18cd7728d5fdc195aaedc25c75ccc59c5105d1424fcd
|
||||
SHA512 (gcc-13.0.1-20230419.tar.xz) = 4723c151479826238cd53f32577eb91578f0314aedda77598ce3d2e7b5287fd57789bfc42c3511e6716775fd895716a2974ad7a1afda248629af27445982deea
|
||||
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
||||
SHA512 (newlib-cygwin-9e09d6ed83cce4777a5950412647ccc603040409.tar.xz) = bef3fa04f7b1a915fc1356ebed114698b5cc835e9fa04b0becff05a9efc76c59fb376482990873d222d7acdcfee3c4f30f5a4cb7f3be1f291f1fa5f1c7a9d983
|
||||
SHA512 (nvptx-tools-93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b.tar.xz) = c719fad8689b2b6f3c888d0308604ddef884037d71ec3e755c68052d30075a181c29358fda516833ace437921b17602b147be7886317be94ec9736faa8cb52be
|
||||
|
Loading…
Reference in New Issue
Block a user