4.4.2-20.fc13
This commit is contained in:
parent
462317c02b
commit
6e98f300dc
@ -1,2 +1,2 @@
|
||||
fastjar-0.97.tar.gz
|
||||
gcc-4.4.2-20091204.tar.bz2
|
||||
gcc-4.4.2-20091222.tar.bz2
|
||||
|
16
fastjar-0.97-len1.patch
Normal file
16
fastjar-0.97-len1.patch
Normal file
@ -0,0 +1,16 @@
|
||||
2009-12-21 Chris Ball <cjb@laptop.org>
|
||||
|
||||
* jartool.c (add_file_to_jar): Test write return value against -1
|
||||
instead of 1.
|
||||
|
||||
--- fastjar-0.97/jartool.c.jj 2008-10-15 12:35:37.000000000 -0400
|
||||
+++ fastjar-0.97/jartool.c 2009-12-22 06:48:09.309530000 -0500
|
||||
@@ -1257,7 +1257,7 @@ int add_file_to_jar(int jfd, int ffd, co
|
||||
exit_on_error("write");
|
||||
|
||||
/* write the file name to the zip file */
|
||||
- if (1 == write(jfd, fname, file_name_length))
|
||||
+ if (-1 == write(jfd, fname, file_name_length))
|
||||
exit_on_error("write");
|
||||
|
||||
if(verbose){
|
62
gcc.spec
62
gcc.spec
@ -1,12 +1,16 @@
|
||||
%global DATE 20091204
|
||||
%global SVNREV 154977
|
||||
%global DATE 20091222
|
||||
%global SVNREV 155395
|
||||
%global gcc_version 4.4.2
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 14
|
||||
%global gcc_release 20
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%if 0%{?fedora} >= 13
|
||||
%global include_gappletviewer 0
|
||||
%else
|
||||
%global include_gappletviewer 1
|
||||
%endif
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
%global build_ada 1
|
||||
%else
|
||||
@ -163,6 +167,7 @@ Patch18: gcc44-libstdc++-docs.patch
|
||||
Patch19: gcc44-ppc64-aixdesc.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -347,7 +352,9 @@ Requires: libart_lgpl >= 2.1.0
|
||||
%if %{build_java}
|
||||
BuildRequires: gtk2-devel >= 2.4.0
|
||||
BuildRequires: glib2-devel >= 2.4.0
|
||||
%if %{include_gappletviewer}
|
||||
BuildRequires: xulrunner-devel
|
||||
%endif
|
||||
BuildRequires: libart_lgpl-devel >= 2.1.0
|
||||
BuildRequires: alsa-lib-devel
|
||||
BuildRequires: libXtst-devel
|
||||
@ -473,6 +480,7 @@ rm libjava/testsuite/libjava.lang/PR35020*
|
||||
tar xzf %{SOURCE4}
|
||||
|
||||
%patch1000 -p0 -b .fastjar-0.97-segfault~
|
||||
%patch1001 -p0 -b .fastjar-0.97-len1~
|
||||
|
||||
%if %{bootstrap_java}
|
||||
tar xjf %{SOURCE10}
|
||||
@ -611,7 +619,10 @@ CC="$CC" CFLAGS="$OPT_FLAGS" CXXFLAGS="`echo $OPT_FLAGS | sed 's/ -Wall / /g'`"
|
||||
%if !%{build_java}
|
||||
--disable-libgcj \
|
||||
%else
|
||||
--enable-java-awt=gtk --disable-dssi --enable-plugin \
|
||||
--enable-java-awt=gtk --disable-dssi \
|
||||
%if %{include_gappletviewer}
|
||||
--enable-plugin \
|
||||
%endif
|
||||
--with-java-home=%{_prefix}/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre \
|
||||
--enable-libgcj-multifile \
|
||||
%if !%{bootstrap_java}
|
||||
@ -1383,6 +1394,8 @@ fi
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/fma4intrin.h
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/xopintrin.h
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/lwpintrin.h
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/abmintrin.h
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/popcntintrin.h
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/mm_malloc.h
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/mm3dnow.h
|
||||
%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_version}/include/cpuid.h
|
||||
@ -1849,6 +1862,47 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 22 2009 Jakub Jelinek <jakub@redhat.com> 4.4.2-20
|
||||
- fix MEM_SIZE of reload created stack slots (#548825,
|
||||
PR rtl-optimization/42429)
|
||||
%if !%{include_gappletviewer}
|
||||
- remove gappletviewer, gcjwebplugin and related files for F13 (#548783)
|
||||
%endif
|
||||
- fix addition of one character long filenames in fastjar (#549493)
|
||||
|
||||
* Thu Dec 17 2009 Jakub Jelinek <jakub@redhat.com> 4.4.2-18
|
||||
- update from gcc-4_4-branch
|
||||
- PRs c++/42387
|
||||
- another C++ virtual dtors fix (PR c++/42386)
|
||||
- VTA mode and COND_EXEC fixes (PR debug/41679)
|
||||
- fix ICE in chrec_convert_1 (#547775)
|
||||
- fix debuginfo for optimized out TLS vars
|
||||
- use DW_AT_location with DW_OP_addr + DW_OP_stack_value instead of
|
||||
DW_AT_const_value with address in it, use DW_OP_addr + DW_OP_stack_value
|
||||
instead of DW_OP_implicit_value with address (#546017)
|
||||
|
||||
* Mon Dec 14 2009 Jakub Jelinek <jakub@redhat.com> 4.4.2-17
|
||||
- propagate TREE_NOTHROW/TREE_READONLY/DECL_PURE_P from ipa-pure-const and
|
||||
EH opt to all same body aliases (#547286)
|
||||
- don't emit DWARF location list entries with no location or DW_AT_location
|
||||
with empty blocks (PR debug/41473)
|
||||
- fix up AMD LWP support
|
||||
- don't crash when mangling C++ decls inside of middle-end generated functions
|
||||
(PR c++/41183)
|
||||
|
||||
* Fri Dec 11 2009 Jakub Jelinek <jakub@redhat.com> 4.4.2-16
|
||||
- update from gcc-4_4-branch
|
||||
- PRs c++/27425, c++/34274, c++/42301, fortran/42268, java/41991,
|
||||
libstdc++/42273, rtl-optimization/41574, target/41196, target/41939
|
||||
target/42263
|
||||
|
||||
* Wed Dec 9 2009 Jakub Jelinek <jakub@redhat.com> 4.4.2-15
|
||||
- VTA backports
|
||||
- PRs debug/42166, debug/42234, debug/42244, debug/42299
|
||||
- fix handling of C++ COMDAT virtual destructors
|
||||
- some x86/x86_64 FMA4, XOP, ABM and LWP fixes
|
||||
- fix a decltype handling bug in templates (PR c++/42277)
|
||||
|
||||
* Fri Dec 4 2009 Jakub Jelinek <jakub@redhat.com> 4.4.2-14
|
||||
- update from gcc-4_4-branch
|
||||
- PRs libstdc++/42261, middle-end/42049
|
||||
|
@ -1,3 +1,4 @@
|
||||
gcc-4_4_0-0_3:HEAD:gcc-4.4.0-0.3.src.rpm:1232130841
|
||||
gcc-4_4_0-5:HEAD:gcc-4.4.0-5.src.rpm:1242291126
|
||||
gcc-4_4_2-14_fc13:HEAD:gcc-4.4.2-14.fc13.src.rpm:1259930464
|
||||
gcc-4_4_2-20_fc13:HEAD:gcc-4.4.2-20.fc13.src.rpm:1261484502
|
||||
|
Loading…
Reference in New Issue
Block a user