11.2.1-7
This commit is contained in:
parent
80be3f02ea
commit
671fc7ba16
1
.gitignore
vendored
1
.gitignore
vendored
@ -53,3 +53,4 @@
|
||||
/gcc-11.2.1-20211012.tar.xz
|
||||
/gcc-11.2.1-20211018.tar.xz
|
||||
/gcc-11.2.1-20211019.tar.xz
|
||||
/gcc-11.2.1-20211203.tar.xz
|
||||
|
37
gcc.spec
37
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20211019
|
||||
%global gitrev 0990a48aaf68b56a3737fdb290328df1da9095cc
|
||||
%global DATE 20211203
|
||||
%global gitrev e41308252e835ddedcabfd4a98240080c6583a43
|
||||
%global gcc_version 11.2.1
|
||||
%global gcc_major 11
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 6
|
||||
%global gcc_release 7
|
||||
%global nvptx_tools_gitrev 5f6f343a302d620b0868edab376c00b15741e39e
|
||||
%global newlib_cygwin_gitrev 50e2a63b04bdd018484605fbb954fd1bd5147fa0
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -270,7 +270,7 @@ Patch13: gcc11-pr99341-revert.patch
|
||||
Patch14: gcc11-libgcc-link.patch
|
||||
Patch15: gcc11-pr101786.patch
|
||||
Patch16: gcc11-stringify-__VA_OPT__.patch
|
||||
Patch17: gcc11-pr102642.patch
|
||||
Patch17: gcc11-stringify-__VA_OPT__-2.patch
|
||||
|
||||
Patch100: gcc11-fortran-fdec-duplicates.patch
|
||||
Patch101: gcc11-fortran-flogical-as-integer.patch
|
||||
@ -799,7 +799,7 @@ to NVidia PTX capable devices if available.
|
||||
%patch14 -p0 -b .libgcc-link~
|
||||
%patch15 -p0 -b .pr101786~
|
||||
%patch16 -p0 -b .stringify-__VA_OPT__~
|
||||
%patch17 -p0 -b .pr102642~
|
||||
%patch17 -p0 -b .stringify-__VA_OPT__-2~
|
||||
|
||||
%if 0%{?rhel} >= 9
|
||||
%patch100 -p1 -b .fortran-fdec-duplicates~
|
||||
@ -3148,6 +3148,33 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 3 2021 Jakub Jelinek <jakub@redhat.com> 11.2.1-7
|
||||
- update from releases/gcc-11-branch
|
||||
- PRs ada/100486, c++/70796, c++/92746, c++/93286, c++/94490, c++/102642,
|
||||
c++/102786, debug/101378, debug/103046, debug/103315, fortran/87711,
|
||||
fortran/87851, fortran/97896, fortran/99061, fortran/99348,
|
||||
fortran/102521, fortran/102685, fortran/102715, fortran/102745,
|
||||
fortran/102816, fortran/102817, fortran/102917, fortran/103137,
|
||||
fortran/103138, fortran/103392, gcov-profile/100520, ipa/102714,
|
||||
ipa/102762, ipa/103052, ipa/103246, ipa/103267, libstdc++/96416,
|
||||
libstdc++/98421, libstdc++/100117, libstdc++/100153, libstdc++/100748,
|
||||
libstdc++/101571, libstdc++/101608, libstdc++/102894,
|
||||
libstdc++/103022, libstdc++/103086, libstdc++/103133,
|
||||
libstdc++/103240, libstdc++/103381, middle-end/64888,
|
||||
middle-end/101480, middle-end/102431, middle-end/102518,
|
||||
middle-end/103059, middle-end/103181, middle-end/103248,
|
||||
middle-end/103384, preprocessor/103130, rtl-optimization/102356,
|
||||
rtl-optimization/102842, target/101985, target/102976, target/102991,
|
||||
target/103205, target/103274, target/103275, testsuite/102690,
|
||||
tree-optimization/100393, tree-optimization/102139,
|
||||
tree-optimization/102505, tree-optimization/102572,
|
||||
tree-optimization/102788, tree-optimization/102789,
|
||||
tree-optimization/102798, tree-optimization/102970,
|
||||
tree-optimization/103192, tree-optimization/103204,
|
||||
tree-optimization/103237, tree-optimization/103255,
|
||||
tree-optimization/103435
|
||||
- fix up #__VA_OPT__ handling (PR preprocessor/103415)
|
||||
|
||||
* Tue Oct 19 2021 Jakub Jelinek <jakub@redhat.com> 11.2.1-6
|
||||
- update from releases/gcc-11-branch
|
||||
- PRs target/100208, target/100316, target/102761
|
||||
|
@ -1,47 +0,0 @@
|
||||
2021-10-11 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR c++/102642
|
||||
* name-lookup.c (push_local_extern_decl_alias): Don't call
|
||||
set_decl_tls_model on error_mark_node.
|
||||
* parser.c (cp_parser_omp_declare_target): Likewise.
|
||||
|
||||
* g++.dg/tls/pr102642.C: New test.
|
||||
|
||||
--- gcc/cp/name-lookup.c.jj 2021-10-01 10:30:07.674588541 +0200
|
||||
+++ gcc/cp/name-lookup.c 2021-10-11 12:43:39.261051228 +0200
|
||||
@@ -3474,7 +3474,9 @@ push_local_extern_decl_alias (tree decl)
|
||||
push_nested_namespace (ns);
|
||||
alias = do_pushdecl (alias, /* hiding= */true);
|
||||
pop_nested_namespace (ns);
|
||||
- if (VAR_P (decl) && CP_DECL_THREAD_LOCAL_P (decl))
|
||||
+ if (VAR_P (decl)
|
||||
+ && CP_DECL_THREAD_LOCAL_P (decl)
|
||||
+ && alias != error_mark_node)
|
||||
set_decl_tls_model (alias, DECL_TLS_MODEL (decl));
|
||||
}
|
||||
}
|
||||
--- gcc/cp/parser.c.jj 2021-10-09 10:14:24.043098112 +0200
|
||||
+++ gcc/cp/parser.c 2021-10-11 12:47:21.220874667 +0200
|
||||
@@ -45665,7 +45666,8 @@ cp_parser_omp_declare_target (cp_parser
|
||||
if (VAR_OR_FUNCTION_DECL_P (t)
|
||||
&& DECL_LOCAL_DECL_P (t)
|
||||
&& DECL_LANG_SPECIFIC (t)
|
||||
- && DECL_LOCAL_DECL_ALIAS (t))
|
||||
+ && DECL_LOCAL_DECL_ALIAS (t)
|
||||
+ && DECL_LOCAL_DECL_ALIAS (t) != error_mark_node)
|
||||
handle_omp_declare_target_clause (c, DECL_LOCAL_DECL_ALIAS (t),
|
||||
device_type);
|
||||
}
|
||||
--- gcc/testsuite/g++.dg/tls/pr102642.C.jj 2021-10-11 13:00:35.889503002 +0200
|
||||
+++ gcc/testsuite/g++.dg/tls/pr102642.C 2021-10-11 13:00:20.388724721 +0200
|
||||
@@ -0,0 +1,10 @@
|
||||
+// PR c++/102642
|
||||
+// { dg-do compile { target c++11 } }
|
||||
+
|
||||
+thread_local int *z; // { dg-message "previous declaration" }
|
||||
+
|
||||
+void
|
||||
+foo ()
|
||||
+{
|
||||
+ extern thread_local int z; // { dg-error "conflicting declaration" }
|
||||
+}
|
197
gcc11-stringify-__VA_OPT__-2.patch
Normal file
197
gcc11-stringify-__VA_OPT__-2.patch
Normal file
@ -0,0 +1,197 @@
|
||||
libcpp: Fix up #__VA_OPT__ handling [PR103415]
|
||||
|
||||
stringify_arg uses pfile->u_buff to create the string literal.
|
||||
Unfortunately, paste_tokens -> _cpp_lex_direct -> lex_number -> _cpp_unaligned_alloc
|
||||
can in some cases use pfile->u_buff too, which results in losing everything
|
||||
prepared for the string literal until the token pasting.
|
||||
|
||||
The following patch fixes that by not calling paste_token during the
|
||||
construction of the string literal, but doing that before. All the tokens
|
||||
we are processing have been pushed into a token buffer using
|
||||
tokens_buff_add_token so it is fine if we paste some of them in that buffer
|
||||
(successful pasting creates a new token in that buffer), move following
|
||||
tokens if any to make it contiguous, pop (throw away) the extra tokens at
|
||||
the end and then do stringify_arg.
|
||||
|
||||
Also, paste_tokens now copies over PREV_WHITE and PREV_FALLTHROUGH flags
|
||||
from the original lhs token to the replacement token. Copying that way
|
||||
the PREV_WHITE flag is needed for the #__VA_OPT__ handling and copying
|
||||
over PREV_FALLTHROUGH fixes the new Wimplicit-fallthrough-38.c test.
|
||||
|
||||
2021-12-01 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR preprocessor/103415
|
||||
libcpp/
|
||||
* macro.c (stringify_arg): Remove va_opt argument and va_opt handling.
|
||||
(paste_tokens): On successful paste or in PREV_WHITE and
|
||||
PREV_FALLTHROUGH flags from the *plhs token to the new token.
|
||||
(replace_args): Adjust stringify_arg callers. For #__VA_OPT__,
|
||||
perform token pasting in a separate loop before stringify_arg call.
|
||||
gcc/testsuite/
|
||||
* c-c++-common/cpp/va-opt-8.c: New test.
|
||||
* c-c++-common/Wimplicit-fallthrough-38.c: New test.
|
||||
|
||||
--- libcpp/macro.c.jj
|
||||
+++ libcpp/macro.c
|
||||
@@ -295,7 +295,7 @@ static cpp_context *next_context (cpp_reader *);
|
||||
static const cpp_token *padding_token (cpp_reader *, const cpp_token *);
|
||||
static const cpp_token *new_string_token (cpp_reader *, uchar *, unsigned int);
|
||||
static const cpp_token *stringify_arg (cpp_reader *, const cpp_token **,
|
||||
- unsigned int, bool);
|
||||
+ unsigned int);
|
||||
static void paste_all_tokens (cpp_reader *, const cpp_token *);
|
||||
static bool paste_tokens (cpp_reader *, location_t,
|
||||
const cpp_token **, const cpp_token *);
|
||||
@@ -834,8 +834,7 @@ cpp_quote_string (uchar *dest, const uchar *src, unsigned int len)
|
||||
/* Convert a token sequence FIRST to FIRST+COUNT-1 to a single string token
|
||||
according to the rules of the ISO C #-operator. */
|
||||
static const cpp_token *
|
||||
-stringify_arg (cpp_reader *pfile, const cpp_token **first, unsigned int count,
|
||||
- bool va_opt)
|
||||
+stringify_arg (cpp_reader *pfile, const cpp_token **first, unsigned int count)
|
||||
{
|
||||
unsigned char *dest;
|
||||
unsigned int i, escape_it, backslash_count = 0;
|
||||
@@ -852,24 +851,6 @@ stringify_arg (cpp_reader *pfile, const cpp_token **first, unsigned int count,
|
||||
{
|
||||
const cpp_token *token = first[i];
|
||||
|
||||
- if (va_opt && (token->flags & PASTE_LEFT))
|
||||
- {
|
||||
- location_t virt_loc = pfile->invocation_location;
|
||||
- const cpp_token *rhs;
|
||||
- do
|
||||
- {
|
||||
- if (i == count)
|
||||
- abort ();
|
||||
- rhs = first[++i];
|
||||
- if (!paste_tokens (pfile, virt_loc, &token, rhs))
|
||||
- {
|
||||
- --i;
|
||||
- break;
|
||||
- }
|
||||
- }
|
||||
- while (rhs->flags & PASTE_LEFT);
|
||||
- }
|
||||
-
|
||||
if (token->type == CPP_PADDING)
|
||||
{
|
||||
if (source == NULL
|
||||
@@ -1003,6 +984,7 @@ paste_tokens (cpp_reader *pfile, location_t location,
|
||||
return false;
|
||||
}
|
||||
|
||||
+ lhs->flags |= (*plhs)->flags & (PREV_WHITE | PREV_FALLTHROUGH);
|
||||
*plhs = lhs;
|
||||
_cpp_pop_buffer (pfile);
|
||||
return true;
|
||||
@@ -1945,8 +1927,7 @@ replace_args (cpp_reader *pfile, cpp_hashnode *node, cpp_macro *macro,
|
||||
if (src->flags & STRINGIFY_ARG)
|
||||
{
|
||||
if (!arg->stringified)
|
||||
- arg->stringified = stringify_arg (pfile, arg->first, arg->count,
|
||||
- false);
|
||||
+ arg->stringified = stringify_arg (pfile, arg->first, arg->count);
|
||||
}
|
||||
else if ((src->flags & PASTE_LEFT)
|
||||
|| (src != macro->exp.tokens && (src[-1].flags & PASTE_LEFT)))
|
||||
@@ -2066,11 +2047,46 @@ replace_args (cpp_reader *pfile, cpp_hashnode *node, cpp_macro *macro,
|
||||
{
|
||||
unsigned int count
|
||||
= start ? paste_flag - start : tokens_buff_count (buff);
|
||||
- const cpp_token *t
|
||||
- = stringify_arg (pfile,
|
||||
- start ? start + 1
|
||||
- : (const cpp_token **) (buff->base),
|
||||
- count, true);
|
||||
+ const cpp_token **first
|
||||
+ = start ? start + 1
|
||||
+ : (const cpp_token **) (buff->base);
|
||||
+ unsigned int i, j;
|
||||
+
|
||||
+ /* Paste any tokens that need to be pasted before calling
|
||||
+ stringify_arg, because stringify_arg uses pfile->u_buff
|
||||
+ which paste_tokens can use as well. */
|
||||
+ for (i = 0, j = 0; i < count; i++, j++)
|
||||
+ {
|
||||
+ const cpp_token *token = first[i];
|
||||
+
|
||||
+ if (token->flags & PASTE_LEFT)
|
||||
+ {
|
||||
+ location_t virt_loc = pfile->invocation_location;
|
||||
+ const cpp_token *rhs;
|
||||
+ do
|
||||
+ {
|
||||
+ if (i == count)
|
||||
+ abort ();
|
||||
+ rhs = first[++i];
|
||||
+ if (!paste_tokens (pfile, virt_loc, &token, rhs))
|
||||
+ {
|
||||
+ --i;
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+ while (rhs->flags & PASTE_LEFT);
|
||||
+ }
|
||||
+
|
||||
+ first[j] = token;
|
||||
+ }
|
||||
+ if (j != i)
|
||||
+ {
|
||||
+ while (i-- != j)
|
||||
+ tokens_buff_remove_last_token (buff);
|
||||
+ count = j;
|
||||
+ }
|
||||
+
|
||||
+ const cpp_token *t = stringify_arg (pfile, first, count);
|
||||
while (count--)
|
||||
tokens_buff_remove_last_token (buff);
|
||||
if (src->flags & PASTE_LEFT)
|
||||
--- gcc/testsuite/c-c++-common/cpp/va-opt-8.c.jj
|
||||
+++ gcc/testsuite/c-c++-common/cpp/va-opt-8.c
|
||||
@@ -0,0 +1,18 @@
|
||||
+/* PR preprocessor/103415 */
|
||||
+/* { dg-do run } */
|
||||
+/* { dg-options "-std=gnu99" { target c } } */
|
||||
+/* { dg-options "-std=c++20" { target c++ } } */
|
||||
+
|
||||
+#define n(x, ...) = #__VA_OPT__(x##3)
|
||||
+#define o(x, ...) #__VA_OPT__(x##__VA_ARGS__##9)
|
||||
+const char *c n(1 2, 4);
|
||||
+const char *d = o(5 6, 7 8);
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ if (__builtin_strcmp (c, "1 23")
|
||||
+ || __builtin_strcmp (d, "5 67 89"))
|
||||
+ __builtin_abort ();
|
||||
+ return 0;
|
||||
+}
|
||||
--- gcc/testsuite/c-c++-common/Wimplicit-fallthrough-38.c.jj
|
||||
+++ gcc/testsuite/c-c++-common/Wimplicit-fallthrough-38.c
|
||||
@@ -0,0 +1,24 @@
|
||||
+/* { dg-do compile } */
|
||||
+/* { dg-options "-Wimplicit-fallthrough=3" } */
|
||||
+
|
||||
+#define FOO \
|
||||
+int \
|
||||
+foo (int a) \
|
||||
+{ \
|
||||
+ switch (a) \
|
||||
+ { \
|
||||
+ case 1: \
|
||||
+ ++a; \
|
||||
+ /* FALLTHRU */ \
|
||||
+ case 2: \
|
||||
+ ++a; \
|
||||
+ /* FALLTHRU */ \
|
||||
+ ca##se 3: \
|
||||
+ ++a; \
|
||||
+ default: \
|
||||
+ break; \
|
||||
+ } \
|
||||
+ return a; \
|
||||
+}
|
||||
+
|
||||
+FOO
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-11.2.1-20211019.tar.xz) = 08c85e39d028446730372cfbe13a708f240d9a20d89429542fa5c8190a7e9bc13c6734ad068152b4644a7ae561d8c76b9633289e9b20735bbca0d034cf1eea82
|
||||
SHA512 (gcc-11.2.1-20211203.tar.xz) = 3cf64d3af541b9e80a2d5dd95a1257afefda554cfa16b757a7f861701e3da2d6917dbb1f4cd74301ffaf45e92c441642b8c589a10698a9103a216620f0849626
|
||||
SHA512 (isl-0.18.tar.bz2) = 85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94
|
||||
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
||||
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
||||
|
Loading…
Reference in New Issue
Block a user