parent
569a5a7804
commit
640291c6b3
2
gcc.spec
2
gcc.spec
@ -269,7 +269,6 @@ Patch14: gcc11-libgcc-link.patch
|
||||
Patch15: gcc11-pr101786.patch
|
||||
Patch16: gcc11-stringify-__VA_OPT__.patch
|
||||
Patch17: gcc11-pr102642.patch
|
||||
Patch18: gcc11-tsan-sigstksz.patch
|
||||
|
||||
Patch100: gcc11-fortran-fdec-duplicates.patch
|
||||
Patch101: gcc11-fortran-flogical-as-integer.patch
|
||||
@ -796,7 +795,6 @@ to NVidia PTX capable devices if available.
|
||||
%patch15 -p0 -b .pr101786~
|
||||
%patch16 -p0 -b .stringify-__VA_OPT__~
|
||||
%patch17 -p0 -b .pr102642~
|
||||
%patch18 -p1 -b .tsan-sigstksz~
|
||||
|
||||
%if 0%{?rhel} >= 9
|
||||
%patch100 -p1 -b .fortran-fdec-duplicates~
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 91f8a7a34cf29ae7c465603a801326767f1cc7e9 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Liska <mliska@suse.cz>
|
||||
Date: Thu, 5 Aug 2021 10:43:17 +0200
|
||||
Subject: [PATCH] sanitizer: cherry pick
|
||||
414482751452e54710f16bae58458c66298aaf69
|
||||
|
||||
The patch is needed in order to support recent glibc (2.34).
|
||||
|
||||
libsanitizer/ChangeLog:
|
||||
|
||||
PR sanitizer/101749
|
||||
* sanitizer_common/sanitizer_posix_libcdep.cpp: Prevent
|
||||
generation of dependency on _cxa_guard for static
|
||||
initialization.
|
||||
---
|
||||
libsanitizer/sanitizer_common/sanitizer_posix_libcdep.cpp | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/libsanitizer/sanitizer_common/sanitizer_posix_libcdep.cpp b/libsanitizer/sanitizer_common/sanitizer_posix_libcdep.cpp
|
||||
index 7ff48c35851..a65b16f5290 100644
|
||||
--- a/libsanitizer/sanitizer_common/sanitizer_posix_libcdep.cpp
|
||||
+++ b/libsanitizer/sanitizer_common/sanitizer_posix_libcdep.cpp
|
||||
@@ -166,9 +166,10 @@ bool SupportsColoredOutput(fd_t fd) {
|
||||
#if !SANITIZER_GO
|
||||
// TODO(glider): different tools may require different altstack size.
|
||||
static uptr GetAltStackSize() {
|
||||
- // SIGSTKSZ is not enough.
|
||||
- static const uptr kAltStackSize = SIGSTKSZ * 4;
|
||||
- return kAltStackSize;
|
||||
+ // Note: since GLIBC_2.31, SIGSTKSZ may be a function call, so this may be
|
||||
+ // more costly that you think. However GetAltStackSize is only call 2-3 times
|
||||
+ // per thread so don't cache the evaluation.
|
||||
+ return SIGSTKSZ * 4;
|
||||
}
|
||||
|
||||
void SetAlternateSignalStack() {
|
||||
--
|
||||
2.27.0
|
Loading…
Reference in New Issue
Block a user