4.8.0-6
This commit is contained in:
parent
4bcc1e4fe2
commit
5c60aab4d1
1
.gitignore
vendored
1
.gitignore
vendored
@ -72,3 +72,4 @@
|
||||
/gcc-4.8.0-20130419.tar.bz2
|
||||
/gcc-4.8.0-20130507.tar.bz2
|
||||
/gcc-4.8.0-20130510.tar.bz2
|
||||
/gcc-4.8.0-20130517.tar.bz2
|
||||
|
21
gcc.spec
21
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20130510
|
||||
%global SVNREV 198794
|
||||
%global DATE 20130517
|
||||
%global SVNREV 199023
|
||||
%global gcc_version 4.8.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 5
|
||||
%global gcc_release 6
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -193,8 +193,6 @@ Patch9: gcc48-cloog-dl2.patch
|
||||
Patch10: gcc48-pr38757.patch
|
||||
Patch11: gcc48-libstdc++-docs.patch
|
||||
Patch12: gcc48-no-add-needed.patch
|
||||
Patch13: gcc48-rh957778.patch
|
||||
Patch14: gcc48-pr57230.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -748,8 +746,6 @@ package or when debugging this package.
|
||||
%patch11 -p0 -b .libstdc++-docs~
|
||||
%endif
|
||||
%patch12 -p0 -b .no-add-needed~
|
||||
%patch13 -p0 -b .rh957778~
|
||||
%patch14 -p0 -b .pr57230~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -2983,6 +2979,17 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Fri May 17 2013 Jakub Jelinek <jakub@redhat.com> 4.8.0-6
|
||||
- update from the 4.8 branch
|
||||
- PRs c++/56782, c++/56998, c++/57041, c++/57196, c++/57243, c++/57252,
|
||||
c++/57253, c++/57254, c++/57274, c++/57279, middle-end/57251,
|
||||
rtl-optimization/57281, rtl-optimization/57300, target/45359,
|
||||
target/46396, target/57264
|
||||
- backport color diagnostics support from trunk, enable with
|
||||
-fdiagnostics-color=auto, -fdiagnostics-color=always or
|
||||
having non-empty GCC_COLORS variable in environment
|
||||
- backport -fstack-protector-strong support from trunk
|
||||
|
||||
* Fri May 10 2013 Jakub Jelinek <jakub@redhat.com> 4.8.0-5
|
||||
- update from the 4.8 branch
|
||||
- PRs bootstrap/54281, bootstrap/54659, c++/57047, c++/57068, c++/57222,
|
||||
|
@ -1,37 +0,0 @@
|
||||
2013-05-10 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR tree-optimization/57230
|
||||
* tree-ssa-strlen.c (handle_char_store): Add missing integer_zerop
|
||||
check.
|
||||
|
||||
* gcc.dg/strlenopt-23.c: New test.
|
||||
|
||||
--- gcc/tree-ssa-strlen.c.jj 2013-04-26 08:49:53.000000000 +0200
|
||||
+++ gcc/tree-ssa-strlen.c 2013-05-10 08:57:20.654523288 +0200
|
||||
@@ -1703,7 +1703,7 @@ handle_char_store (gimple_stmt_iterator
|
||||
its length may be decreased. */
|
||||
adjust_last_stmt (si, stmt, false);
|
||||
}
|
||||
- else if (si != NULL)
|
||||
+ else if (si != NULL && integer_zerop (gimple_assign_rhs1 (stmt)))
|
||||
{
|
||||
si = unshare_strinfo (si);
|
||||
si->length = build_int_cst (size_type_node, 0);
|
||||
--- gcc/testsuite/gcc.dg/strlenopt-23.c.jj 2013-05-10 09:01:27.808152595 +0200
|
||||
+++ gcc/testsuite/gcc.dg/strlenopt-23.c 2013-05-10 09:02:08.042931124 +0200
|
||||
@@ -0,0 +1,15 @@
|
||||
+/* PR tree-optimization/57230 */
|
||||
+/* { dg-do run } */
|
||||
+/* { dg-options "-O2" } */
|
||||
+
|
||||
+#include "strlenopt.h"
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ char p[] = "hello world";
|
||||
+ p[0] = (char) (strlen (p) - 1);
|
||||
+ if (strlen (p) != 11)
|
||||
+ abort ();
|
||||
+ return 0;
|
||||
+}
|
@ -1,17 +0,0 @@
|
||||
2013-05-06 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* gcc.c (SANITIZER_SPEC): Reject -fsanitize=address -fsanitize=thread
|
||||
linking.
|
||||
|
||||
--- gcc/gcc.c.jj 2013-04-15 16:55:04.000000000 +0200
|
||||
+++ gcc/gcc.c 2013-05-06 17:25:42.306455151 +0200
|
||||
@@ -716,7 +716,8 @@ proper position among the other output f
|
||||
#ifndef SANITIZER_SPEC
|
||||
#define SANITIZER_SPEC "\
|
||||
%{!nostdlib:%{!nodefaultlibs:%{fsanitize=address:" LIBASAN_SPEC "\
|
||||
- %{static:%ecannot specify -static with -fsanitize=address}}\
|
||||
+ %{static:%ecannot specify -static with -fsanitize=address}\
|
||||
+ %{fsanitize=thread:%e-fsanitize=address is incompatible with -fsanitize=thread}}\
|
||||
%{fsanitize=thread:" LIBTSAN_SPEC "\
|
||||
%{!pie:%{!shared:%e-fsanitize=thread linking must be done with -pie or -shared}}}}}"
|
||||
#endif
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
be78a47bd82523250eb3e91646db5b3d cloog-0.18.0.tar.gz
|
||||
2659f09c2e43ef8b7d4406321753f1b2 fastjar-0.97.tar.gz
|
||||
685602a8393f6d34cf63d14827828fbf gcc-4.8.0-20130510.tar.bz2
|
||||
968a4a0990408a441e4fe3fae4dc7c21 gcc-4.8.0-20130517.tar.bz2
|
||||
bce1586384d8635a76d2f017fb067cd2 isl-0.11.1.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user