4.7.0-0.2
This commit is contained in:
parent
de609bb65f
commit
5c29a25740
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/gcc-4.6.1-20110627.tar.bz2
|
||||
/gcc-4.6.1-20110708.tar.bz2
|
||||
/gcc-4.6.1-20110715.tar.bz2
|
||||
/gcc-4.7.0-20120103.tar.bz2
|
||||
|
@ -1,61 +0,0 @@
|
||||
Build i386.rpm libgomp and libsupc++.a(guard.o) as i486+, pre-i486
|
||||
hardware isn't supported because NPTL doesn't support it anyway.
|
||||
|
||||
--- libgomp/configure.tgt.jj 2008-01-10 20:53:48.000000000 +0100
|
||||
+++ libgomp/configure.tgt 2008-03-27 12:44:51.000000000 +0100
|
||||
@@ -44,14 +44,14 @@ if test $enable_linux_futex = yes; then
|
||||
;;
|
||||
|
||||
# Note that bare i386 is not included here. We need cmpxchg.
|
||||
- i[456]86-*-linux*)
|
||||
+ i[3456]86-*-linux*)
|
||||
config_path="linux/x86 linux posix"
|
||||
case " ${CC} ${CFLAGS} " in
|
||||
*" -m64 "*)
|
||||
;;
|
||||
*)
|
||||
if test -z "$with_arch"; then
|
||||
- XCFLAGS="${XCFLAGS} -march=i486 -mtune=${target_cpu}"
|
||||
+ XCFLAGS="${XCFLAGS} -march=i486 -mtune=generic"
|
||||
fi
|
||||
esac
|
||||
;;
|
||||
@@ -63,7 +63,7 @@ if test $enable_linux_futex = yes; then
|
||||
config_path="linux/x86 linux posix"
|
||||
case " ${CC} ${CFLAGS} " in
|
||||
*" -m32 "*)
|
||||
- XCFLAGS="${XCFLAGS} -march=i486 -mtune=i686"
|
||||
+ XCFLAGS="${XCFLAGS} -march=i486 -mtune=generic"
|
||||
;;
|
||||
esac
|
||||
;;
|
||||
--- libstdc++-v3/libsupc++/guard.cc.jj 2008-03-01 00:58:24.000000000 +0100
|
||||
+++ libstdc++-v3/libsupc++/guard.cc 2008-03-27 14:08:44.000000000 +0100
|
||||
@@ -35,6 +35,27 @@
|
||||
#include <new>
|
||||
#include <ext/atomicity.h>
|
||||
#include <ext/concurrence.h>
|
||||
+#if defined __i386__ && !defined _GLIBCXX_ATOMIC_BUILTINS_4
|
||||
+# define _GLIBCXX_ATOMIC_BUILTINS_4 1
|
||||
+# define __sync_val_compare_and_swap(a, b, c) \
|
||||
+ ({ \
|
||||
+ typedef char sltast[sizeof (*a) == sizeof (int) ? 1 : -1]; \
|
||||
+ int sltas; \
|
||||
+ __asm __volatile ("lock; cmpxchgl %3, (%1)" \
|
||||
+ : "=a" (sltas) \
|
||||
+ : "r" (a), "0" (b), "r" (c) : "memory"); \
|
||||
+ sltas; \
|
||||
+ })
|
||||
+# define __sync_lock_test_and_set(a, b) \
|
||||
+ ({ \
|
||||
+ typedef char sltast[sizeof (*a) == sizeof (int) ? 1 : -1]; \
|
||||
+ int sltas; \
|
||||
+ __asm __volatile ("xchgl (%1), %0" \
|
||||
+ : "=r" (sltas) \
|
||||
+ : "r" (a), "0" (b) : "memory"); \
|
||||
+ sltas; \
|
||||
+ })
|
||||
+#endif
|
||||
#if defined(__GTHREADS) && defined(__GTHREAD_HAS_COND) \
|
||||
&& defined(_GLIBCXX_ATOMIC_BUILTINS_4) && defined(_GLIBCXX_HAVE_LINUX_FUTEX)
|
||||
# include <climits>
|
@ -1,36 +0,0 @@
|
||||
--- libstdc++-v3/doc/html/index.html.jj 2011-01-03 12:53:21.282829010 +0100
|
||||
+++ libstdc++-v3/doc/html/index.html 2011-01-04 18:06:28.999851145 +0100
|
||||
@@ -12,7 +12,8 @@
|
||||
<div>
|
||||
<h1>The GNU C++ Library Documentation</h1>
|
||||
|
||||
-<p>Copyright 2008, 2009 FSF</p>
|
||||
+<p>Release 4.6.0</p>
|
||||
+<p>Copyright 2008, 2009, 2010, 2011 FSF</p>
|
||||
|
||||
<p>
|
||||
Permission is granted to copy, distribute and/or modify this
|
||||
--- libstdc++-v3/doc/html/api.html.jj 2011-01-03 12:53:21.000000000 +0100
|
||||
+++ libstdc++-v3/doc/html/api.html 2011-01-04 18:12:01.672757784 +0100
|
||||
@@ -3,7 +3,7 @@
|
||||
<html xmlns="http://www.w3.org/1999/xhtml"><head><title>The GNU C++ Library API Reference</title><meta name="generator" content="DocBook XSL-NS Stylesheets V1.76.1"/><link rel="home" href="spine.html" title="The GNU C++ Library"/><link rel="up" href="bk02.html" title=""/><link rel="prev" href="bk02.html" title=""/><link rel="next" href="bk03.html" title=""/></head><body><div class="navheader"><table width="100%" summary="Navigation header"><tr><th colspan="3" align="center">The GNU C++ Library API Reference</th></tr><tr><td align="left"><a accesskey="p" href="bk02.html">Prev</a> </td><th width="60%" align="center"/><td align="right"> <a accesskey="n" href="bk03.html">Next</a></td></tr></table><hr/></div><div class="article" title="The GNU C++ Library API Reference"><div class="titlepage"><div><div><h2 class="title"><a id="api"/>The GNU C++ Library API Reference</h2></div><div><p class="copyright">Copyright ©
|
||||
2008
|
||||
,
|
||||
- 2010
|
||||
+ 2010, 2011
|
||||
|
||||
<a class="link" href="http://www.fsf.org/">FSF
|
||||
</a>
|
||||
@@ -19,8 +19,11 @@
|
||||
member functions for the library classes, finding out what is in a
|
||||
particular include file, looking at inheritance diagrams, etc.
|
||||
</p><p>
|
||||
- The API documentation, rendered into HTML, can be viewed online:
|
||||
+ The API documentation, rendered into HTML, can be viewed here:
|
||||
</p><div class="itemizedlist"><ul class="itemizedlist"><li class="listitem"><p>
|
||||
+ <a class="ulink" href="api/index.html">for the 4.6 release, local
|
||||
+ </a>
|
||||
+ </p></li><li class="listitem"><p>
|
||||
<a class="link" href="http://gcc.gnu.org/onlinedocs/libstdc++/libstdc++-html-USERS-3.4/index.html">for the 3.4 release
|
||||
</a>
|
||||
</p></li><li class="listitem"><p>
|
@ -1,40 +0,0 @@
|
||||
--- gcc/config.gcc.jj 2008-04-24 15:42:46.000000000 -0500
|
||||
+++ gcc/config.gcc 2008-04-24 15:44:51.000000000 -0500
|
||||
@@ -2530,7 +2530,7 @@ sparc-*-rtems*)
|
||||
tmake_file="sparc/t-elf sparc/t-crtin sparc/t-crtfm t-rtems"
|
||||
extra_parts="crtbegin.o crtend.o"
|
||||
;;
|
||||
-sparc-*-linux*)
|
||||
+sparc-*-linux* | sparcv9-*-linux*)
|
||||
tm_file="${tm_file} dbxelf.h elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h"
|
||||
extra_options="${extra_options} sparc/long-double-switch.opt"
|
||||
case ${target} in
|
||||
@@ -2624,7 +2624,7 @@ sparc64-*-rtems*)
|
||||
tmake_file="${tmake_file} sparc/t-crtin sparc/t-crtfm t-rtems"
|
||||
extra_parts="crtbegin.o crtend.o"
|
||||
;;
|
||||
-sparc64-*-linux*)
|
||||
+sparc64*-*-linux*)
|
||||
tm_file="sparc/biarch64.h ${tm_file} dbxelf.h elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/linux64.h"
|
||||
extra_options="${extra_options} sparc/long-double-switch.opt"
|
||||
tmake_file="${tmake_file} sparc/t-linux sparc/t-linux64 sparc/t-crtfm"
|
||||
--- libgcc/config.host.jj 2008-04-24 15:46:19.000000000 -0500
|
||||
+++ libgcc/config.host 2008-04-24 15:46:49.000000000 -0500
|
||||
@@ -572,7 +572,7 @@ sparc64-*-openbsd*)
|
||||
;;
|
||||
sparc-*-elf*)
|
||||
;;
|
||||
-sparc-*-linux*) # SPARC's running GNU/Linux, libc6
|
||||
+sparc-*-linux* | sparcv9*-*-linux*) # SPARC's running GNU/Linux, libc6
|
||||
extra_parts="$extra_parts crtfastmath.o"
|
||||
tmake_file="${tmake_file} sparc/t-crtfm"
|
||||
;;
|
||||
@@ -590,7 +590,7 @@ sparc-wrs-vxworks)
|
||||
;;
|
||||
sparc64-*-freebsd*|ultrasparc-*-freebsd*)
|
||||
;;
|
||||
-sparc64-*-linux*) # 64-bit SPARC's running GNU/Linux
|
||||
+sparc64*-*-linux*) # 64-bit SPARC's running GNU/Linux
|
||||
extra_parts="$extra_parts crtfastmath.o"
|
||||
tmake_file="${tmake_file} sparc/t-crtfm"
|
||||
;;
|
@ -9,7 +9,7 @@
|
||||
|
||||
--- gcc/cp/decl.c.jj 2007-10-01 22:11:09.000000000 +0200
|
||||
+++ gcc/cp/decl.c 2007-10-02 11:39:46.000000000 +0200
|
||||
@@ -2001,23 +2001,21 @@ duplicate_decls (tree newdecl, tree oldd
|
||||
@@ -2137,39 +2137,37 @@ duplicate_decls (tree newdecl, tree oldd
|
||||
DECL_ARGUMENTS (olddecl) = DECL_ARGUMENTS (newdecl);
|
||||
DECL_RESULT (olddecl) = DECL_RESULT (newdecl);
|
||||
}
|
||||
@ -21,6 +21,22 @@
|
||||
+ /* If we're keeping the built-in definition, keep the rtl,
|
||||
+ regardless of declaration matches. */
|
||||
+ COPY_DECL_RTL (olddecl, newdecl);
|
||||
+ if (DECL_BUILT_IN_CLASS (newdecl) == BUILT_IN_NORMAL)
|
||||
+ {
|
||||
+ enum built_in_function fncode = DECL_FUNCTION_CODE (newdecl);
|
||||
+ switch (fncode)
|
||||
+ {
|
||||
+ /* If a compatible prototype of these builtin functions
|
||||
+ is seen, assume the runtime implements it with the
|
||||
+ expected semantics. */
|
||||
+ case BUILT_IN_STPCPY:
|
||||
+ if (builtin_decl_explicit_p (fncode))
|
||||
+ set_builtin_decl_implicit_p (fncode, true);
|
||||
+ break;
|
||||
+ default:
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
if (new_defines_function)
|
||||
/* If defining a function declared with other language
|
||||
@ -37,6 +53,22 @@
|
||||
- /* If we're keeping the built-in definition, keep the rtl,
|
||||
- regardless of declaration matches. */
|
||||
- COPY_DECL_RTL (olddecl, newdecl);
|
||||
- if (DECL_BUILT_IN_CLASS (newdecl) == BUILT_IN_NORMAL)
|
||||
- {
|
||||
- enum built_in_function fncode = DECL_FUNCTION_CODE (newdecl);
|
||||
- switch (fncode)
|
||||
- {
|
||||
- /* If a compatible prototype of these builtin functions
|
||||
- is seen, assume the runtime implements it with the
|
||||
- expected semantics. */
|
||||
- case BUILT_IN_STPCPY:
|
||||
- if (builtin_decl_explicit_p (fncode))
|
||||
- set_builtin_decl_implicit_p (fncode, true);
|
||||
- break;
|
||||
- default:
|
||||
- break;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
-
|
||||
DECL_RESULT (newdecl) = DECL_RESULT (olddecl);
|
@ -15,7 +15,7 @@
|
||||
|
||||
--- gcc/Makefile.in.jj 2011-01-03 13:44:14.163900902 +0100
|
||||
+++ gcc/Makefile.in 2011-01-04 17:48:53.588775911 +0100
|
||||
@@ -984,6 +984,8 @@ GCC_PLUGIN_H = gcc-plugin.h highlev-plug
|
||||
@@ -962,6 +962,8 @@ GCC_PLUGIN_H = gcc-plugin.h highlev-plug
|
||||
PLUGIN_H = plugin.h $(GCC_PLUGIN_H)
|
||||
PLUGIN_VERSION_H = plugin-version.h configargs.h
|
||||
LIBFUNCS_H = libfuncs.h $(HASHTAB_H)
|
||||
@ -24,16 +24,16 @@
|
||||
|
||||
#
|
||||
# Now figure out from those variables how to compile and link.
|
||||
@@ -1037,7 +1039,7 @@ BUILD_LIBDEPS= $(BUILD_LIBIBERTY)
|
||||
@@ -1016,7 +1018,7 @@ BUILD_LIBDEPS= $(BUILD_LIBIBERTY)
|
||||
# and the system's installed libraries.
|
||||
LIBS = @LIBS@ $(CPPLIB) $(LIBINTL) $(LIBICONV) $(LIBIBERTY) $(LIBDECNUMBER) \
|
||||
$(HOST_LIBS)
|
||||
LIBS = @LIBS@ libcommon.a $(CPPLIB) $(LIBINTL) $(LIBICONV) $(LIBIBERTY) \
|
||||
$(LIBDECNUMBER) $(HOST_LIBS)
|
||||
-BACKENDLIBS = $(CLOOGLIBS) $(PPLLIBS) $(GMPLIBS) $(PLUGINLIBS) $(HOST_LIBS) \
|
||||
+BACKENDLIBS = $(GMPLIBS) $(if $(CLOOGLIBS),-ldl) $(PLUGINLIBS) $(HOST_LIBS) \
|
||||
$(ZLIB)
|
||||
# Any system libraries needed just for GNAT.
|
||||
SYSLIBS = @GNAT_LIBEXC@
|
||||
@@ -2668,40 +2670,40 @@ sese.o : sese.c sese.h $(CONFIG_H) $(SYS
|
||||
@@ -2602,40 +2604,40 @@ sese.o : sese.c sese.h $(CONFIG_H) $(SYS
|
||||
$(TREE_FLOW_H) $(CFGLOOP_H) $(TREE_DATA_REF_H) tree-pass.h value-prof.h
|
||||
graphite.o : graphite.c $(CONFIG_H) $(SYSTEM_H) coretypes.h $(DIAGNOSTIC_CORE_H) \
|
||||
$(TREE_FLOW_H) $(TREE_DUMP_H) $(CFGLOOP_H) $(TREE_DATA_REF_H) sese.h \
|
||||
@ -88,21 +88,25 @@
|
||||
graphite-sese-to-poly.h
|
||||
tree-vect-loop.o: tree-vect-loop.c $(CONFIG_H) $(SYSTEM_H) coretypes.h \
|
||||
$(TM_H) $(GGC_H) $(TREE_H) $(BASIC_BLOCK_H) $(DIAGNOSTIC_H) $(TREE_FLOW_H) \
|
||||
@@ -3482,6 +3484,11 @@ $(out_object_file): $(out_file) $(CONFIG
|
||||
@@ -3454,6 +3456,15 @@ $(common_out_object_file): $(common_out_
|
||||
$(COMPILER) -c $(ALL_COMPILERFLAGS) $(ALL_CPPFLAGS) \
|
||||
$(out_file) $(OUTPUT_OPTION)
|
||||
$< $(OUTPUT_OPTION)
|
||||
|
||||
+graphite%.o : \
|
||||
+ ALL_CFLAGS := -O $(filter-out -fkeep-inline-functions, $(ALL_CFLAGS))
|
||||
+graphite.o : \
|
||||
+ ALL_CFLAGS := -O $(filter-out -fkeep-inline-functions, $(ALL_CFLAGS))
|
||||
+graphite%.o : \
|
||||
+ ALL_CXXFLAGS := -O $(filter-out -fkeep-inline-functions, $(ALL_CXXFLAGS))
|
||||
+graphite.o : \
|
||||
+ ALL_CXXFLAGS := -O $(filter-out -fkeep-inline-functions, $(ALL_CXXFLAGS))
|
||||
+
|
||||
# Build auxiliary files that support ecoff format.
|
||||
mips-tfile: mips-tfile.o version.o $(LIBDEPS)
|
||||
mips-tfile: mips-tfile.o $(LIBDEPS)
|
||||
$(LINKER) $(LINKERFLAGS) $(LDFLAGS) -o $@ \
|
||||
--- gcc/graphite-cloog-compat.h.jj 2011-01-03 12:53:05.000000000 +0100
|
||||
+++ gcc/graphite-cloog-compat.h 2011-01-04 17:34:09.857757544 +0100
|
||||
@@ -272,4 +272,277 @@ static inline int cloog_matrix_nrows (Cl
|
||||
@@ -272,4 +272,279 @@ static inline int cloog_matrix_nrows (Cl
|
||||
return m->NbRows;
|
||||
}
|
||||
#endif /* CLOOG_ORG */
|
||||
@ -220,6 +224,7 @@
|
||||
+ DYNSYM (stmt_guard); \
|
||||
+ DYNSYM (stmt_root); \
|
||||
+ DYNSYM (stmt_user); \
|
||||
+ DYNSYM (stmt_ass); \
|
||||
+ DYNSYM (ppl_delete_Constraint_System); \
|
||||
+ DYNSYM (ppl_initialize); \
|
||||
+ DYNSYM (ppl_new_Constraint_System_from_Constraint); \
|
||||
@ -227,7 +232,7 @@
|
||||
+ DYNSYM (ppl_Polyhedron_affine_image); \
|
||||
+ DYNSYM (ppl_io_fprint_Pointset_Powerset_C_Polyhedron); \
|
||||
+ DYNSYMS_PPL11
|
||||
+extern struct
|
||||
+extern struct cloog_pointers_s__
|
||||
+{
|
||||
+ bool inited;
|
||||
+ void *h;
|
||||
@ -364,6 +369,7 @@
|
||||
+#define stmt_guard (*cloog_pointers__.p_stmt_guard)
|
||||
+#define stmt_root (*cloog_pointers__.p_stmt_root)
|
||||
+#define stmt_user (*cloog_pointers__.p_stmt_user)
|
||||
+#define stmt_ass (*cloog_pointers__.p_stmt_ass)
|
||||
+#define ppl_delete_Constraint_System (*cloog_pointers__.p_ppl_delete_Constraint_System)
|
||||
+#define ppl_initialize (*cloog_pointers__.p_ppl_initialize)
|
||||
+#define ppl_new_Constraint_System_from_Constraint (*cloog_pointers__.p_ppl_new_Constraint_System_from_Constraint)
|
||||
@ -433,19 +439,26 @@
|
||||
initialize_original_copy_tables ();
|
||||
--- gcc/graphite-clast-to-gimple.c.jj 2011-01-03 12:53:05.000000000 +0100
|
||||
+++ gcc/graphite-clast-to-gimple.c 2011-01-04 16:29:55.738007463 +0100
|
||||
@@ -738,10 +738,10 @@ clast_get_body_of_loop (struct clast_stm
|
||||
@@ -836,7 +836,7 @@ clast_get_body_of_loop (struct clast_stm
|
||||
from STMT_FOR. */
|
||||
|
||||
static tree
|
||||
-gcc_type_for_iv_of_clast_loop (struct clast_for *stmt_for, int level,
|
||||
+gcc_type_for_iv_of_clast_loop (struct clast_for *stmt_fora, int level,
|
||||
tree lb_type, tree ub_type)
|
||||
-type_for_clast_for (struct clast_for *stmt_for, ivs_params_p ip)
|
||||
+type_for_clast_for (struct clast_for *stmt_fora, ivs_params_p ip)
|
||||
{
|
||||
- struct clast_stmt *stmt = (struct clast_stmt *) stmt_for;
|
||||
+ struct clast_stmt *stmt = (struct clast_stmt *) stmt_fora;
|
||||
struct clast_user_stmt *body = clast_get_body_of_loop (stmt);
|
||||
CloogStatement *cs = body->statement;
|
||||
poly_bb_p pbb = (poly_bb_p) cloog_statement_usr (cs);
|
||||
mpz_t bound_one, bound_two;
|
||||
tree lb_type, ub_type;
|
||||
@@ -844,8 +844,8 @@ type_for_clast_for (struct clast_for *st
|
||||
mpz_init (bound_one);
|
||||
mpz_init (bound_two);
|
||||
|
||||
- lb_type = type_for_clast_expr (stmt_for->LB, ip, bound_one, bound_two);
|
||||
- ub_type = type_for_clast_expr (stmt_for->UB, ip, bound_one, bound_two);
|
||||
+ lb_type = type_for_clast_expr (stmt_fora->LB, ip, bound_one, bound_two);
|
||||
+ ub_type = type_for_clast_expr (stmt_fora->UB, ip, bound_one, bound_two);
|
||||
|
||||
mpz_clear (bound_one);
|
||||
mpz_clear (bound_two);
|
||||
--- gcc/graphite-poly.h.jj 2011-01-03 12:53:05.000000000 +0100
|
||||
+++ gcc/graphite-poly.h 2011-01-04 17:35:53.308788629 +0100
|
||||
@@ -22,6 +22,8 @@ along with GCC; see the file COPYING3.
|
@ -1,8 +1,8 @@
|
||||
--- libada/Makefile.in.jj 2009-01-14 12:07:35.000000000 +0100
|
||||
+++ libada/Makefile.in 2009-01-15 14:25:33.000000000 +0100
|
||||
@@ -69,18 +69,40 @@ version := $(shell cat $(srcdir)/../gcc/
|
||||
libsubdir := $(libdir)/gcc/$(target_noncanonical)/$(version)$(MULTISUBDIR)
|
||||
@@ -66,18 +66,40 @@ libsubdir := $(libdir)/gcc/$(target_nonc
|
||||
ADA_RTS_DIR=$(GCC_DIR)/ada/rts$(subst /,_,$(MULTISUBDIR))
|
||||
ADA_RTS_SUBDIR=./rts$(subst /,_,$(MULTISUBDIR))
|
||||
|
||||
+DEFAULTMULTIFLAGS :=
|
||||
+ifeq ($(MULTISUBDIR),)
|
||||
@ -33,42 +33,30 @@
|
||||
LIBADA_FLAGS_TO_PASS = \
|
||||
"MAKEOVERRIDES=" \
|
||||
- "LDFLAGS=$(LDFLAGS)" \
|
||||
+ "LDFLAGS=$(strip $(LDFLAGS) $(DEFAULTMULTIFLAGS))" \
|
||||
+ "LDFLAGS=$(LDFLAGS) $(DEFAULTMULTIFLAGS)" \
|
||||
"LN_S=$(LN_S)" \
|
||||
"SHELL=$(SHELL)" \
|
||||
- "GNATLIBFLAGS=$(GNATLIBFLAGS) $(MULTIFLAGS)" \
|
||||
- "GNATLIBCFLAGS=$(GNATLIBCFLAGS) $(MULTIFLAGS)" \
|
||||
- "GNATLIBCFLAGS_FOR_C=$(GNATLIBCFLAGS_FOR_C) $(MULTIFLAGS)" \
|
||||
+ "GNATLIBFLAGS=$(strip $(GNATLIBFLAGS) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS))" \
|
||||
+ "GNATLIBCFLAGS=$(strip $(GNATLIBCFLAGS) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS))" \
|
||||
+ "GNATLIBCFLAGS_FOR_C=$(strip $(GNATLIBCFLAGS_FOR_C) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS))" \
|
||||
"TARGET_LIBGCC2_CFLAGS=$(TARGET_LIBGCC2_CFLAGS)" \
|
||||
+ "GNATLIBFLAGS=$(GNATLIBFLAGS) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS)" \
|
||||
+ "GNATLIBCFLAGS=$(GNATLIBCFLAGS) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS)" \
|
||||
+ "GNATLIBCFLAGS_FOR_C=$(GNATLIBCFLAGS_FOR_C) $(MULTIFLAGS) $(DEFAULTMULTIFLAGS)" \
|
||||
"PICFLAG_FOR_TARGET=$(PICFLAG)" \
|
||||
"THREAD_KIND=$(THREAD_KIND)" \
|
||||
"TRACE=$(TRACE)" \
|
||||
@@ -91,7 +113,7 @@ LIBADA_FLAGS_TO_PASS = \
|
||||
@@ -88,7 +110,7 @@ LIBADA_FLAGS_TO_PASS = \
|
||||
"exeext=.exeext.should.not.be.used " \
|
||||
'CC=the.host.compiler.should.not.be.needed' \
|
||||
"GCC_FOR_TARGET=$(CC)" \
|
||||
- "CFLAGS=$(CFLAGS) $(WARN_CFLAGS)"
|
||||
+ "CFLAGS=$(strip $(CFLAGS) $(DEFAULTMULTIFLAGS) $(WARN_CFLAGS))"
|
||||
- "CFLAGS=$(CFLAGS)"
|
||||
+ "CFLAGS=$(CFLAGS) $(DEFAULTMULTIFLAGS)"
|
||||
|
||||
# Rules to build gnatlib.
|
||||
.PHONY: gnatlib gnatlib-plain gnatlib-sjlj gnatlib-zcx gnatlib-shared oscons
|
||||
.PHONY: gnatlib gnatlib-plain gnatlib-sjlj gnatlib-zcx gnatlib-shared osconstool
|
||||
--- gcc/ada/sem_util.adb (revision 161677)
|
||||
+++ gcc/ada/sem_util.adb (working copy)
|
||||
@@ -2246,7 +2246,11 @@
|
||||
end if;
|
||||
|
||||
elsif Is_Entity_Name (A2) then
|
||||
+
|
||||
+ -- Triggered by -Wall
|
||||
+ pragma Warnings (Off);
|
||||
return Denotes_Same_Prefix (A2, A1);
|
||||
+ pragma Warnings (On);
|
||||
|
||||
elsif Nkind_In (A1, N_Selected_Component, N_Indexed_Component, N_Slice)
|
||||
and then
|
||||
@@ -4694,7 +4698,7 @@
|
||||
@@ -5487,7 +5487,7 @@ package body Sem_Util is
|
||||
Exp : Node_Id;
|
||||
Assn : Node_Id;
|
||||
Choice : Node_Id;
|
28
gcc47-i386-libgomp.patch
Normal file
28
gcc47-i386-libgomp.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- libgomp/configure.tgt.jj 2008-01-10 20:53:48.000000000 +0100
|
||||
+++ libgomp/configure.tgt 2008-03-27 12:44:51.000000000 +0100
|
||||
@@ -44,14 +44,14 @@ if test $enable_linux_futex = yes; then
|
||||
;;
|
||||
|
||||
# Note that bare i386 is not included here. We need cmpxchg.
|
||||
- i[456]86-*-linux*)
|
||||
+ i[456]86-*-linux*)
|
||||
config_path="linux/x86 linux posix"
|
||||
case " ${CC} ${CFLAGS} " in
|
||||
*" -m64 "*)
|
||||
;;
|
||||
*)
|
||||
if test -z "$with_arch"; then
|
||||
- XCFLAGS="${XCFLAGS} -march=i486 -mtune=${target_cpu}"
|
||||
+ XCFLAGS="${XCFLAGS} -march=i486 -mtune=generic"
|
||||
fi
|
||||
esac
|
||||
;;
|
||||
@@ -63,7 +63,7 @@ if test $enable_linux_futex = yes; then
|
||||
config_path="linux/x86 linux posix"
|
||||
case " ${CC} ${CFLAGS} " in
|
||||
*" -m32 "*)
|
||||
- XCFLAGS="${XCFLAGS} -march=i486 -mtune=i686"
|
||||
+ XCFLAGS="${XCFLAGS} -march=i486 -mtune=generic"
|
||||
;;
|
||||
esac
|
||||
;;
|
26
gcc47-libitm-fno-exceptions.patch
Normal file
26
gcc47-libitm-fno-exceptions.patch
Normal file
@ -0,0 +1,26 @@
|
||||
2011-12-22 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* Makefile.am (beginend.lo): Append -fno-exceptions to
|
||||
CXXFLAGS.
|
||||
* Makefile.in: Regenerated.
|
||||
|
||||
--- libitm/Makefile.am.jj 2011-12-20 13:47:57.000000000 +0100
|
||||
+++ libitm/Makefile.am 2011-12-22 09:14:06.663469165 +0100
|
||||
@@ -72,6 +72,7 @@ endif
|
||||
if ARCH_X86_AVX
|
||||
x86_avx.lo : XCFLAGS += -mavx
|
||||
endif
|
||||
+beginend.lo : CXXFLAGS += -fno-exceptions
|
||||
|
||||
if ARCH_FUTEX
|
||||
libitm_la_SOURCES += futex.cc
|
||||
--- libitm/Makefile.in.jj 2011-12-20 13:47:57.000000000 +0100
|
||||
+++ libitm/Makefile.in 2011-12-22 09:14:29.466329944 +0100
|
||||
@@ -1278,6 +1278,7 @@ vpath % $(strip $(search_path))
|
||||
@LIBITM_BUILD_VERSIONED_SHLIB_SUN_TRUE@@LIBITM_BUILD_VERSIONED_SHLIB_TRUE@ > $@ || (rm -f $@ ; exit 1)
|
||||
@ARCH_X86_TRUE@x86_sse.lo : XCFLAGS += -msse
|
||||
@ARCH_X86_AVX_TRUE@x86_avx.lo : XCFLAGS += -mavx
|
||||
+beginend.lo : CXXFLAGS += -fno-exceptions
|
||||
|
||||
all-local: $(STAMP_GENINSRC)
|
||||
|
26
gcc47-libstdc++-docs.patch
Normal file
26
gcc47-libstdc++-docs.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- libstdc++-v3/doc/html/index.html.jj 2011-01-03 12:53:21.282829010 +0100
|
||||
+++ libstdc++-v3/doc/html/index.html 2011-01-04 18:06:28.999851145 +0100
|
||||
@@ -5,6 +5,8 @@
|
||||
<a class="link" href="http://www.fsf.org/">FSF
|
||||
</a>
|
||||
</p><p>
|
||||
+ Release 4.7.0
|
||||
+ </p><p>
|
||||
Permission is granted to copy, distribute and/or modify this
|
||||
document under the terms of the GNU Free Documentation
|
||||
License, Version 1.2 or any later version published by the
|
||||
--- libstdc++-v3/doc/html/api.html.jj 2011-01-03 12:53:21.000000000 +0100
|
||||
+++ libstdc++-v3/doc/html/api.html 2011-01-04 18:12:01.672757784 +0100
|
||||
@@ -19,8 +19,11 @@
|
||||
member functions for the library classes, finding out what is in a
|
||||
particular include file, looking at inheritance diagrams, etc.
|
||||
</p><p>
|
||||
- The API documentation, rendered into HTML, can be viewed online:
|
||||
+ The API documentation, rendered into HTML, can be viewed here:
|
||||
</p><div class="itemizedlist"><ul class="itemizedlist"><li class="listitem"><p>
|
||||
+ <a class="ulink" href="api/index.html">for the 4.7 release, local
|
||||
+ </a>
|
||||
+ </p></li><li class="listitem"><p>
|
||||
<a class="link" href="http://gcc.gnu.org/onlinedocs/libstdc++/libstdc++-html-USERS-3.4/index.html">for the 3.4 release
|
||||
</a>
|
||||
</p></li><li class="listitem"><p>
|
@ -19,15 +19,15 @@
|
||||
/* A C statement (sans semicolon) to output to the stdio stream STREAM
|
||||
--- gcc/config/ia64/linux.h.jj 2011-01-03 13:02:11.462994522 +0100
|
||||
+++ gcc/config/ia64/linux.h 2011-01-04 18:14:10.931874160 +0100
|
||||
@@ -82,7 +82,7 @@ do { \
|
||||
@@ -77,7 +77,7 @@ do { \
|
||||
Signalize that because we have fde-glibc, we don't need all C shared libs
|
||||
linked against -lgcc_s. */
|
||||
#undef LINK_EH_SPEC
|
||||
-#define LINK_EH_SPEC ""
|
||||
+#define LINK_EH_SPEC "--no-add-needed "
|
||||
|
||||
#define MD_UNWIND_SUPPORT "config/ia64/linux-unwind.h"
|
||||
|
||||
/* Put all *tf routines in libgcc. */
|
||||
#undef LIBGCC2_HAS_TF_MODE
|
||||
--- gcc/config/gnu-user.h.jj 2011-01-03 12:53:03.739057299 +0100
|
||||
+++ gcc/config/gnu-user.h 2011-01-04 18:14:10.932814884 +0100
|
||||
@@ -82,7 +82,7 @@ see the files COPYING3 and COPYING.RUNTI
|
||||
@ -41,8 +41,8 @@
|
||||
#undef LINK_GCC_C_SEQUENCE_SPEC
|
||||
--- gcc/config/rs6000/sysv4.h.jj 2011-01-03 13:02:18.255994215 +0100
|
||||
+++ gcc/config/rs6000/sysv4.h 2011-01-04 18:14:10.933888871 +0100
|
||||
@@ -869,7 +869,7 @@ extern int fixuplabelno;
|
||||
-dynamic-linker " LINUX_DYNAMIC_LINKER "}}"
|
||||
@@ -820,7 +820,7 @@ extern int fixuplabelno;
|
||||
-dynamic-linker " GNU_USER_DYNAMIC_LINKER "}}"
|
||||
|
||||
#if defined(HAVE_LD_EH_FRAME_HDR)
|
||||
-# define LINK_EH_SPEC "%{!static:--eh-frame-hdr} "
|
@ -12,19 +12,19 @@
|
||||
|
||||
--- gcc/tree-inline.c.jj 2007-11-06 09:29:04.000000000 +0100
|
||||
+++ gcc/tree-inline.c 2007-11-06 16:19:12.000000000 +0100
|
||||
@@ -3157,6 +3157,12 @@ expand_call_inline (basic_block bb, gimp
|
||||
@@ -3817,6 +3817,12 @@ expand_call_inline (basic_block bb, gimp
|
||||
goto egress;
|
||||
|
||||
if (lookup_attribute ("always_inline", DECL_ATTRIBUTES (fn))
|
||||
+ /* For extern inline functions that get redefined we always
|
||||
+ silently ignored alway_inline flag. Better behaviour would
|
||||
+ be to be able to keep both bodies and use extern inline body
|
||||
+ for inlining, but we can't do that because frontends overwrite
|
||||
+ the body. */
|
||||
+ /* For extern inline functions that get redefined we always
|
||||
+ silently ignored always_inline flag. Better behaviour would
|
||||
+ be to be able to keep both bodies and use extern inline body
|
||||
+ for inlining, but we can't do that because frontends overwrite
|
||||
+ the body. */
|
||||
+ && !cg_edge->callee->local.redefined_extern_inline
|
||||
/* Avoid warnings during early inline pass. */
|
||||
&& cgraph_global_info_ready)
|
||||
{
|
||||
&& cgraph_global_info_ready
|
||||
/* PR 20090218-1_0.c. Body can be provided by another module. */
|
||||
--- gcc/testsuite/gcc.dg/pr33763.c.jj 2007-11-06 16:19:12.000000000 +0100
|
||||
+++ gcc/testsuite/gcc.dg/pr33763.c 2007-11-06 16:19:12.000000000 +0100
|
||||
@@ -0,0 +1,60 @@
|
@ -46,7 +46,7 @@
|
||||
#endif /* GCC_LANG_HOOKS_DEF_H */
|
||||
--- gcc/c-lang.c.jj 2011-01-03 12:53:05.376056936 +0100
|
||||
+++ gcc/c-lang.c 2011-01-04 17:59:43.167743798 +0100
|
||||
@@ -36,6 +36,12 @@ along with GCC; see the file COPYING3.
|
||||
@@ -36,6 +36,12 @@ along with GCC; see the file COPYING3.
|
||||
|
||||
enum c_language_kind c_language = clk_c;
|
||||
|
||||
@ -59,10 +59,10 @@
|
||||
/* Lang hooks common to C and ObjC are declared in c-objc-common.h;
|
||||
consequently, there should be very few hooks below. */
|
||||
|
||||
@@ -43,6 +49,8 @@ enum c_language_kind c_language = clk_c;
|
||||
#define LANG_HOOKS_NAME "GNU C"
|
||||
#undef LANG_HOOKS_INIT
|
||||
@@ -45,6 +51,8 @@ enum c_language_kind c_language = clk_c;
|
||||
#define LANG_HOOKS_INIT c_objc_common_init
|
||||
#undef LANG_HOOKS_INIT_TS
|
||||
#define LANG_HOOKS_INIT_TS c_common_init_ts
|
||||
+#undef LANG_HOOKS_SOURCE_LANGUAGE
|
||||
+#define LANG_HOOKS_SOURCE_LANGUAGE c_source_language
|
||||
|
||||
@ -83,7 +83,7 @@
|
||||
+ case DW_LANG_C89:
|
||||
+ case DW_LANG_C99:
|
||||
+ case DW_LANG_ObjC:
|
||||
+ if (prototype_p (func_type) != NULL)
|
||||
+ if (prototype_p (func_type))
|
||||
+ add_AT_flag (die, DW_AT_prototyped, 1);
|
||||
+ break;
|
||||
+ default:
|
40
gcc47-sparc-config-detection.patch
Normal file
40
gcc47-sparc-config-detection.patch
Normal file
@ -0,0 +1,40 @@
|
||||
--- gcc/config.gcc.jj 2008-04-24 15:42:46.000000000 -0500
|
||||
+++ gcc/config.gcc 2008-04-24 15:44:51.000000000 -0500
|
||||
@@ -2356,7 +2356,7 @@ sparc-*-rtems*)
|
||||
tm_file="${tm_file} dbxelf.h elfos.h sparc/sysv4.h sparc/sp-elf.h sparc/rtemself.h rtems.h newlib-stdint.h"
|
||||
tmake_file="sparc/t-sparc sparc/t-elf t-rtems"
|
||||
;;
|
||||
-sparc-*-linux*)
|
||||
+sparc-*-linux* | sparcv9-*-linux*)
|
||||
tm_file="${tm_file} dbxelf.h elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/tso.h"
|
||||
extra_options="${extra_options} sparc/long-double-switch.opt"
|
||||
case ${target} in
|
||||
@@ -2409,7 +2409,7 @@ sparc64-*-rtems*)
|
||||
extra_options="${extra_options}"
|
||||
tmake_file="${tmake_file} sparc/t-sparc t-rtems"
|
||||
;;
|
||||
-sparc64-*-linux*)
|
||||
+sparc64*-*-linux*)
|
||||
tm_file="sparc/biarch64.h ${tm_file} dbxelf.h elfos.h sparc/sysv4.h gnu-user.h linux.h glibc-stdint.h sparc/default-64.h sparc/linux64.h sparc/tso.h"
|
||||
extra_options="${extra_options} sparc/long-double-switch.opt"
|
||||
tmake_file="${tmake_file} sparc/t-sparc sparc/t-linux64"
|
||||
--- libgcc/config.host.jj 2008-04-24 15:46:19.000000000 -0500
|
||||
+++ libgcc/config.host 2008-04-24 15:46:49.000000000 -0500
|
||||
@@ -1002,7 +1002,7 @@ sparc-*-elf*)
|
||||
tmake_file="${tmake_file} t-fdpbit t-crtfm"
|
||||
extra_parts="$extra_parts crti.o crtn.o crtfastmath.o"
|
||||
;;
|
||||
-sparc-*-linux*) # SPARC's running GNU/Linux, libc6
|
||||
+sparc-*-linux* | sparcv9-*-linux*) # SPARC's running GNU/Linux, libc6
|
||||
tmake_file="${tmake_file} t-crtfm"
|
||||
if test "${host_address}" = 64; then
|
||||
tmake_file="$tmake_file sparc/t-linux64"
|
||||
@@ -1050,7 +1050,7 @@ sparc64-*-freebsd*|ultrasparc-*-freebsd*
|
||||
tmake_file="$tmake_file t-crtfm"
|
||||
extra_parts="$extra_parts crtfastmath.o"
|
||||
;;
|
||||
-sparc64-*-linux*) # 64-bit SPARC's running GNU/Linux
|
||||
+sparc64*-*-linux*) # 64-bit SPARC's running GNU/Linux
|
||||
extra_parts="$extra_parts crtfastmath.o"
|
||||
tmake_file="${tmake_file} t-crtfm sparc/t-linux"
|
||||
if test "${host_address}" = 64; then
|
Loading…
Reference in New Issue
Block a user