4.8.0-0.6
This commit is contained in:
parent
6980affb9b
commit
5b97d78690
1
.gitignore
vendored
1
.gitignore
vendored
@ -54,3 +54,4 @@
|
||||
/cloog-0.18.0.tar.gz
|
||||
/isl-0.11.1.tar.bz2
|
||||
/gcc-4.8.0-20130122.tar.bz2
|
||||
/gcc-4.8.0-20130124.tar.bz2
|
||||
|
21
gcc.spec
21
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20130122
|
||||
%global SVNREV 195359
|
||||
%global DATE 20130124
|
||||
%global SVNREV 195418
|
||||
%global gcc_version 4.8.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.5
|
||||
%global gcc_release 0.6
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -105,7 +105,8 @@ BuildRequires: binutils >= 2.20.51.0.2-12
|
||||
# While gcc doesn't include statically linked binaries, during testing
|
||||
# -static is used several times.
|
||||
BuildRequires: glibc-static
|
||||
BuildRequires: zlib-devel, gettext, dejagnu, bison, flex, texinfo, sharutils
|
||||
BuildRequires: zlib-devel, gettext, dejagnu, bison, flex, sharutils
|
||||
BuildRequires: texinfo, texinfo-tex
|
||||
BuildRequires: systemtap-sdt-devel >= 1.3
|
||||
%if %{build_go}
|
||||
BuildRequires: hostname
|
||||
@ -143,7 +144,7 @@ BuildRequires: libunwind >= 0.98
|
||||
%endif
|
||||
%if %{build_libstdcxx_docs}
|
||||
BuildRequires: doxygen >= 1.7.1
|
||||
BuildRequires: graphviz
|
||||
BuildRequires: graphviz, dblatex, texlive-collection-latex, docbook5-style-xsl
|
||||
%endif
|
||||
Requires: cpp = %{version}-%{release}
|
||||
# Need .eh_frame ld optimizations
|
||||
@ -198,7 +199,6 @@ Patch11: gcc48-libstdc++-docs.patch
|
||||
Patch12: gcc48-no-add-needed.patch
|
||||
Patch13: gcc48-pr55608.patch
|
||||
Patch14: gcc48-pr55742.patch
|
||||
Patch15: gcc48-pr56052.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -752,7 +752,6 @@ package or when debugging this package.
|
||||
%patch12 -p0 -b .no-add-needed~
|
||||
%patch13 -p0 -b .pr55608~
|
||||
%patch14 -p0 -E -b .pr55742~
|
||||
%patch15 -p0 -b .pr56052~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -2976,6 +2975,14 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Thu Jan 24 2013 Jakub Jelinek <jakub@redhat.com> 4.8.0-0.6
|
||||
- updated from trunk
|
||||
- PRs c++/53609, c++/55944, c++/56067, c++/56071, fortran/56081,
|
||||
libgomp/51376, libgomp/56073, libquadmath/56072, middle-end/56074,
|
||||
sanitizer/55989, target/49069, target/54222, target/55686,
|
||||
target/56028
|
||||
- update TeX related BuildRequires (#891460)
|
||||
|
||||
* Tue Jan 22 2013 Jakub Jelinek <jakub@redhat.com> 4.8.0-0.5
|
||||
- updated from trunk
|
||||
- PRs c++/56059, fortran/55919, rtl-optimization/56023,
|
||||
|
@ -1,53 +0,0 @@
|
||||
2013-01-21 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR fortran/56052
|
||||
* trans-decl.c (gfc_get_symbol_decl): Set DECL_ARTIFICIAL
|
||||
and DECL_IGNORED_P on select_type_temporary and don't set
|
||||
DECL_BY_REFERENCE.
|
||||
|
||||
* gfortran.dg/gomp/pr56052.f90: New test.
|
||||
|
||||
--- gcc/fortran/trans-decl.c.jj 2013-01-11 09:02:50.000000000 +0100
|
||||
+++ gcc/fortran/trans-decl.c 2013-01-21 18:11:39.684529593 +0100
|
||||
@@ -1397,6 +1397,12 @@ gfc_get_symbol_decl (gfc_symbol * sym)
|
||||
DECL_IGNORED_P (decl) = 1;
|
||||
}
|
||||
|
||||
+ if (sym->attr.select_type_temporary)
|
||||
+ {
|
||||
+ DECL_ARTIFICIAL (decl) = 1;
|
||||
+ DECL_IGNORED_P (decl) = 1;
|
||||
+ }
|
||||
+
|
||||
if (sym->attr.dimension || sym->attr.codimension)
|
||||
{
|
||||
/* Create variables to hold the non-constant bits of array info. */
|
||||
@@ -1496,7 +1502,8 @@ gfc_get_symbol_decl (gfc_symbol * sym)
|
||||
&& POINTER_TYPE_P (TREE_TYPE (decl))
|
||||
&& !sym->attr.pointer
|
||||
&& !sym->attr.allocatable
|
||||
- && !sym->attr.proc_pointer)
|
||||
+ && !sym->attr.proc_pointer
|
||||
+ && !sym->attr.select_type_temporary)
|
||||
DECL_BY_REFERENCE (decl) = 1;
|
||||
|
||||
if (sym->attr.vtab
|
||||
--- gcc/testsuite/gfortran.dg/gomp/pr56052.f90.jj 2013-01-21 18:14:38.716547446 +0100
|
||||
+++ gcc/testsuite/gfortran.dg/gomp/pr56052.f90 2013-01-21 18:14:59.425432249 +0100
|
||||
@@ -0,0 +1,16 @@
|
||||
+! PR fortran/56052
|
||||
+! { dg-do compile }
|
||||
+! { dg-options "-fopenmp" }
|
||||
+
|
||||
+subroutine middle(args)
|
||||
+ type args_t
|
||||
+ end type
|
||||
+ type, extends(args_t) :: scan_args_t
|
||||
+ end type
|
||||
+ class(args_t),intent(inout) :: args
|
||||
+ !$omp single
|
||||
+ select type (args)
|
||||
+ type is (scan_args_t)
|
||||
+ end select
|
||||
+ !$omp end single
|
||||
+end subroutine middle
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
be78a47bd82523250eb3e91646db5b3d cloog-0.18.0.tar.gz
|
||||
2659f09c2e43ef8b7d4406321753f1b2 fastjar-0.97.tar.gz
|
||||
bce1586384d8635a76d2f017fb067cd2 isl-0.11.1.tar.bz2
|
||||
a0898ee557790b350f33fd6e0f5f9b37 gcc-4.8.0-20130122.tar.bz2
|
||||
f9c6f66a32475e32ec02bf2505fa895f gcc-4.8.0-20130124.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user