4.7.0-2
This commit is contained in:
parent
76070518ae
commit
58da100211
1
.gitignore
vendored
1
.gitignore
vendored
@ -27,3 +27,4 @@
|
||||
/gcc-4.7.0-20120308.tar.bz2
|
||||
/gcc-4.7.0-20120315.tar.bz2
|
||||
/gcc-4.7.0-20120322.tar.bz2
|
||||
/gcc-4.7.0-20120416.tar.bz2
|
||||
|
32
gcc.spec
32
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20120322
|
||||
%global SVNREV 185684
|
||||
%global DATE 20120416
|
||||
%global SVNREV 186487
|
||||
%global gcc_version 4.7.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 1
|
||||
%global gcc_release 2
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -174,7 +174,6 @@ Patch12: gcc47-libstdc++-docs.patch
|
||||
Patch13: gcc47-no-add-needed.patch
|
||||
Patch14: gcc47-ppl-0.10.patch
|
||||
Patch15: gcc47-libitm-fno-exceptions.patch
|
||||
Patch16: gcc47-pr52582.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -676,7 +675,6 @@ package or when debugging this package.
|
||||
%patch14 -p0 -b .ppl-0.10~
|
||||
%endif
|
||||
%patch15 -p0 -b .libitm-fno-exceptions~
|
||||
%patch16 -p0 -b .pr52582~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -2643,6 +2641,30 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Mon Apr 16 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-2
|
||||
- update from the 4.7 branch
|
||||
- PRs c++/52292, c++/52380, c++/52465, c++/52487, c++/52596, c++/52671,
|
||||
c++/52672, c++/52685, c++/52718, c++/52743, c++/52746, c++/52759,
|
||||
c++/52796, c++/52824, c++/52906, c/52682, c/52862, fortran/52452,
|
||||
fortran/52668, fortran/52893, libgfortran/52758, libitm/52854,
|
||||
libstdc++/52433, libstdc++/52476, libstdc++/52540, libstdc++/52591,
|
||||
libstdc++/52699, libstdc++/52799, libstdc++/52822, libstdc++/52924,
|
||||
libstdc++/52942, middle-end/51893, middle-end/52493,
|
||||
middle-end/52547, middle-end/52580, middle-end/52640,
|
||||
middle-end/52691, middle-end/52693, middle-end/52720,
|
||||
middle-end/52750, middle-end/52894, other/52545,
|
||||
rtl-optimization/52543, target/48596, target/48806, target/50310,
|
||||
target/52461, target/52484, target/52488, target/52496, target/52499,
|
||||
target/52505, target/52506, target/52507, target/52508, target/52610,
|
||||
target/52692, target/52698, target/52717, target/52736, target/52737,
|
||||
target/52775, tree-optimization/52406, tree-optimization/52678,
|
||||
tree-optimization/52701, tree-optimization/52754,
|
||||
tree-optimization/52835, tree-optimization/52943,
|
||||
tree-optimization/52969
|
||||
- avoid duplicate pointers in C++ debug info due to injected class name
|
||||
(PR debug/45088)
|
||||
- libjava locale fixes (#712013)
|
||||
|
||||
* Thu Mar 22 2012 Jakub Jelinek <jakub@redhat.com> 4.7.0-1
|
||||
- update from the 4.7 branch
|
||||
- GCC 25th Anniversary 4.7.0 release
|
||||
|
@ -1,15 +0,0 @@
|
||||
2012-03-14 Jason Merrill <jason@redhat.com>
|
||||
|
||||
PR c++/52582
|
||||
* method.c (implicitly_declare_fn): Set DECL_EXTERNAL.
|
||||
|
||||
--- gcc/cp/method.c
|
||||
+++ gcc/cp/method.c
|
||||
@@ -1593,6 +1593,7 @@ implicitly_declare_fn (special_function_kind kind, tree type, bool const_p)
|
||||
DECL_DELETED_FN (fn) = deleted_p;
|
||||
DECL_DECLARED_CONSTEXPR_P (fn) = constexpr_p;
|
||||
}
|
||||
+ DECL_EXTERNAL (fn) = true;
|
||||
DECL_NOT_REALLY_EXTERN (fn) = 1;
|
||||
DECL_DECLARED_INLINE_P (fn) = 1;
|
||||
gcc_assert (!TREE_USED (fn));
|
Loading…
Reference in New Issue
Block a user