Fix nvptx-none build.
This commit is contained in:
parent
04dfce99db
commit
57a884df51
2
gcc.spec
2
gcc.spec
@ -256,6 +256,7 @@ Patch8: gcc10-foffload-default.patch
|
||||
Patch9: gcc10-Wno-format-security.patch
|
||||
Patch10: gcc10-rh1574936.patch
|
||||
Patch11: gcc10-d-shared-libphobos.patch
|
||||
Patch12: gcc10-coroutines.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -767,6 +768,7 @@ to NVidia PTX capable devices if available.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .coroutines~
|
||||
|
||||
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
||||
|
||||
|
16
gcc10-coroutines.patch
Normal file
16
gcc10-coroutines.patch
Normal file
@ -0,0 +1,16 @@
|
||||
2020-01-18 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* coroutines.cc (get_fn_local_identifier): Fix NO_DOT_IN_LABEL
|
||||
but non-NO_DOLLAR_IN_LABEL case build.
|
||||
|
||||
--- gcc/cp/coroutines.cc.jj 2020-01-18 13:47:09.318360691 +0100
|
||||
+++ gcc/cp/coroutines.cc 2020-01-18 19:05:48.349119608 +0100
|
||||
@@ -2252,7 +2252,7 @@ get_fn_local_identifier (tree orig, cons
|
||||
sep = ".";
|
||||
#else
|
||||
#ifndef NO_DOLLAR_IN_LABEL
|
||||
- sep = "$"
|
||||
+ sep = "$";
|
||||
#else
|
||||
sep = "_";
|
||||
pfx = "__";
|
Loading…
Reference in New Issue
Block a user