Disable annobin for now. Adjust sanitizer_linux.cc patch.
This commit is contained in:
parent
2cf19e11cb
commit
544398b502
10
gcc.spec
10
gcc.spec
@ -11,6 +11,10 @@
|
||||
%global _performance_build 1
|
||||
# Hardening slows the compiler way too much.
|
||||
%undefine _hardened_build
|
||||
%if 0%{?fedora} > 27
|
||||
# Until annobin is fixed (#1519165).
|
||||
%undefine _annotated_build
|
||||
%endif
|
||||
%global multilib_64_archs sparc64 ppc64 ppc64p7 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc %{power64} alpha s390x %{arm} aarch64
|
||||
%global build_ada 1
|
||||
@ -237,6 +241,7 @@ Patch13: gcc7-pr81325.patch
|
||||
Patch14: gcc7-pr82112-1.patch
|
||||
Patch15: gcc7-pr82112-2.patch
|
||||
Patch16: gcc7-pr81929.patch
|
||||
Patch17: gcc7-aarch64-sanitizer-fix.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -259,7 +264,6 @@ Patch2014: gcc7-rh1512529-14.patch
|
||||
Patch2015: gcc7-rh1512529-15.patch
|
||||
Patch2016: gcc7-rh1512529-16.patch
|
||||
Patch2017: gcc7-rh1512529-17.patch
|
||||
Patch2018: gcc7-rh1512529-18.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -850,6 +854,9 @@ package or when debugging this package.
|
||||
%patch14 -p0 -b .pr82112-1~
|
||||
%patch15 -p0 -b .pr82112-2~
|
||||
%patch16 -p0 -b .pr81929~
|
||||
%if 0%{?fedora} > 27
|
||||
%patch17 -p0 -b .aarch64-sanitizer-fix~
|
||||
%endif
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
@ -874,7 +881,6 @@ cd ..
|
||||
%patch2015 -p1
|
||||
%patch2016 -p1
|
||||
%patch2017 -p1
|
||||
%patch2018 -p1
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
mkdir dwz-wrapper
|
||||
|
@ -1,7 +1,5 @@
|
||||
diff --git a/libsanitizer/sanitizer_common/sanitizer_linux.cc b/libsanitizer/sanitizer_common/sanitizer_linux.cc
|
||||
index 5b6f18602e7..b5e96a1a0e4 100644
|
||||
--- a/libsanitizer/sanitizer_common/sanitizer_linux.cc
|
||||
+++ b/libsanitizer/sanitizer_common/sanitizer_linux.cc
|
||||
--- libsanitizer/sanitizer_common/sanitizer_linux.cc
|
||||
+++ libsanitizer/sanitizer_common/sanitizer_linux.cc
|
||||
@@ -1262,7 +1262,7 @@ struct __sanitizer_esr_context {
|
||||
|
||||
static bool Aarch64GetESR(ucontext_t *ucontext, u64 *esr) {
|
Loading…
Reference in New Issue
Block a user