13.0.1-0.14
This commit is contained in:
parent
52fa8aefa3
commit
52a79c17ee
1
.gitignore
vendored
1
.gitignore
vendored
@ -100,3 +100,4 @@
|
||||
/gcc-13.0.1-20230329.tar.xz
|
||||
/gcc-13.0.1-20230401.tar.xz
|
||||
/gcc-13.0.1-20230404.tar.xz
|
||||
/gcc-13.0.1-20230418.tar.xz
|
||||
|
31
gcc.spec
31
gcc.spec
@ -1,5 +1,5 @@
|
||||
%global DATE 20230404
|
||||
%global gitrev f9101c02b26988d799233db0b778732f7e56259f
|
||||
%global DATE 20230418
|
||||
%global gitrev 90e2966fefb872b610765ac4f89ad9bcab43d72c
|
||||
%global gcc_version 13.0.1
|
||||
%global gcc_major 13
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
@ -136,7 +136,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.13%{?dist}
|
||||
Release: %{gcc_release}.14%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -286,6 +286,7 @@ Patch8: gcc13-no-add-needed.patch
|
||||
Patch9: gcc13-Wno-format-security.patch
|
||||
Patch10: gcc13-rh1574936.patch
|
||||
Patch11: gcc13-d-shared-libphobos.patch
|
||||
Patch12: gcc13-pr108969.patch
|
||||
|
||||
Patch50: isl-rh2155127.patch
|
||||
|
||||
@ -862,6 +863,7 @@ so that there cannot be any synchronization problems.
|
||||
%patch -P10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch -P11 -p0 -b .d-shared-libphobos~
|
||||
%patch -P12 -p0 -b .pr108969~
|
||||
|
||||
%patch -P50 -p0 -b .rh2155127~
|
||||
touch -r isl-0.24/m4/ax_prog_cxx_for_build.m4 isl-0.24/m4/ax_prog_cc_for_build.m4
|
||||
@ -3458,6 +3460,29 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Apr 18 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.14
|
||||
- update from trunk and releases/gcc-13 branch
|
||||
- PRs analyzer/108722, bootstrap/109510, c++/109277, c++/109357, c++/109420,
|
||||
c++/109514, c++/109531, driver/108241, fortran/61615, fortran/85686,
|
||||
fortran/87477, fortran/88247, fortran/91941, fortran/92779,
|
||||
fortran/93339, fortran/93813, fortran/98408, fortran/99982,
|
||||
fortran/100948, fortran/102106, fortran/104272, fortran/104312,
|
||||
fortran/104349, fortran/105205, fortran/106918, fortran/109492,
|
||||
fortran/109511, ipa/107769, ipa/108959, ipa/109318, libstdc++/108291,
|
||||
libstdc++/108827, libstdc++/108969, libstdc++/109482,
|
||||
libstdc++/109525, modula2/109423, modula2/109488, modula2/109496,
|
||||
modula2/109497, target/54816, target/70243, target/99708,
|
||||
target/104989, target/108812, target/108892, target/108947,
|
||||
target/109040, target/109104, target/109374, target/109402,
|
||||
target/109458, target/109479, target/109508, testsuite/108809,
|
||||
testsuite/108815, tree-optimization/108139, tree-optimization/109392,
|
||||
tree-optimization/109410, tree-optimization/109417,
|
||||
tree-optimization/109427, tree-optimization/109434,
|
||||
tree-optimization/109462, tree-optimization/109469,
|
||||
tree-optimization/109473, tree-optimization/109491,
|
||||
tree-optimization/109502, tree-optimization/109524,
|
||||
tree-optimization/109539
|
||||
|
||||
* Tue Apr 4 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.13
|
||||
- update from trunk
|
||||
- PRs c++/53164, c++/105848, c++/107484, c++/109160, c++/109300, ipa/109303,
|
||||
|
29
gcc13-pr108969.patch
Normal file
29
gcc13-pr108969.patch
Normal file
@ -0,0 +1,29 @@
|
||||
libstdc++: Fix preprocessor condition in linker script [PR108969]
|
||||
|
||||
The linker script is preprocessed with $(top_builddir)/config.h not the
|
||||
include/$target/bits/c++config.h version, which means that configure
|
||||
macros do not have the _GLIBCXX_ prefix yet.
|
||||
|
||||
The _GLIBCXX_SYMVER_GNU and _GLIBCXX_SHARED checks are redundant,
|
||||
because the gnu.ver file is only used for _GLIBCXX_SYMVER_GNU and the
|
||||
linker script is only used for the shared library. Remove those.
|
||||
|
||||
libstdc++-v3/ChangeLog:
|
||||
|
||||
PR libstdc++/108969
|
||||
* config/abi/pre/gnu.ver: Fix preprocessor condition.
|
||||
|
||||
--- libstdc++-v3/config/abi/pre/gnu.ver
|
||||
+++ libstdc++-v3/config/abi/pre/gnu.ver
|
||||
@@ -2512,9 +2512,8 @@ GLIBCXX_3.4.31 {
|
||||
_ZNKSt12__shared_ptrINSt10filesystem28recursive_directory_iterator10_Dir_stackELN9__gnu_cxx12_Lock_policyE[012]EEcvbEv;
|
||||
_ZNKSt12__shared_ptrINSt10filesystem7__cxx1128recursive_directory_iterator10_Dir_stackELN9__gnu_cxx12_Lock_policyE[012]EEcvbEv;
|
||||
|
||||
-#if defined(_GLIBCXX_SYMVER_GNU) && defined(_GLIBCXX_SHARED) \
|
||||
- && defined(_GLIBCXX_HAVE_AS_SYMVER_DIRECTIVE) \
|
||||
- && defined(_GLIBCXX_HAVE_SYMVER_SYMBOL_RENAMING_RUNTIME_SUPPORT)
|
||||
+#if defined(HAVE_AS_SYMVER_DIRECTIVE) \
|
||||
+ && defined(HAVE_SYMVER_SYMBOL_RENAMING_RUNTIME_SUPPORT)
|
||||
# See src/c++98/globals_io.cc
|
||||
_ZSt3cin;
|
||||
_ZSt4cout;
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-13.0.1-20230404.tar.xz) = d7c177e5bcf0efe6f3e48af4da5ab601c44eadad48b4af30bfcd833f256e615593e3ae5979ded5249b3d88417f482093a548dfab353e0d44bc1743afee295a79
|
||||
SHA512 (gcc-13.0.1-20230418.tar.xz) = 2015b135608474d16dde00cccf03a405898494eb2988048e781b9ae64e3b8a7a6d3b4faf3ca30185ec9e18cd7728d5fdc195aaedc25c75ccc59c5105d1424fcd
|
||||
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
||||
SHA512 (newlib-cygwin-9e09d6ed83cce4777a5950412647ccc603040409.tar.xz) = bef3fa04f7b1a915fc1356ebed114698b5cc835e9fa04b0becff05a9efc76c59fb376482990873d222d7acdcfee3c4f30f5a4cb7f3be1f291f1fa5f1c7a9d983
|
||||
SHA512 (nvptx-tools-93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b.tar.xz) = c719fad8689b2b6f3c888d0308604ddef884037d71ec3e755c68052d30075a181c29358fda516833ace437921b17602b147be7886317be94ec9736faa8cb52be
|
||||
|
Loading…
Reference in New Issue
Block a user