4.1.0-14
This commit is contained in:
parent
d79f4e043f
commit
523e60c801
@ -1 +1 @@
|
|||||||
gcc-4.1.0-20060503.tar.bz2
|
gcc-4.1.0-20060508.tar.bz2
|
||||||
|
@ -1,3 +1,13 @@
|
|||||||
|
2006-05-05 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
* gcc.dg/tls/opt-12.c: New test.
|
||||||
|
|
||||||
|
2006-04-25 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
|
* gcc.dg/20060425-2.c: New test.
|
||||||
|
|
||||||
|
* g++.dg/opt/pr15054-2.C: New test.
|
||||||
|
|
||||||
2006-04-20 Jakub Jelinek <jakub@redhat.com>
|
2006-04-20 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
|
||||||
* gcc.c-torture/execute/20060420-1.c: New test.
|
* gcc.c-torture/execute/20060420-1.c: New test.
|
||||||
@ -148,3 +158,77 @@
|
|||||||
+ abort ();
|
+ abort ();
|
||||||
+ return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
|
--- gcc/testsuite/g++.dg/opt/pr15054-2.C 2006-04-19 19:21:31.748476000 +0200
|
||||||
|
+++ gcc/testsuite/g++.dg/opt/pr15054-2.C 2006-04-25 15:55:07.000000000 +0200
|
||||||
|
@@ -0,0 +1,39 @@
|
||||||
|
+// PR middle-end/15054
|
||||||
|
+
|
||||||
|
+// { dg-do run }
|
||||||
|
+// { dg-options "-O2" }
|
||||||
|
+
|
||||||
|
+extern "C" void abort (void);
|
||||||
|
+
|
||||||
|
+void
|
||||||
|
+__attribute__((noinline))
|
||||||
|
+check (long x, long y)
|
||||||
|
+{
|
||||||
|
+ if (x != y)
|
||||||
|
+ abort ();
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+struct A
|
||||||
|
+{
|
||||||
|
+ A() : a(2) { check (a, 2); }
|
||||||
|
+ ~A() { check (a, 2); }
|
||||||
|
+private:
|
||||||
|
+ long a;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+class B {
|
||||||
|
+ long b;
|
||||||
|
+ B& operator =(const B& );
|
||||||
|
+public:
|
||||||
|
+ B (long p) : b(p) { check (b, 6); }
|
||||||
|
+ B (const B& p) : b(p.b) { check (b, 6); }
|
||||||
|
+ ~B () { check (b, 6); A obj; check (b, 6); }
|
||||||
|
+ B foo() { return B(*this); }
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+int main ()
|
||||||
|
+{
|
||||||
|
+ B o(6);
|
||||||
|
+ o.foo().foo();
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
--- gcc/testsuite/gcc.dg/20060425-2.c 2004-06-24 14:04:38.000000000 -0400
|
||||||
|
+++ gcc/testsuite/gcc.dg/20060425-2.c 2006-04-25 09:15:04.000000000 -0400
|
||||||
|
@@ -0,0 +1,10 @@
|
||||||
|
+/* { dg-do compile } */
|
||||||
|
+/* { dg-options "-O2" } */
|
||||||
|
+
|
||||||
|
+double
|
||||||
|
+crashme (double v, double *p)
|
||||||
|
+{
|
||||||
|
+ if (v < 0. && *p == 1.)
|
||||||
|
+ v = 0.;
|
||||||
|
+ return v;
|
||||||
|
+}
|
||||||
|
--- gcc/testsuite/gcc.dg/tls/opt-12.c 2006-04-19 19:21:31.748476000 +0200
|
||||||
|
+++ gcc/testsuite/gcc.dg/tls/opt-12.c 2006-05-05 11:01:33.000000000 +0200
|
||||||
|
@@ -0,0 +1,16 @@
|
||||||
|
+/* { dg-do compile } */
|
||||||
|
+/* { dg-options "-O2" } */
|
||||||
|
+/* { dg-require-effective-target tls } */
|
||||||
|
+
|
||||||
|
+__thread struct
|
||||||
|
+{
|
||||||
|
+ int a;
|
||||||
|
+ char b[32];
|
||||||
|
+} thr;
|
||||||
|
+
|
||||||
|
+int
|
||||||
|
+main ()
|
||||||
|
+{
|
||||||
|
+ __builtin_strcpy (thr.b, "abcd");
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
30
gcc41.spec
30
gcc41.spec
@ -1,6 +1,6 @@
|
|||||||
%define DATE 20060503
|
%define DATE 20060508
|
||||||
%define gcc_version 4.1.0
|
%define gcc_version 4.1.0
|
||||||
%define gcc_release 13
|
%define gcc_release 14
|
||||||
%define _unpackaged_files_terminate_build 0
|
%define _unpackaged_files_terminate_build 0
|
||||||
%define multilib_64_archs sparc64 ppc64 s390x x86_64
|
%define multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||||
%ifarch %{ix86} x86_64 ia64
|
%ifarch %{ix86} x86_64 ia64
|
||||||
@ -124,8 +124,10 @@ Patch26: gcc41-pr26729.patch
|
|||||||
Patch27: gcc41-rh188944.patch
|
Patch27: gcc41-rh188944.patch
|
||||||
Patch28: gcc41-rh137200.patch
|
Patch28: gcc41-rh137200.patch
|
||||||
Patch29: gcc41-rh187450.patch
|
Patch29: gcc41-rh187450.patch
|
||||||
Patch30: gcc41-pr27285.patch
|
Patch30: gcc41-pr27260.patch
|
||||||
Patch31: gcc41-pr27260.patch
|
Patch31: gcc41-pr27136.patch
|
||||||
|
Patch32: gcc41-pr27409.patch
|
||||||
|
Patch33: gcc41-pr27421.patch
|
||||||
%define _gnu %{nil}
|
%define _gnu %{nil}
|
||||||
%ifarch sparc
|
%ifarch sparc
|
||||||
%define gcc_target_platform sparc64-%{_vendor}-%{_target_os}
|
%define gcc_target_platform sparc64-%{_vendor}-%{_target_os}
|
||||||
@ -433,8 +435,10 @@ which are required to run programs compiled with the GNAT.
|
|||||||
%patch27 -p0 -b .rh188944~
|
%patch27 -p0 -b .rh188944~
|
||||||
%patch28 -p0 -b .rh137200~
|
%patch28 -p0 -b .rh137200~
|
||||||
%patch29 -p0 -b .rh187450~
|
%patch29 -p0 -b .rh187450~
|
||||||
%patch30 -p0 -b .pr27285~
|
%patch30 -p0 -b .pr27260~
|
||||||
%patch31 -p0 -b .pr27260~
|
%patch31 -p0 -b .pr27136~
|
||||||
|
%patch32 -p0 -b .pr27409~
|
||||||
|
%patch33 -p0 -b .pr27421~
|
||||||
|
|
||||||
sed -i -e 's/4\.1\.1/4.1.0/' gcc/BASE-VER gcc/version.c
|
sed -i -e 's/4\.1\.1/4.1.0/' gcc/BASE-VER gcc/version.c
|
||||||
sed -i -e 's/" (Red Hat[^)]*)"/" (Red Hat %{version}-%{gcc_release})"/' gcc/version.c
|
sed -i -e 's/" (Red Hat[^)]*)"/" (Red Hat %{version}-%{gcc_release})"/' gcc/version.c
|
||||||
@ -1471,6 +1475,18 @@ fi
|
|||||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 8 2006 Jakub Jelinek <jakub@redhat.com> 4.1.0-14
|
||||||
|
- update from gcc-4_1-branch (-r113489:113623)
|
||||||
|
- PRs c++/27422, c++/27427, fortran/24813, fortran/25099, fortran/25681,
|
||||||
|
fortran/27269, fortran/27324, libfortran/26985, objc/27240,
|
||||||
|
target/26481, target/26765, tree-optimization/25985,
|
||||||
|
tree-optimization/27151
|
||||||
|
- fix zero size field handling in structalias (Richard Guenther,
|
||||||
|
PR tree-optimization/27409)
|
||||||
|
- fix PR tree-optimization/27136 (Richard Guenther)
|
||||||
|
- fix classification of invalid struct types on x86_64 (Volker Reichelt,
|
||||||
|
PR target/27421)
|
||||||
|
|
||||||
* Wed May 3 2006 Jakub Jelinek <jakub@redhat.com> 4.1.0-13
|
* Wed May 3 2006 Jakub Jelinek <jakub@redhat.com> 4.1.0-13
|
||||||
- update from gcc-4_1-branch (-r113416:113489)
|
- update from gcc-4_1-branch (-r113416:113489)
|
||||||
- PRs c/25309, target/27374, target/27387, tree-optimization/27364
|
- PRs c/25309, target/27374, target/27387, tree-optimization/27364
|
||||||
@ -1478,7 +1494,7 @@ fi
|
|||||||
-r113452:113456, -r113482:113483, -r113493:113494)
|
-r113452:113456, -r113482:113483, -r113493:113494)
|
||||||
- PR fortran/27395
|
- PR fortran/27395
|
||||||
- additional gomp fixes (PRs c++/27359, middle-end/27388)
|
- additional gomp fixes (PRs c++/27359, middle-end/27388)
|
||||||
- package SYSCALLS.c.X for protize (#190047)
|
- package SYSCALLS.c.X for protoize (#190047)
|
||||||
- fix gcj -fprofile-arcs -ftest-coverage (Alexandre Oliva, #177450)
|
- fix gcj -fprofile-arcs -ftest-coverage (Alexandre Oliva, #177450)
|
||||||
- reenable profiledbootstrap
|
- reenable profiledbootstrap
|
||||||
- in 64-bit builds remove 32-bit /usr/lib/lib* libraries from the
|
- in 64-bit builds remove 32-bit /usr/lib/lib* libraries from the
|
||||||
|
Loading…
Reference in New Issue
Block a user