4.3.2-3
This commit is contained in:
parent
cd9cbfcd14
commit
5127525464
42
gcc43-altivec-tests.patch
Normal file
42
gcc43-altivec-tests.patch
Normal file
@ -0,0 +1,42 @@
|
||||
2008-08-26 Janis Johnson <janis187@us.ibm.com>
|
||||
|
||||
* g++.dg/ext/altivec-3.C: Move AltiVec code out of main.
|
||||
|
||||
2008-04-04 Janis Johnson <janis187@us.ibm.com>
|
||||
|
||||
* gcc.dg/var-expand3.c: Skip for powerpc-linux if not on AltiVec HW.
|
||||
|
||||
--- gcc/testsuite/g++.dg/ext/altivec-3.C (revision 139609)
|
||||
+++ gcc/testsuite/g++.dg/ext/altivec-3.C (revision 139610)
|
||||
@@ -120,16 +120,19 @@ void baz2 (int i, ... )
|
||||
CHECK_INVARIANT (vec_all_eq (vxi.v, vx_g.v));
|
||||
}
|
||||
|
||||
-int main(void)
|
||||
+void main1(void)
|
||||
{
|
||||
CHECK_INVARIANT (sizeof(struct foo) == 8 && sizeof(struct vfoo) == 48);
|
||||
|
||||
- altivec_check();
|
||||
-
|
||||
bar(i_1, x_g, (short)i_2, (float)d_2, ld_1, (char)i_1, d_3);
|
||||
baz(i_1, v_g, i_1, vx_g, i_1, v2_g, i_1, vx2_g);
|
||||
quux(i_1, v_g, v_g);
|
||||
baz2(i_1, vx_g);
|
||||
-
|
||||
+}
|
||||
+
|
||||
+int main(void)
|
||||
+{
|
||||
+ altivec_check();
|
||||
+ main1();
|
||||
return 0;
|
||||
}
|
||||
--- gcc/testsuite/gcc.dg/var-expand3.c (revision 133910)
|
||||
+++ gcc/testsuite/gcc.dg/var-expand3.c (revision 133911)
|
||||
@@ -1,4 +1,4 @@
|
||||
-/* { dg-do run { target { powerpc*-*-* && powerpc_altivec_ok } } }} */
|
||||
+/* { dg-do run { target { powerpc*-*-* && vmx_hw } } }} */
|
||||
/* { dg-options "-O2 -funroll-loops -ffast-math -fvariable-expansion-in-unroller -maltivec -fdump-rtl-loop2" } */
|
||||
|
||||
#include "altivec.h"
|
12
gcc43.spec
12
gcc43.spec
@ -51,7 +51,7 @@ Source3: protoize.1
|
||||
%define fastjar_ver 0.95
|
||||
Source4: http://download.savannah.nongnu.org/releases/fastjar/fastjar-%{fastjar_ver}.tar.gz
|
||||
URL: http://gcc.gnu.org
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n))
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
# Need binutils with -pie support >= 2.14.90.0.4-4
|
||||
# Need binutils which can omit dot symbols and overlap .opd on ppc64 >= 2.15.91.0.2-4
|
||||
# Need binutils which handle -msecure-plt on ppc >= 2.16.91.0.2-2
|
||||
@ -152,6 +152,8 @@ Patch15: gcc43-sparc-config-detection.patch
|
||||
Patch16: gcc43-libgomp-omp_h-multilib.patch
|
||||
Patch17: gcc43-x86_64-va_start.patch
|
||||
Patch18: gcc43-pr37189.patch
|
||||
Patch19: gcc43-altivec-tests.patch
|
||||
Patch20: gcc43-libtool-no-rpath.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
@ -454,6 +456,8 @@ which are required to run programs compiled with the GNAT.
|
||||
%patch16 -p0 -b .libgomp-omp_h-multilib~
|
||||
%patch17 -p0 -b .x86_64-va_start~
|
||||
%patch18 -p0 -b .pr37189~
|
||||
%patch19 -p0 -b .altivec-tests~
|
||||
%patch20 -p0 -b .libtool-no-rpath~
|
||||
|
||||
tar xzf %{SOURCE4}
|
||||
|
||||
@ -1702,6 +1706,12 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Sat Sep 6 2008 Jakub Jelinek <jakub@redhat.com> 4.3.2-3
|
||||
- don't run tests that require Altivec hw on non-Altivec powerpcs
|
||||
- make sure none of libgcj binaries/libraries contains /usr/%{lib} in
|
||||
RPATH
|
||||
- fix up BuildRoot
|
||||
|
||||
* Fri Sep 5 2008 Jakub Jelinek <jakub@redhat.com> 4.3.2-2
|
||||
- update from gcc-4_3-branch
|
||||
- PRs c++/37348, c/37261, fortran/36371, fortran/37193, middle-end/36449,
|
||||
|
Loading…
Reference in New Issue
Block a user