7.0.1-0.6
This commit is contained in:
parent
3d5e14ec38
commit
4d72b19d1c
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/gcc-7.0.1-20170128.tar.bz2
|
||||
/gcc-7.0.1-20170131.tar.bz2
|
||||
/gcc-7.0.1-20170201.tar.bz2
|
||||
/gcc-7.0.1-20170204.tar.bz2
|
||||
|
32
gcc.spec
32
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20170201
|
||||
%global SVNREV 245093
|
||||
%global DATE 20170204
|
||||
%global SVNREV 245184
|
||||
%global gcc_version 7.0.1
|
||||
%global gcc_major 7
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.5
|
||||
%global gcc_release 0.6
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -227,9 +227,8 @@ Patch7: gcc7-libstdc++-docs.patch
|
||||
Patch8: gcc7-no-add-needed.patch
|
||||
Patch9: gcc7-aarch64-async-unw-tables.patch
|
||||
Patch10: gcc7-foffload-default.patch
|
||||
Patch11: gcc7-pr79197.patch
|
||||
Patch12: gcc7-pr79232.patch
|
||||
Patch13: gcc7-pr79288.patch
|
||||
Patch11: gcc7-pr79232.patch
|
||||
Patch12: gcc7-pr79288.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -817,9 +816,8 @@ package or when debugging this package.
|
||||
%patch8 -p0 -b .no-add-needed~
|
||||
%patch9 -p0 -b .aarch64-async-unw-tables~
|
||||
%patch10 -p0 -b .foffload-default~
|
||||
%patch11 -p0 -b .pr79197~
|
||||
%patch12 -p0 -b .pr79232~
|
||||
%patch13 -p0 -b .pr79288~
|
||||
%patch11 -p0 -b .pr79232~
|
||||
%patch12 -p0 -b .pr79288~
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
@ -1119,10 +1117,14 @@ CONFIGURE_OPTS="\
|
||||
%ifarch s390 s390x
|
||||
%if 0%{?rhel} >= 7
|
||||
--with-arch=z196 --with-tune=zEC12 --enable-decimal-float \
|
||||
%else
|
||||
%if 0%{?fedora} >= 26
|
||||
--with-arch=zEC12 --with-tune=z13 --enable-decimal-float \
|
||||
%else
|
||||
--with-arch=z9-109 --with-tune=z10 --enable-decimal-float \
|
||||
%endif
|
||||
%endif
|
||||
%endif
|
||||
%ifarch armv7hl
|
||||
--with-tune=cortex-a8 --with-arch=armv7-a \
|
||||
--with-float=hard --with-fpu=vfpv3-d16 --with-abi=aapcs-linux \
|
||||
@ -3237,6 +3239,18 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Feb 4 2017 Jakub Jelinek <jakub@redhat.com> 7.0.1-0.6
|
||||
- update from the trunk
|
||||
- PRs ada/79309, c++/12245, c++/69637, c++/78689, c++/79294, cp/14179,
|
||||
ipa/79337, libstdc++/60936, libstdc++/78346, lto/66295,
|
||||
middle-end/32003, middle-end/78142, middle-end/78468,
|
||||
middle-end/79275, sanitizer/78663, target/70012, target/78862,
|
||||
target/79158, target/79354, testsuite/76957, testsuite/79272,
|
||||
testsuite/79324, tree-optimization/79327, tree-optimization/79338,
|
||||
tree-optimization/79339, tree-optimization/79340,
|
||||
tree-optimization/79352
|
||||
- default to -march=zEC12 -mtune=z13 on s390x (#1404991)
|
||||
|
||||
* Wed Feb 1 2017 Jakub Jelinek <jakub@redhat.com> 7.0.1-0.5
|
||||
- update from the trunk
|
||||
- PRs c++/67273, c++/79253, c++/79264, c++/79290, c++/79298, c++/79304,
|
||||
|
@ -1,59 +0,0 @@
|
||||
2017-01-30 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR target/79197
|
||||
* config/rs6000/rs6000.md (*fixuns_trunc<mode>di2_fctiduz): Rename to ...
|
||||
(fixuns_trunc<mode>di2): ... this, remove previous expander. Put all
|
||||
conditions on a single line.
|
||||
|
||||
* gcc.target/powerpc/pr79197.c: New test.
|
||||
* gcc.c-torture/compile/pr79197.c: New test.
|
||||
|
||||
--- gcc/config/rs6000/rs6000.md.jj 2017-01-23 18:41:20.000000000 +0100
|
||||
+++ gcc/config/rs6000/rs6000.md 2017-01-30 14:44:12.148761705 +0100
|
||||
@@ -5712,17 +5712,10 @@ (define_insn_and_split "fixuns_trunc<mod
|
||||
[(set_attr "length" "12")
|
||||
(set_attr "type" "fp")])
|
||||
|
||||
-(define_expand "fixuns_trunc<mode>di2"
|
||||
- [(set (match_operand:DI 0 "register_operand" "")
|
||||
- (unsigned_fix:DI (match_operand:SFDF 1 "register_operand" "")))]
|
||||
- "TARGET_HARD_FLOAT && (TARGET_FCTIDUZ || VECTOR_UNIT_VSX_P (<MODE>mode))"
|
||||
- "")
|
||||
-
|
||||
-(define_insn "*fixuns_trunc<mode>di2_fctiduz"
|
||||
+(define_insn "fixuns_trunc<mode>di2"
|
||||
[(set (match_operand:DI 0 "gpc_reg_operand" "=d,wi")
|
||||
(unsigned_fix:DI (match_operand:SFDF 1 "gpc_reg_operand" "<Ff>,<Fv>")))]
|
||||
- "TARGET_HARD_FLOAT && TARGET_DOUBLE_FLOAT && TARGET_FPRS
|
||||
- && TARGET_FCTIDUZ"
|
||||
+ "TARGET_HARD_FLOAT && TARGET_DOUBLE_FLOAT && TARGET_FPRS && TARGET_FCTIDUZ"
|
||||
"@
|
||||
fctiduz %0,%1
|
||||
xscvdpuxds %x0,%x1"
|
||||
--- gcc/testsuite/gcc.target/powerpc/pr79197.c.jj 2017-01-30 14:54:55.533314402 +0100
|
||||
+++ gcc/testsuite/gcc.target/powerpc/pr79197.c 2017-01-30 14:55:20.407988406 +0100
|
||||
@@ -0,0 +1,11 @@
|
||||
+/* PR target/79197 */
|
||||
+/* { dg-do compile } */
|
||||
+/* { dg-options "-O0 -mno-popcntd" } */
|
||||
+
|
||||
+unsigned a;
|
||||
+
|
||||
+void
|
||||
+foo (void)
|
||||
+{
|
||||
+ a = *(double *) (__UINTPTR_TYPE__) 0x400000;
|
||||
+}
|
||||
--- gcc/testsuite/gcc.c-torture/compile/pr79197.c.jj 2017-01-30 14:56:31.383058240 +0100
|
||||
+++ gcc/testsuite/gcc.c-torture/compile/pr79197.c 2017-01-30 14:56:40.902933477 +0100
|
||||
@@ -0,0 +1,10 @@
|
||||
+/* PR target/79197 */
|
||||
+
|
||||
+unsigned long b;
|
||||
+
|
||||
+unsigned long
|
||||
+foo (float *a, float *x)
|
||||
+{
|
||||
+ __builtin_memcpy (a, x, sizeof (float));
|
||||
+ return *a;
|
||||
+}
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-7.0.1-20170201.tar.bz2) = 3d18b674cc406682596e6488777c8d1fcf4921d26cf77b5eda58ab6f5f45734e5609e9efe037fb84a8013bdeccb5afc89bc3d76259d56df8e7b53f9803fb3c04
|
||||
SHA512 (gcc-7.0.1-20170204.tar.bz2) = bca8ac6656af91ea0fb4c7ad9b3ea8f182fb88f06e6ce5b8e5daeab8bd513ef3b1fc4adcf9108d6712fe7c2d1b333b6a1f5c4e352c684dfbbb85fbc3f0519398
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.bz2) = 38f97c9297ad108568352a4d28277455a3c01fd8b7864e798037e5006b6f757022e874bbf3f165775fe3b873781bc108137bbeb42dd5ed3c7d3e6747746fa918
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.bz2) = 95b577a06a93bb044dbc8033e550cb36bcf2ab2687da030a7318cdc90e7467ed49665e247dcafb5ff4a7e92cdc264291d19728bd17fab902fb64b22491269330
|
||||
|
Loading…
Reference in New Issue
Block a user