7.0.1-0.5
This commit is contained in:
parent
6ed6e5a4c3
commit
3d5e14ec38
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.bz2
|
||||
/gcc-7.0.1-20170128.tar.bz2
|
||||
/gcc-7.0.1-20170131.tar.bz2
|
||||
/gcc-7.0.1-20170201.tar.bz2
|
||||
|
27
gcc.spec
27
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20170131
|
||||
%global SVNREV 245054
|
||||
%global DATE 20170201
|
||||
%global SVNREV 245093
|
||||
%global gcc_version 7.0.1
|
||||
%global gcc_major 7
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.4
|
||||
%global gcc_release 0.5
|
||||
%global nvptx_tools_gitrev c28050f60193b3b95a18866a96f03334e874e78f
|
||||
%global nvptx_newlib_gitrev aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -227,10 +227,9 @@ Patch7: gcc7-libstdc++-docs.patch
|
||||
Patch8: gcc7-no-add-needed.patch
|
||||
Patch9: gcc7-aarch64-async-unw-tables.patch
|
||||
Patch10: gcc7-foffload-default.patch
|
||||
Patch11: gcc7-s390-asan.patch
|
||||
Patch12: gcc7-pr79197.patch
|
||||
Patch13: gcc7-pr79232.patch
|
||||
Patch14: gcc7-pr79288.patch
|
||||
Patch11: gcc7-pr79197.patch
|
||||
Patch12: gcc7-pr79232.patch
|
||||
Patch13: gcc7-pr79288.patch
|
||||
|
||||
Patch1000: nvptx-tools-no-ptxas.patch
|
||||
Patch1001: nvptx-tools-build.patch
|
||||
@ -818,10 +817,9 @@ package or when debugging this package.
|
||||
%patch8 -p0 -b .no-add-needed~
|
||||
%patch9 -p0 -b .aarch64-async-unw-tables~
|
||||
%patch10 -p0 -b .foffload-default~
|
||||
%patch11 -p0 -b .s390-asan~
|
||||
%patch12 -p0 -b .pr79197~
|
||||
%patch13 -p0 -b .pr79232~
|
||||
%patch14 -p0 -b .pr79288~
|
||||
%patch11 -p0 -b .pr79197~
|
||||
%patch12 -p0 -b .pr79232~
|
||||
%patch13 -p0 -b .pr79288~
|
||||
|
||||
cd nvptx-tools-%{nvptx_tools_gitrev}
|
||||
%patch1000 -p1 -b .nvptx-tools-no-ptxas~
|
||||
@ -3239,6 +3237,13 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 1 2017 Jakub Jelinek <jakub@redhat.com> 7.0.1-0.5
|
||||
- update from the trunk
|
||||
- PRs c++/67273, c++/79253, c++/79264, c++/79290, c++/79298, c++/79304,
|
||||
fortran/79305, ipa/79285, middle-end/79315, preprocessor/79210,
|
||||
target/78597, target/79038, tree-optimization/71691,
|
||||
tree-optimization/71824, tree-optimization/77318
|
||||
|
||||
* Tue Jan 31 2017 Jakub Jelinek <jakub@redhat.com> 7.0.1-0.4
|
||||
- update from the trunk
|
||||
- PRs bootstrap/78985, debug/63238, debug/79289, gcov-profile/79259,
|
||||
|
@ -1,48 +0,0 @@
|
||||
2017-01-23 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
gcc/
|
||||
* config/s390/s390.c (s390_asan_shadow_offset): New function.
|
||||
(TARGET_ASAN_SHADOW_OFFSET): Redefine.
|
||||
libsanitizer/
|
||||
* configure.tgt: Enable asan and ubsan on 64-bit s390*-*-linux*.
|
||||
|
||||
--- gcc/config/s390/s390.c.jj 2017-01-19 16:58:25.000000000 +0100
|
||||
+++ gcc/config/s390/s390.c 2017-01-23 16:32:28.220398187 +0100
|
||||
@@ -15435,6 +15435,14 @@ s390_excess_precision (enum excess_preci
|
||||
return FLT_EVAL_METHOD_UNPREDICTABLE;
|
||||
}
|
||||
|
||||
+/* Implement the TARGET_ASAN_SHADOW_OFFSET hook. */
|
||||
+
|
||||
+static unsigned HOST_WIDE_INT
|
||||
+s390_asan_shadow_offset (void)
|
||||
+{
|
||||
+ return TARGET_64BIT ? HOST_WIDE_INT_1U << 52 : HOST_WIDE_INT_UC (0x20000000);
|
||||
+}
|
||||
+
|
||||
/* Initialize GCC target structure. */
|
||||
|
||||
#undef TARGET_ASM_ALIGNED_HI_OP
|
||||
@@ -15536,6 +15544,8 @@ s390_excess_precision (enum excess_preci
|
||||
#define TARGET_BUILD_BUILTIN_VA_LIST s390_build_builtin_va_list
|
||||
#undef TARGET_EXPAND_BUILTIN_VA_START
|
||||
#define TARGET_EXPAND_BUILTIN_VA_START s390_va_start
|
||||
+#undef TARGET_ASAN_SHADOW_OFFSET
|
||||
+#define TARGET_ASAN_SHADOW_OFFSET s390_asan_shadow_offset
|
||||
#undef TARGET_GIMPLIFY_VA_ARG_EXPR
|
||||
#define TARGET_GIMPLIFY_VA_ARG_EXPR s390_gimplify_va_arg
|
||||
|
||||
--- libsanitizer/configure.tgt.jj 2017-01-23 15:25:21.000000000 +0100
|
||||
+++ libsanitizer/configure.tgt 2017-01-23 15:36:40.787456320 +0100
|
||||
@@ -39,6 +39,11 @@ case "${target}" in
|
||||
;;
|
||||
sparc*-*-linux*)
|
||||
;;
|
||||
+ s390*-*-linux*)
|
||||
+ if test x$ac_cv_sizeof_void_p = x4; then
|
||||
+ UNSUPPORTED=1
|
||||
+ fi
|
||||
+ ;;
|
||||
arm*-*-linux*)
|
||||
;;
|
||||
aarch64*-*-linux*)
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gcc-7.0.1-20170131.tar.bz2) = 976af1e513fe6f701cf3e83503e2a44560e37f0f33622c45b4d1fe119006c7cc9d45584df5e760a41c4767be036dee24d88a33379ff65366b187605f463ea1b0
|
||||
SHA512 (gcc-7.0.1-20170201.tar.bz2) = 3d18b674cc406682596e6488777c8d1fcf4921d26cf77b5eda58ab6f5f45734e5609e9efe037fb84a8013bdeccb5afc89bc3d76259d56df8e7b53f9803fb3c04
|
||||
SHA512 (nvptx-newlib-aadc8eb0ec43b7cd0dd2dfb484bae63c8b05ef24.tar.bz2) = 38f97c9297ad108568352a4d28277455a3c01fd8b7864e798037e5006b6f757022e874bbf3f165775fe3b873781bc108137bbeb42dd5ed3c7d3e6747746fa918
|
||||
SHA512 (nvptx-tools-c28050f60193b3b95a18866a96f03334e874e78f.tar.bz2) = 95b577a06a93bb044dbc8033e550cb36bcf2ab2687da030a7318cdc90e7467ed49665e247dcafb5ff4a7e92cdc264291d19728bd17fab902fb64b22491269330
|
||||
|
Loading…
Reference in New Issue
Block a user