4.4.1-8
This commit is contained in:
parent
cb4e33ae41
commit
3b6291bcd4
@ -1,2 +1,2 @@
|
||||
fastjar-0.97.tar.gz
|
||||
gcc-4.4.1-20090901.tar.bz2
|
||||
gcc-4.4.1-20090902.tar.bz2
|
||||
|
73
gcc.spec
73
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20090901
|
||||
%global SVNREV 151272
|
||||
%global DATE 20090902
|
||||
%global SVNREV 151328
|
||||
%global gcc_version 4.4.1
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 7
|
||||
%global gcc_release 8
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%global include_gappletviewer 1
|
||||
@ -144,22 +144,21 @@ Patch2: gcc44-c++-builtin-redecl.patch
|
||||
Patch3: gcc44-ia64-libunwind.patch
|
||||
Patch4: gcc44-java-nomulti.patch
|
||||
Patch5: gcc44-ppc32-retaddr.patch
|
||||
Patch9: gcc44-pr33763.patch
|
||||
Patch10: gcc44-rh330771.patch
|
||||
Patch11: gcc44-rh341221.patch
|
||||
Patch12: gcc44-java-debug-iface-type.patch
|
||||
Patch13: gcc44-i386-libgomp.patch
|
||||
Patch15: gcc44-sparc-config-detection.patch
|
||||
Patch16: gcc44-libgomp-omp_h-multilib.patch
|
||||
Patch20: gcc44-libtool-no-rpath.patch
|
||||
Patch21: gcc44-cloog-dl.patch
|
||||
Patch22: gcc44-raw-string.patch
|
||||
Patch24: gcc44-unwind-debug-hook.patch
|
||||
Patch28: gcc44-pr38757.patch
|
||||
Patch29: gcc44-libstdc++-docs.patch
|
||||
Patch30: gcc44-rh503816-1.patch
|
||||
Patch31: gcc44-rh503816-2.patch
|
||||
Patch32: gcc44-unique-object.patch
|
||||
Patch6: gcc44-pr33763.patch
|
||||
Patch7: gcc44-rh330771.patch
|
||||
Patch8: gcc44-rh341221.patch
|
||||
Patch9: gcc44-java-debug-iface-type.patch
|
||||
Patch10: gcc44-i386-libgomp.patch
|
||||
Patch11: gcc44-sparc-config-detection.patch
|
||||
Patch12: gcc44-libgomp-omp_h-multilib.patch
|
||||
Patch13: gcc44-libtool-no-rpath.patch
|
||||
Patch14: gcc44-cloog-dl.patch
|
||||
Patch15: gcc44-raw-string.patch
|
||||
Patch16: gcc44-unwind-debug-hook.patch
|
||||
Patch17: gcc44-pr38757.patch
|
||||
Patch18: gcc44-libstdc++-docs.patch
|
||||
Patch19: gcc44-rh503816-1.patch
|
||||
Patch20: gcc44-rh503816-2.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
|
||||
@ -448,26 +447,25 @@ which are required to compile with the GNAT.
|
||||
%patch3 -p0 -b .ia64-libunwind~
|
||||
%patch4 -p0 -b .java-nomulti~
|
||||
%patch5 -p0 -b .ppc32-retaddr~
|
||||
%patch9 -p0 -b .pr33763~
|
||||
%patch10 -p0 -b .rh330771~
|
||||
%patch11 -p0 -b .rh341221~
|
||||
%patch12 -p0 -b .java-debug-iface-type~
|
||||
%patch13 -p0 -b .i386-libgomp~
|
||||
%patch15 -p0 -b .sparc-config-detection~
|
||||
%patch16 -p0 -b .libgomp-omp_h-multilib~
|
||||
%patch20 -p0 -b .libtool-no-rpath~
|
||||
%patch6 -p0 -b .pr33763~
|
||||
%patch7 -p0 -b .rh330771~
|
||||
%patch8 -p0 -b .rh341221~
|
||||
%patch9 -p0 -b .java-debug-iface-type~
|
||||
%patch10 -p0 -b .i386-libgomp~
|
||||
%patch11 -p0 -b .sparc-config-detection~
|
||||
%patch12 -p0 -b .libgomp-omp_h-multilib~
|
||||
%patch13 -p0 -b .libtool-no-rpath~
|
||||
%if %{build_cloog}
|
||||
%patch21 -p0 -b .cloog-dl~
|
||||
%patch14 -p0 -b .cloog-dl~
|
||||
%endif
|
||||
%patch22 -p0 -b .raw-string~
|
||||
%patch24 -p0 -b .unwind-debug-hook~
|
||||
%patch28 -p0 -b .pr38757~
|
||||
%patch15 -p0 -b .raw-string~
|
||||
%patch16 -p0 -b .unwind-debug-hook~
|
||||
%patch17 -p0 -b .pr38757~
|
||||
%if %{build_libstdcxx_docs}
|
||||
%patch29 -p0 -b .libstdc++-docs~
|
||||
%patch18 -p0 -b .libstdc++-docs~
|
||||
%endif
|
||||
%patch30 -p0 -b .rh503816-1~
|
||||
%patch31 -p0 -b .rh503816-2~
|
||||
%patch32 -p0 -b .unique-object~
|
||||
%patch19 -p0 -b .rh503816-1~
|
||||
%patch20 -p0 -b .rh503816-2~
|
||||
|
||||
# This testcase doesn't compile.
|
||||
rm libjava/testsuite/libjava.lang/PR35020*
|
||||
@ -604,6 +602,7 @@ CC="$CC" CFLAGS="$OPT_FLAGS" CXXFLAGS="`echo $OPT_FLAGS | sed 's/ -Wall / /g'`"
|
||||
--with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap \
|
||||
--enable-shared --enable-threads=posix --enable-checking=release \
|
||||
--with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions \
|
||||
--enable-gnu-unique-object \
|
||||
%if !%{build_ada}
|
||||
--enable-languages=c,c++,objc,obj-c++,java,fortran \
|
||||
%else
|
||||
@ -1806,6 +1805,10 @@ fi
|
||||
%doc rpm.doc/changelogs/libmudflap/ChangeLog*
|
||||
|
||||
%changelog
|
||||
* Wed Sep 2 2009 Jakub Jelinek <jakub@redhat.com> 4.4.1-8
|
||||
- fix up __builtin_object_size (#505862)
|
||||
- fix Fortran GOTO warning (PR fortran/38507)
|
||||
|
||||
* Tue Sep 1 2009 Jakub Jelinek <jakub@redhat.com> 4.4.1-7
|
||||
- update from gcc-4_4-branch
|
||||
- PRs c++/41120, c++/41127, c++/41131, fortran/41062, fortran/41102,
|
||||
|
@ -1,142 +0,0 @@
|
||||
2009-07-22 Jason Merrill <jason@redhat.com>
|
||||
|
||||
* config/elfos.h (ASM_DECLARE_OBJECT_NAME): Use gnu_unique_object
|
||||
type if available.
|
||||
* configure.ac: Test for it.
|
||||
* configure, config.in: Regenerate.
|
||||
|
||||
--- gcc/config/elfos.h.jj 2009-04-14 15:51:24.000000000 +0200
|
||||
+++ gcc/config/elfos.h 2009-07-23 09:25:46.000000000 +0200
|
||||
@@ -289,24 +289,37 @@ see the files COPYING3 and COPYING.RUNTI
|
||||
|
||||
/* Write the extra assembler code needed to declare an object properly. */
|
||||
|
||||
-#define ASM_DECLARE_OBJECT_NAME(FILE, NAME, DECL) \
|
||||
- do \
|
||||
- { \
|
||||
- HOST_WIDE_INT size; \
|
||||
- \
|
||||
- ASM_OUTPUT_TYPE_DIRECTIVE (FILE, NAME, "object"); \
|
||||
- \
|
||||
- size_directive_output = 0; \
|
||||
- if (!flag_inhibit_size_directive \
|
||||
- && (DECL) && DECL_SIZE (DECL)) \
|
||||
- { \
|
||||
- size_directive_output = 1; \
|
||||
- size = int_size_in_bytes (TREE_TYPE (DECL)); \
|
||||
- ASM_OUTPUT_SIZE_DIRECTIVE (FILE, NAME, size); \
|
||||
- } \
|
||||
- \
|
||||
- ASM_OUTPUT_LABEL (FILE, NAME); \
|
||||
- } \
|
||||
+#ifdef HAVE_GAS_GNU_UNIQUE_OBJECT
|
||||
+#define USE_GNU_UNIQUE_OBJECT 1
|
||||
+#else
|
||||
+#define USE_GNU_UNIQUE_OBJECT 0
|
||||
+#endif
|
||||
+
|
||||
+#define ASM_DECLARE_OBJECT_NAME(FILE, NAME, DECL) \
|
||||
+ do \
|
||||
+ { \
|
||||
+ HOST_WIDE_INT size; \
|
||||
+ \
|
||||
+ /* For template static data member instantiations or \
|
||||
+ inline fn local statics, use gnu_unique_object so that \
|
||||
+ they will be combined even under RTLD_LOCAL. */ \
|
||||
+ if (USE_GNU_UNIQUE_OBJECT \
|
||||
+ && !DECL_ARTIFICIAL (DECL) && DECL_ONE_ONLY (DECL)) \
|
||||
+ ASM_OUTPUT_TYPE_DIRECTIVE (FILE, NAME, "gnu_unique_object"); \
|
||||
+ else \
|
||||
+ ASM_OUTPUT_TYPE_DIRECTIVE (FILE, NAME, "object"); \
|
||||
+ \
|
||||
+ size_directive_output = 0; \
|
||||
+ if (!flag_inhibit_size_directive \
|
||||
+ && (DECL) && DECL_SIZE (DECL)) \
|
||||
+ { \
|
||||
+ size_directive_output = 1; \
|
||||
+ size = int_size_in_bytes (TREE_TYPE (DECL)); \
|
||||
+ ASM_OUTPUT_SIZE_DIRECTIVE (FILE, NAME, size); \
|
||||
+ } \
|
||||
+ \
|
||||
+ ASM_OUTPUT_LABEL (FILE, NAME); \
|
||||
+ } \
|
||||
while (0)
|
||||
|
||||
/* Output the size directive for a decl in rest_of_decl_compilation
|
||||
--- gcc/configure.ac.jj 2009-03-28 09:53:59.000000000 +0100
|
||||
+++ gcc/configure.ac 2009-07-23 09:25:46.000000000 +0200
|
||||
@@ -3299,6 +3299,12 @@ gcc_GAS_CHECK_FEATURE([.lcomm with align
|
||||
[AC_DEFINE(HAVE_GAS_LCOMM_WITH_ALIGNMENT, 1,
|
||||
[Define if your assembler supports .lcomm with an alignment field.])])
|
||||
|
||||
+gcc_GAS_CHECK_FEATURE([gnu_unique_object], gcc_cv_as_gnu_unique_object,
|
||||
+ [elf,2,19,52],,
|
||||
+[.type foo, @gnu_unique_object],,
|
||||
+[AC_DEFINE(HAVE_GAS_GNU_UNIQUE_OBJECT, 1,
|
||||
+ [Define if your assembler supports @gnu_unique_object.])])
|
||||
+
|
||||
AC_CACHE_CHECK([assembler for tolerance to line number 0],
|
||||
[gcc_cv_as_line_zero],
|
||||
[gcc_cv_as_line_zero=no
|
||||
--- gcc/configure.jj 2009-03-28 09:53:37.000000000 +0100
|
||||
+++ gcc/configure 2009-07-23 09:26:52.000000000 +0200
|
||||
@@ -24288,6 +24288,44 @@ _ACEOF
|
||||
|
||||
fi
|
||||
|
||||
+echo "$as_me:$LINENO: checking assembler for gnu_unique_object" >&5
|
||||
+echo $ECHO_N "checking assembler for gnu_unique_object... $ECHO_C" >&6
|
||||
+if test "${gcc_cv_as_gnu_unique_object+set}" = set; then
|
||||
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
+else
|
||||
+ gcc_cv_as_gnu_unique_object=no
|
||||
+ if test $in_tree_gas = yes; then
|
||||
+ if test $in_tree_gas_is_elf = yes \
|
||||
+ && test $gcc_cv_gas_vers -ge `expr \( \( 2 \* 1000 \) + 19 \) \* 1000 + 52`
|
||||
+ then gcc_cv_as_gnu_unique_object=yes
|
||||
+fi
|
||||
+ elif test x$gcc_cv_as != x; then
|
||||
+ echo '.type foo, @gnu_unique_object' > conftest.s
|
||||
+ if { ac_try='$gcc_cv_as -o conftest.o conftest.s >&5'
|
||||
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
+ (eval $ac_try) 2>&5
|
||||
+ ac_status=$?
|
||||
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
+ (exit $ac_status); }; }
|
||||
+ then
|
||||
+ gcc_cv_as_gnu_unique_object=yes
|
||||
+ else
|
||||
+ echo "configure: failed program was" >&5
|
||||
+ cat conftest.s >&5
|
||||
+ fi
|
||||
+ rm -f conftest.o conftest.s
|
||||
+ fi
|
||||
+fi
|
||||
+echo "$as_me:$LINENO: result: $gcc_cv_as_gnu_unique_object" >&5
|
||||
+echo "${ECHO_T}$gcc_cv_as_gnu_unique_object" >&6
|
||||
+if test $gcc_cv_as_gnu_unique_object = yes; then
|
||||
+
|
||||
+cat >>confdefs.h <<\_ACEOF
|
||||
+#define HAVE_GAS_GNU_UNIQUE_OBJECT 1
|
||||
+_ACEOF
|
||||
+
|
||||
+fi
|
||||
+
|
||||
echo "$as_me:$LINENO: checking assembler for tolerance to line number 0" >&5
|
||||
echo $ECHO_N "checking assembler for tolerance to line number 0... $ECHO_C" >&6
|
||||
if test "${gcc_cv_as_line_zero+set}" = set; then
|
||||
--- gcc/config.in.jj 2009-02-16 22:48:20.000000000 +0100
|
||||
+++ gcc/config.in 2009-07-23 09:26:56.000000000 +0200
|
||||
@@ -845,6 +845,12 @@
|
||||
#endif
|
||||
|
||||
|
||||
+/* Define if your assembler supports @gnu_unique_object. */
|
||||
+#ifndef USED_FOR_TARGET
|
||||
+#undef HAVE_GAS_GNU_UNIQUE_OBJECT
|
||||
+#endif
|
||||
+
|
||||
+
|
||||
/* Define if your assembler and linker support .hidden. */
|
||||
#undef HAVE_GAS_HIDDEN
|
||||
|
Loading…
Reference in New Issue
Block a user