13.0.1-0.1
This commit is contained in:
parent
311655b816
commit
2e2b76f57a
8
gcc.spec
8
gcc.spec
@ -287,8 +287,7 @@ Patch9: gcc13-Wno-format-security.patch
|
||||
Patch10: gcc13-rh1574936.patch
|
||||
Patch11: gcc13-d-shared-libphobos.patch
|
||||
Patch12: gcc13-pr107678.patch
|
||||
Patch13: gcc13-pr107608.patch
|
||||
Patch14: gcc13-pr108411.patch
|
||||
Patch13: gcc13-pr108411.patch
|
||||
|
||||
Patch50: isl-rh2155127.patch
|
||||
|
||||
@ -864,8 +863,7 @@ so that there cannot be any synchronization problems.
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr107678~
|
||||
%patch13 -p0 -b .pr107608~
|
||||
%patch14 -p0 -b .pr108411~
|
||||
%patch13 -p0 -b .pr108411~
|
||||
|
||||
%patch50 -p0 -b .rh2155127~
|
||||
touch -r isl-0.24/m4/ax_prog_cxx_for_build.m4 isl-0.24/m4/ax_prog_cc_for_build.m4
|
||||
@ -3467,7 +3465,7 @@ end
|
||||
- PRs c++/105593, fortran/108421, go/108426, ipa/106077, libstdc++/108288,
|
||||
libstdc++/108413, other/108413, target/55522, target/96795,
|
||||
target/105980, target/107515, target/108272, tree-optimization/94793,
|
||||
tree-optimization/106523, tree-optimization/107608
|
||||
tree-optimization/106523
|
||||
- don't build ppc64le unwinder with -fno-omit-frame-pointer (#2161595)
|
||||
|
||||
* Sun Jan 15 2023 Jakub Jelinek <jakub@redhat.com> 13.0.0-0.9
|
||||
|
@ -1,47 +0,0 @@
|
||||
2023-01-15 Aldy Hernandez <aldyh@redhat.com>
|
||||
|
||||
PR tree-optimization/107608
|
||||
* range-op-float.cc (range_operator_float::fold_range): Avoid
|
||||
folding into INF when flag_trapping_math.
|
||||
* value-range.h (frange::known_isinf): Return false for possible NANs.
|
||||
|
||||
--- gcc/range-op-float.cc
|
||||
+++ gcc/range-op-float.cc
|
||||
@@ -91,6 +91,27 @@ range_operator_float::fold_range (frange &r, tree type,
|
||||
else
|
||||
r.clear_nan ();
|
||||
|
||||
+ // If the result has overflowed and flag_trapping_math, folding this
|
||||
+ // operation could elide an overflow or division by zero exception.
|
||||
+ // Avoid returning a singleton +-INF, to keep the propagators (DOM
|
||||
+ // and substitute_and_fold_engine) from folding. See PR107608.
|
||||
+ if (flag_trapping_math
|
||||
+ && MODE_HAS_INFINITIES (TYPE_MODE (type))
|
||||
+ && r.known_isinf () && !op1.known_isinf () && !op2.known_isinf ())
|
||||
+ {
|
||||
+ REAL_VALUE_TYPE inf = r.lower_bound ();
|
||||
+ if (real_isneg (&inf))
|
||||
+ {
|
||||
+ REAL_VALUE_TYPE min = real_min_representable (type);
|
||||
+ r.set (type, inf, min);
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ REAL_VALUE_TYPE max = real_max_representable (type);
|
||||
+ r.set (type, max, inf);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
return true;
|
||||
}
|
||||
|
||||
--- gcc/value-range.h
|
||||
+++ gcc/value-range.h
|
||||
@@ -1300,6 +1300,7 @@ inline bool
|
||||
frange::known_isinf () const
|
||||
{
|
||||
return (m_kind == VR_RANGE
|
||||
+ && !maybe_isnan ()
|
||||
&& real_identical (&m_min, &m_max)
|
||||
&& real_isinf (&m_min));
|
||||
}
|
Loading…
Reference in New Issue
Block a user