13.0.1-0.9
This commit is contained in:
parent
99a093cb4f
commit
28a41d7ec1
2
.gitignore
vendored
2
.gitignore
vendored
@ -94,3 +94,5 @@
|
||||
/gcc-13.0.1-20230304.tar.xz
|
||||
/gcc-13.0.1-20230310.tar.xz
|
||||
/gcc-13.0.1-20230318.tar.xz
|
||||
/gcc-13.0.1-20230321.tar.xz
|
||||
/nvptx-tools-93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b.tar.xz
|
||||
|
19
gcc.spec
19
gcc.spec
@ -1,11 +1,11 @@
|
||||
%global DATE 20230318
|
||||
%global gitrev 24c7659a6ceb150243ffcbb95401b05e70d3fff8
|
||||
%global DATE 20230321
|
||||
%global gitrev 631cc7b96752740a3fdfd960b503d64faf02c1b6
|
||||
%global gcc_version 13.0.1
|
||||
%global gcc_major 13
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 0
|
||||
%global nvptx_tools_gitrev 472b6e78b3ba918d727698f79911360b7c808247
|
||||
%global nvptx_tools_gitrev 93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b
|
||||
%global newlib_cygwin_gitrev 9e09d6ed83cce4777a5950412647ccc603040409
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global _performance_build 1
|
||||
@ -136,7 +136,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}.8%{?dist}
|
||||
Release: %{gcc_release}.9%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -286,6 +286,7 @@ Patch8: gcc13-no-add-needed.patch
|
||||
Patch9: gcc13-Wno-format-security.patch
|
||||
Patch10: gcc13-rh1574936.patch
|
||||
Patch11: gcc13-d-shared-libphobos.patch
|
||||
Patch12: gcc13-pr109230.patch
|
||||
|
||||
Patch50: isl-rh2155127.patch
|
||||
|
||||
@ -862,6 +863,7 @@ so that there cannot be any synchronization problems.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr109230~
|
||||
|
||||
%patch50 -p0 -b .rh2155127~
|
||||
touch -r isl-0.24/m4/ax_prog_cxx_for_build.m4 isl-0.24/m4/ax_prog_cc_for_build.m4
|
||||
@ -3458,6 +3460,15 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Mar 21 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.9
|
||||
- update from trunk
|
||||
- PRs analyzer/109094, c++/106890, c++/109159, c++/109164, fortran/85877,
|
||||
fortran/87127, fortran/99036, fortran/109186, fortran/109206,
|
||||
fortran/109209, fortran/109216, libstdc++/109182, target/109067,
|
||||
target/109178, testsuite/108898, tree-optimization/109170,
|
||||
tree-optimization/109192, tree-optimization/109215,
|
||||
tree-optimization/109219
|
||||
|
||||
* Sat Mar 18 2023 Jakub Jelinek <jakub@redhat.com> 13.0.1-0.8
|
||||
- update from trunk
|
||||
- PRs analyzer/105906, analyzer/108045, analyzer/109097, c++/58538,
|
||||
|
51
gcc13-pr109230.patch
Normal file
51
gcc13-pr109230.patch
Normal file
@ -0,0 +1,51 @@
|
||||
2023-03-21 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR tree-optimization/109230
|
||||
* match.pd (fneg/fadd simplify): Verify also odd permutation indexes.
|
||||
|
||||
* gcc.dg/pr109230.c: New test.
|
||||
|
||||
--- gcc/match.pd.jj 2023-02-18 12:38:30.967022708 +0100
|
||||
+++ gcc/match.pd 2023-03-21 19:59:40.209634256 +0100
|
||||
@@ -8096,6 +8096,7 @@ and,
|
||||
scalar_mode inner_mode = GET_MODE_INNER (vec_mode);
|
||||
}
|
||||
(if (sel.series_p (0, 2, 0, 2)
|
||||
+ && sel.series_p (1, 2, nelts + 1, 2)
|
||||
&& GET_MODE_2XWIDER_MODE (inner_mode).exists (&wide_elt_mode)
|
||||
&& multiple_p (GET_MODE_NUNITS (vec_mode), 2, &wide_nunits)
|
||||
&& related_vector_mode (vec_mode, wide_elt_mode,
|
||||
--- gcc/testsuite/gcc.dg/pr109230.c.jj 2023-03-21 20:03:52.811979268 +0100
|
||||
+++ gcc/testsuite/gcc.dg/pr109230.c 2023-03-21 20:03:35.884224342 +0100
|
||||
@@ -0,0 +1,31 @@
|
||||
+/* PR tree-optimization/109230 */
|
||||
+/* { dg-do run } */
|
||||
+/* { dg-options "-O2 -Wno-psabi" } */
|
||||
+
|
||||
+#if __SIZEOF_FLOAT__ == __SIZEOF_INT__
|
||||
+typedef float V __attribute__((vector_size (4 * sizeof (float))));
|
||||
+typedef int VI __attribute__((vector_size (4 * sizeof (float))));
|
||||
+
|
||||
+__attribute__((noipa)) V
|
||||
+foo (V x, V y)
|
||||
+{
|
||||
+ V a = x - y;
|
||||
+ V b = y + x;
|
||||
+ return __builtin_shuffle (b, a, (VI) { 0, 5, 2, 3 });
|
||||
+}
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ V a = (V) { 1.0f, 2.0f, 3.0f, 4.0f };
|
||||
+ V b = (V) { 8.0f, 9.0f, 10.0f, 11.0f };
|
||||
+ V c = foo (a, b);
|
||||
+ if (c[0] != 9.0f || c[1] != -7.0f || c[2] != 13.0f || c[3] != 15.0f)
|
||||
+ __builtin_abort ();
|
||||
+}
|
||||
+#else
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+}
|
||||
+#endif
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-13.0.1-20230318.tar.xz) = 691f0d15e19fd89ca6003f443fe9363f9acbb57920869a51c1ecb4938d225f0c02502a74d6cd224464b68a8f420374e5f6d9685c37ecd936f82a9a1c27b15c79
|
||||
SHA512 (gcc-13.0.1-20230321.tar.xz) = 92031a51ab6c41d02e081d2013bf33f30a1b483fb4bf37349a683e71ee479dec877edb6e8735092326ed6e5c4081bb14d4be888a648fec948c11c58c06ced455
|
||||
SHA512 (isl-0.24.tar.bz2) = aab3bddbda96b801d0f56d2869f943157aad52a6f6e6a61745edd740234c635c38231af20bc3f1a08d416a5e973a90e18249078ed8e4ae2f1d5de57658738e95
|
||||
SHA512 (newlib-cygwin-9e09d6ed83cce4777a5950412647ccc603040409.tar.xz) = bef3fa04f7b1a915fc1356ebed114698b5cc835e9fa04b0becff05a9efc76c59fb376482990873d222d7acdcfee3c4f30f5a4cb7f3be1f291f1fa5f1c7a9d983
|
||||
SHA512 (nvptx-tools-472b6e78b3ba918d727698f79911360b7c808247.tar.xz) = 91690321bf96460c3b3e229199a6f752ed1c27c6933d4345dc7e237dc068f604ad211bb3a0373e14d4f332bee05b6227d6933e14e0b475ffdfea8b511ab735e6
|
||||
SHA512 (nvptx-tools-93e00909ceb9cbbc104f0fcba56c0361ffb3ca4b.tar.xz) = c719fad8689b2b6f3c888d0308604ddef884037d71ec3e755c68052d30075a181c29358fda516833ace437921b17602b147be7886317be94ec9736faa8cb52be
|
||||
|
Loading…
Reference in New Issue
Block a user