12.1.1-4
This commit is contained in:
parent
23a21fde25
commit
2615a533b8
1
.gitignore
vendored
1
.gitignore
vendored
@ -73,3 +73,4 @@
|
||||
/gcc-12.0.1-20220429.tar.xz
|
||||
/gcc-12.1.1-20220507.tar.xz
|
||||
/gcc-12.1.1-20220628.tar.xz
|
||||
/gcc-12.1.1-20220810.tar.xz
|
||||
|
37
gcc.spec
37
gcc.spec
@ -1,10 +1,10 @@
|
||||
%global DATE 20220628
|
||||
%global gitrev 874cb9452c56f1c3b3a7b5bfed93a262504b9856
|
||||
%global DATE 20220810
|
||||
%global gitrev c66b9ee42a4ecd9d14f9724bf0a26019326edf0a
|
||||
%global gcc_version 12.1.1
|
||||
%global gcc_major 12
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %%{release}, append them after %%{gcc_release} on Release: line.
|
||||
%global gcc_release 3
|
||||
%global gcc_release 4
|
||||
%global nvptx_tools_gitrev 5f6f343a302d620b0868edab376c00b15741e39e
|
||||
%global newlib_cygwin_gitrev 50e2a63b04bdd018484605fbb954fd1bd5147fa0
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
@ -125,7 +125,7 @@
|
||||
Summary: Various compilers (C, C++, Objective-C, ...)
|
||||
Name: gcc
|
||||
Version: %{gcc_version}
|
||||
Release: %{gcc_release}%{?dist}.1
|
||||
Release: %{gcc_release}%{?dist}
|
||||
# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
|
||||
# GCC Runtime Exception.
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
|
||||
@ -275,8 +275,6 @@ Patch8: gcc12-no-add-needed.patch
|
||||
Patch9: gcc12-Wno-format-security.patch
|
||||
Patch10: gcc12-rh1574936.patch
|
||||
Patch11: gcc12-d-shared-libphobos.patch
|
||||
Patch12: gcc12-pr105551.patch
|
||||
Patch13: gcc12-libtsan-s390x.patch
|
||||
|
||||
Patch100: gcc12-fortran-fdec-duplicates.patch
|
||||
Patch101: gcc12-fortran-flogical-as-integer.patch
|
||||
@ -804,8 +802,6 @@ so that there cannot be any synchronization problems.
|
||||
%patch10 -p0 -b .rh1574936~
|
||||
%endif
|
||||
%patch11 -p0 -b .d-shared-libphobos~
|
||||
%patch12 -p0 -b .pr105551~
|
||||
%patch13 -p0 -b .libtsan-s390x~
|
||||
|
||||
%if 0%{?rhel} >= 9
|
||||
%patch100 -p1 -b .fortran-fdec-duplicates~
|
||||
@ -3217,8 +3213,29 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 12.1.1-3.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
* Wed Aug 8 2022 Jakub Jelinek <jakub@redhat.com> 12.1.1-4
|
||||
- update from releases/gcc-12 branch
|
||||
- PRs analyzer/105285, analyzer/106204, analyzer/106225, c++/53164,
|
||||
c++/96363, c++/100374, c++/105541, c++/105626, c++/105634, c++/105637,
|
||||
c++/105758, c++/105842, c++/105848, c++/105912, c++/106024,
|
||||
c++/106102, c++/106230, c++/106311, c++/106361, d/106139, d/106555,
|
||||
d/106563, debug/106261, fortran/101330, fortran/103137,
|
||||
fortran/103138, fortran/103504, fortran/103693, fortran/104313,
|
||||
fortran/105243, fortran/105691, fortran/105813, fortran/105954,
|
||||
fortran/106121, libfortran/106079, libstdc++/88881, libstdc++/100823,
|
||||
libstdc++/104443, libstdc++/105844, libstdc++/105880,
|
||||
libstdc++/105957, libstdc++/105995, libstdc++/106162,
|
||||
libstdc++/106248, lto/106129, middle-end/105965, middle-end/106027,
|
||||
middle-end/106144, middle-end/106331, middle-end/106449,
|
||||
preprocessor/97498, rtl-optimization/105041, rtl-optimization/106032,
|
||||
target/103722, target/105459, target/105930, target/105991,
|
||||
target/106091, target/106097, target/106122, testsuite/106345,
|
||||
tree-optimization/105665, tree-optimization/105860,
|
||||
tree-optimization/105946, tree-optimization/105969,
|
||||
tree-optimization/105971, tree-optimization/106063,
|
||||
tree-optimization/106087, tree-optimization/106112,
|
||||
tree-optimization/106114, tree-optimization/106131,
|
||||
tree-optimization/106189
|
||||
|
||||
* Thu Jun 30 2022 Jakub Jelinek <jakub@redhat.com> 12.1.1-3
|
||||
- fix up libtsan on s390x
|
||||
|
@ -1,17 +0,0 @@
|
||||
commit r12-8527-g7811663964aa7e31c3939b859bbfa2e16919639f
|
||||
Author: Martin Liska <mliska@suse.cz>
|
||||
Date: Wed Jun 29 15:28:07 2022 +0200
|
||||
|
||||
libsanitizer: cherry-pick 791e0d1bc85d
|
||||
|
||||
791e0d1bc85d: [compiler-rt] Add NO_EXEC_STACK_DIRECTIVE on s390x
|
||||
(cherry picked from commit aa87b7541b4c11f59c521154513f844ea6b5c977)
|
||||
|
||||
--- libsanitizer/tsan/tsan_rtl_s390x.S
|
||||
+++ libsanitizer/tsan/tsan_rtl_s390x.S
|
||||
@@ -45,3 +45,5 @@ intercept setjmp, _ZN14__interception11real_setjmpE
|
||||
intercept _setjmp, _ZN14__interception12real__setjmpE
|
||||
intercept sigsetjmp, _ZN14__interception14real_sigsetjmpE
|
||||
intercept __sigsetjmp, _ZN14__interception16real___sigsetjmpE
|
||||
+
|
||||
+NO_EXEC_STACK_DIRECTIVE
|
@ -1,28 +0,0 @@
|
||||
2022-05-11 Richard Biener <rguenther@suse.de>
|
||||
|
||||
PR bootstrap/105551
|
||||
* opts.cc (finish_options): Also disable var-tracking if
|
||||
!DWARF2_DEBUGGING_INFO.
|
||||
|
||||
--- gcc/opts.cc
|
||||
+++ gcc/opts.cc
|
||||
@@ -1334,11 +1334,15 @@ finish_options (struct gcc_options *opts, struct gcc_options *opts_set,
|
||||
|| opts->x_flag_selective_scheduling2));
|
||||
|
||||
/* We know which debug output will be used so we can set flag_var_tracking
|
||||
- and flag_var_tracking_uninit if the user has not specified them. Note
|
||||
- we have not yet initialized debug_hooks so we might uselessly run
|
||||
- var-tracking on targets without var_location debug hook support. */
|
||||
+ and flag_var_tracking_uninit if the user has not specified them. */
|
||||
if (opts->x_debug_info_level < DINFO_LEVEL_NORMAL
|
||||
- || !dwarf_debuginfo_p (opts))
|
||||
+ || !dwarf_debuginfo_p (opts)
|
||||
+ /* We have not yet initialized debug hooks so match that to check
|
||||
+ whether we're only doing DWARF2_LINENO_DEBUGGING_INFO. */
|
||||
+#ifndef DWARF2_DEBUGGING_INFO
|
||||
+ || true
|
||||
+#endif
|
||||
+ )
|
||||
{
|
||||
if ((opts_set->x_flag_var_tracking && opts->x_flag_var_tracking == 1)
|
||||
|| (opts_set->x_flag_var_tracking_uninit
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (gcc-12.1.1-20220628.tar.xz) = e047dd9500dccbdc1fb8f26e5fc1f1b03eaf63b5c04344f9b7a23e1467a397b1eabcb49e344be06b6881505be584c85e123ce294b5f5605fcb5a6740dabba383
|
||||
SHA512 (gcc-12.1.1-20220810.tar.xz) = dffb7d9b2de89a47ad29533d0b467ffc26d094b1e6eab0b019c5ea5cd06f7766f912a7c38ca8e046516c5bcb50424d6b51b47e5b4f93ef4fc8cec56e37f1d6f5
|
||||
SHA512 (isl-0.18.tar.bz2) = 85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94
|
||||
SHA512 (newlib-cygwin-50e2a63b04bdd018484605fbb954fd1bd5147fa0.tar.xz) = 002a48a7b689a81abbf16161bcaec001a842e67dfbe372e9e109092703bfc666675f16198f60ca429370e8850d564547dc505df81bc3aaca4ce6defbc014ad6c
|
||||
SHA512 (nvptx-tools-5f6f343a302d620b0868edab376c00b15741e39e.tar.xz) = f6d10db94fa1570ae0f94df073fa3c73c8e5ee16d59070b53d94f7db0de8a031bc44d7f3f1852533da04b625ce758e022263855ed43cfc6867e0708d001e53c7
|
||||
|
Loading…
Reference in New Issue
Block a user